New "Windows 11 ready" BIOS updates for Z590 boards

peshirley159802e0

New member
Joined
Feb 12, 2022
Messages
15
So I'm not sure where it got corrupted or how it even let me use a corrupted bios file bit anyways After doing a hard power reset and unplugging switch 2 O and 3min of waiting and finally the option to enable IGP was available because before it wasn't there, Flash issue I guess But it's all back and running perfectly, no help from anyone but that's how it is when a black man enters a group that's majority opposite ethicnicity... Thanks anyways and hope everyone has a peaceful Saturday, back 2 managing my 4 120TH ASIC miners 🧠🧠✅️
 
Last edited by a moderator:

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
7,850
no help from anyone but that's how it is when a black man enters a group that's majority opposite ethicnicity...
That's ridiculous. You posted your initial message that i somewhat struggled to understand. I replied that i have the setting available and i thus couldn't reproduce the problem. When there isn't any further reply about your problem within one hour, you then post this statement, basically suggesting racism as the cause...??

Look man, we don't see your race, color or ethnicity here on the forum, we only see what you post. And very rarely do things get solved here within an hour, a lot of the time we're talking at least a couple hours or a day of back-and-forth replies. So that claim is completely baseless and only reveals something about your character, not about this forum.
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
9,152
So I'm not sure where it got corrupted or how it even let me use a corrupted bios file bit anyways After doing a hard power reset and unplugging switch 2 O and 3min of waiting and finally the option to enable IGP was available because before it wasn't there, Flash issue I guess But it's all back and running perfectly, no help from anyone but that's how it is when a black man enters a group that's majority opposite ethicnicity... Thanks anyways and hope everyone has a peaceful Saturday, back 2 managing my 4 120TH ASIC miners 🧠🧠✅️
Racial comments and sleures will not be tolerated nor will any racism of any kind this is a global Forum filled with people from all over the world.

And this is the first Racist comment I have seen no one in here cares what you look like or what your sex is or if your Pink, yellow, blue, green, of white or black or any colour you happen to be.


Please read the Forum Rules>>Please read and comply with the Forum Rules.<<
 
Last edited:

peshirley159802e0

New member
Joined
Feb 12, 2022
Messages
15
I'm sorry I mean you guys aren't of any help, and yes I can easily say I feel discriminated against based off the lack of information that was provided for a solution and the fact that a mod called me a Dick in another thread... Not even abiding by your own rule of deragoty terms being directed towards a user... And he's a mod!! But quite frankly my issue is solved and I no longer feel the need to waste my time on a forum so thanks for your opinions and I wish yall the best of moderation!! Maybe don't call new users a Dic* and new users won't feel discriminated... Did that thought ever cross your mind while targeting me (clearly) and not the person calling new users A Dic*
 

peshirley159802e0

New member
Joined
Feb 12, 2022
Messages
15
Discrimination isn't just Racial comments my friend, maybe update the rules to a more Equal level where mods have to abide by the same rules and can't call new users a D for knowing something isn't right and going to the only educated area where I can find a solution to be called a Dic*.... How would you feel moderator... or better yet step outta your shoes and see it from my POV
 

peshirley159802e0

New member
Joined
Feb 12, 2022
Messages
15
You're not right or wrong in this situation, but some of your Mods also aren't presenting the forum in a professional manor by calling a New user a Dick, once you understand that then maybe you'll see why I made the comments I did, You can't expect me to show respect for someone who disrespected me... You can ban me etc, won't change how mods approached my question by calling me a Dick!
 

darkhawk

Well-known member
Global Moderator
Joined
Nov 20, 2012
Messages
14,229
No, we called you a dick for posting in inappropriate ways and manners, and generally just not being a good person.
I'll gladly do that, like it or not. Is it a little rude? Sure.....is it more rude than arguing constantly, making inappropriate troll and flaming posts, and then trying to play off being the victim? No.
Learn to be a better human being to others. It's really that simple. Everyone here is just a user, just like you.
 

Obscure

High-Tech Redneck
PRIVATE E-2
Joined
Feb 16, 2015
Messages
45
Finally had time to sit down and give this new bios a go, and so far, everything seems to be working fine.
Other than the few typos that have been pointed out by others, I don't see any major issues with it.
I call it a keeper.

On a side note....
In the 8 years I have been frequenting these forums, I have never seen anyone treated differently based on race or sex.
In fact, no one here can see through the internet to even know these things unless you bring them up in the exchange.

When challenges occur in life, it’s easy to let your emotions get the best of you and assume that the world is out to get you.
It’s okay to have a pity party now and then. However, if it gets out of hand, it’s easy to start floundering in victimhood.

It is impossible to be the driver of your life if all you do is play the victim card.
In my opinion, this is the fastest way to lose your power.

You have two choices—believe that life is happening for you or to you.

Peace
Obscure
 
Last edited:

echoE

Member
Joined
Oct 29, 2021
Messages
85
Interesting. I see no bios update for the MSI Z590 Gaming plus other then the one back in 2021-09-13 . I remember some time in Jan there was a LED Firmware within MSI Center. But no Bios update. I checked my CPU MCU 44. I see there no bios update. In MSI Center though for other MSI 590's boards such as the Z590 PRO Wifi that has a bio update as of last month. I wonder if Other Z590's board will get the same update? At least the Adjusting PCIe Lanes settings for the MSI Z590 Gaming Plus?

Only for MSI 590 PRO WIFI

Version
7D09v14
Release Date
2022-01-12

- Update CPU Microcode
- Adjust PCIe Lanes setting
 
Last edited:

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
7,850
Yeah, the Z590 GAMING PLUS should get the update soon as well. I'd say within one or two weeks (from previous experience). It's really easy to adapt the BIOS to the different Z590 models once it's finished overall. The release date on the support site is always backdated, i think they mean when the BIOS was finished or something. Cause it certainly isn't the date when it was released to the public.
 

echoE

Member
Joined
Oct 29, 2021
Messages
85
Yeah, the Z590 GAMING PLUS should get the update soon as well. I'd say within one or two weeks (from previous experience). It's really easy to adapt the BIOS to the different Z590 models once it's finished overall. The release date on the support site is always backdated, i think they mean when the BIOS was finished or something. Cause it certainly isn't the date when it was released to the public.
I wouldn't know. All I know is I saw this thread. And look at it. And thought to myself odd that so many motherboards has a bios update in early last month. Yet the Z590 Gaming plus haven't had a bios update like the rest of the z590s family. I do hope it comes at some point this month like you said. Just seems odd that all the other ones have the same exact date it was posted up to be for them boards yet the z590 gaming plus no post there.

By the way. What exactly did they do with Adjust PCIe Lanes setting? I know what lanes is such as x16 x8 x4 x1 if that what there speaking of. Though how exactly was it adjusted? Any info on that if you may have anything in regards of that?
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
7,850
They released the BIOS for many Z590 boards exactly five days ago. As i said, they backdate the release date. But it's only been available to the public for less than a week. So don't feel like you've been missing out for over a month, it's only been days. When they put it up for your board model, you can be sure that it will also be backdated the same. I'm not sure about the PCIe lanes thing, i currently don't even have a graphics card (long story).
 

echoE

Member
Joined
Oct 29, 2021
Messages
85
They released the BIOS for many Z590 boards exactly five days ago. As i said, they backdate the release date. But it's only been available to the public for less than a week. So don't feel like you've been missing out for over a month, it's only been days. When they put it up for your board model, you can be sure that it will also be backdated the same. I'm not sure about the PCIe lanes thing, i currently don't even have a graphics card (long story).
Ohh ok. Thanks for clearing it up now I know what you mean. Thanks man. :)
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
7,850
There's a new stable BIOS out for the Z590 boards as of today, changelog: "Update Intel Micro code for security vulnerabilities" (we know they always fix more behind the scenes though).

I've just installed it on my MPG Z590 GAMING FORCE and i'm happy to report that the bugs mentioned here seem to be fixed now.
Intel microcode update (MCU) version went from 50 to 53.
Stability seems to be the same as on the previous version, that is, if set up properly, it's completely stable.

Furthermore, there are reports that this new BIOS improves/fixes the RAM support when using four modules and enabling XMP. So for anyone with a Z590, this might work better than the last BIOS.
 

mnemonic

Member
Joined
Dec 26, 2021
Messages
93
I have updated my z590 tomahawk wifi with the new .25 bios and everything seems in order. I could even straight boot after enabling XMP without having to press the reset because of a boot hang it had with older bios. So everything seems in order now, only the auto voltage of vccsa and vccio2 are still the same too high after enabling XMP. Without xmp the voltages are in the 0.9 range and with xmp and auto voltage it returns to 1.59 and 1.37 for vccsa and vccio2 so i tuned them manually again to 1.2 and 1.15 volts respectively. All in all this seems like a good and hopefully golden one.
Microcode 53 is also good to have with this. Thanks for the heads up Citay.
 

doug.hogart153b02d9

Active member
Joined
Nov 9, 2021
Messages
158
I had two bad experiences with this update from .24 to .25 on my Tomahawk WiFi. One is that CPU Fan PWM Smart got two weird first points of 0C=20% and 20C=20%. Second is that I got the dreaded Win11Pro activation problem which has been mentioned by others with recent MSI BIOS updates. .24 had been activated with a digital license linked to my Microsoft account. .25 says not activated and the troubleshooter "I changed my hardware on this device recently" does not show that PC as one of my licenses. My guess is it might be related to how MSI disables the secure boot and enabling requires enrolling keys again.
 

mnemonic

Member
Joined
Dec 26, 2021
Messages
93
I had two bad experiences with this update from .24 to .25 on my Tomahawk WiFi. One is that CPU Fan PWM Smart got two weird first points of 0C=20% and 20C=20%. Second is that I got the dreaded Win11Pro activation problem which has been mentioned by others with recent MSI BIOS updates. .24 had been activated with a digital license linked to my Microsoft account. .25 says not activated and the troubleshooter "I changed my hardware on this device recently" does not show that PC as one of my licenses. My guess is it might be related to how MSI disables the secure boot and enabling requires enrolling keys again.
You are right, something is off with the bios fan settings, the values don't seem to correlate, i think the graph lines are reversed where temp should be fan speed percentage and vice versa.
With win 11 activation i had no problem, yes windows asked for the password again to verify the account but it went smooth without a hitch.
And yes , after a bios update you HAVE to set every option in your bios again the way they were or how you had them set, just the same as if you were booting a new system for the first time.
All settings get wiped to default with a bios update, so yes also the secure keys and all that. But when set right, it all works without a problem. Boot windows, it asks for verification to check it is really you (when using a microsoft account) and off you go as if nothing happened.
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
7,850
For me, the fan curves behave normally on the new BIOS. No problems with the Windows license either.

What i do after a BIOS update in regards to Secure Boot is what i mention here (from memory, hope i didn't forget something):
- Go to Settings\Security\Secure Boot
- Set it to [Enabled], it will tell you to "Enroll keys" first, so Enroll keys (maybe you can enroll keys straight away). It will ask you to reboot without saving, confirm.
- Enter the BIOS, now you can set it to [Enabled]. It wants a reboot again.
- Enter the BIOS, now you can set it from [Custom] to [Standard]. Done.

Then i set everything else, and only when i'm finished, i boot Windows. I don't get a prompt from Windows about any issue.
 

mnemonic

Member
Joined
Dec 26, 2021
Messages
93
For me, the fan curves behave normally on the new BIOS. No problems with the Windows license either.

What i do after a BIOS update in regards to Secure Boot is what i mention here (from memory, hope i didn't forget something):
- Go to Settings\Security\Secure Boot
- Set it to [Enabled], it will tell you to "Enroll keys" first, so Enroll keys (maybe you can enroll keys straight away). It will ask you to reboot without saving, confirm.
- Enter the BIOS, now you can set it to [Enabled]. It wants a reboot again.
- Enter the BIOS, now you can set it from [Custom] to [Standard]. Done.

Then i set everything else, and only when i'm finished, i boot Windows. I don't get a prompt from Windows about any issue.
But are you using a microsoft account to run windows or just a local account?
My windows 11 complained about the hello pincode no longer being valid, probably to do with it's storage in the tpm, which gets wiped with a bios flash probably, like every other setting.
So on boot it needs to check in again with Microsoft to see if it is legit. This would not happen if you are not using a Microsoft account. This is quite normal behaviour.
Another possible reason for rechecking the license is when you are using Virtualization based security functions of windows.
 
Top