Optix MAG321CQR: power button lit and input detected but no screen at all

treydb015a702e2

New member
Joined
Jul 2, 2022
Messages
1
A bit of info to add to the title, its an MAG321. I was using the back button to mess w/ the brightness and then the entire screen power went out mid game. I know its detecting input because the when I hook it back up to my pc w/ dvi the light stays solid, and the same thing w/ a normal hdmi with a fire stick. I've checked for any sort of light at all w/ a flashlight and to my understanding a completely off screen indicates the issue might not be the backlight. I have literally no clue what happened, not even the slightest of signs that there was any problem w/ the monitor prior. ive spent a stupid amount of hours in the past day trying everything to fix it and Im really just hoping for any extra suggestions before I subject myself to 2 months of waiting for RMA :( I spoke w/ the support and they basically just checked my serial number and told me to ship it lol

Thanks foryour time and any suggestions!
 

elafranc43b7062a

New member
Joined
Aug 2, 2020
Messages
14
A bit of info to add to the title, its an MAG321. I was using the back button to mess w/ the brightness and then the entire screen power went out mid game. I know its detecting input because the when I hook it back up to my pc w/ dvi the light stays solid, and the same thing w/ a normal hdmi with a fire stick. I've checked for any sort of light at all w/ a flashlight and to my understanding a completely off screen indicates the issue might not be the backlight. I have literally no clue what happened, not even the slightest of signs that there was any problem w/ the monitor prior. ive spent a stupid amount of hours in the past day trying everything to fix it and Im really just hoping for any extra suggestions before I subject myself to 2 months of waiting for RMA :( I spoke w/ the support and they basically just checked my serial number and told me to ship it lol

Thanks foryour time and any suggestions!
Can you access the monitor menu? If so you could try resetting the monitor under the settings menu.
Also make sure the cable to the monitor or the PC isn't slightly loose
Lastly make sure that the PC isn't the issue by connecting it to a TV or some other display.
 

darkhawk

Well-known member
Global Moderator
Joined
Nov 20, 2012
Messages
14,242
Most likely, shipping the monitor back is the best option.....
However.....

If you haven't already tried it, unplug the power from the monitor and let it sit for about 10 minutes, and then plug it back in and see if it works.
I have an older MAG272CQR, and occasionally (like, once every 3 to 6 months maybe) the same thing happens, and it just won't detect anything even though the monitor is detected. I generally just remove power from it for a little bit, and plug it back in and it's good for a while.
 

elafranc43b7062a

New member
Joined
Aug 2, 2020
Messages
14
Any updates? I’m have the same problem right now
I had the same monitor, bought 2 of them... It might be best to check with warranty if there is no display. When flashing on and off sometimes could be display cable even if no display, could also be wrong display input selected or too high a refresh rate or invalid refresh / resolution. Or could be a warranty issue...
If you can access the monitor menu try resetting the display to factory
 
Top