OPTIX MAG322CQR usb and displayport troubles

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
When connecting the usba to b cablel from my OPTIX MAG322CQR to pc In the divice manager it wil say in a few seconds "unknow usb device"
Is there a way to fix this and why is there no driver or firmware update.
Because there are more problems.
Example if using the display port. everytime i'm turn off the monitor power it will remove itself from the divicemangager (standard monitor) very annoying special if you use multible monitors and want to use mag322 as your main monitor. Something if using hdmi not happen.
My pc win 10 pro system has a 98th percentile passmark reading. Thing should be going smoothly.


kind regards
 

zerijelly

Member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
517
Could I know how many monitors are connected? And the system / laptop and graphic card which the monitor connects to?
 

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
Thx for your reply zerijelly.

On the moment i got 2 monitors going tho i want to expand to 4 if this displayport issue get solved otherwise i'm stuck with 3 max.
My system,
Motherbord asrockx570 phantom gaming x, processor AMD ryzen 7 3800xt, mem 32GB 3200, grafiks Sapphire Radeon RX 580 8GB NITRO+
OS Win10pro

Kind regards
 

zerijelly

Member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
517
Have you tried with different USB ports? Have the USB driver being updated to the latest version?
Could you connect the USB cable to the USB ports on another system / laptop to try?
 
Last edited:

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
Yes all is up to date and other usb poort make no difference this problem was the same on my old system. I didn't associated the usb problem with mag322 at that time. tho when creating my new system i noticed again a usb problem and track it down to the usba to b connection from my mag322.
 

zerijelly

Member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
517
Could you provide screenshot of the Unknown USB device in device manager?
And please help to specify the firmware version of the monitor on the bottom right side of OSD menu as screenshot shows.
As you state that after powering off monitor, there would be device being removed from device manager, could you identify which device being remove at that moment?
It is Human Interface Devices, Monitors or Universal Serail Bus controllers?
 

Attachments

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
Firmware version for the monitor is FW.008
I was mistaken about the monitor being removed. Turning off the monitor give a bleeping sound which you hear if you remove a device, In turning off the monitor i assosiated it such. Tho i now see it only removed the foulty usb device .
As far i see the only problem is this foulty usb device.

appbeheer.png
 

zerijelly

Member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
517
If the monitor could display normally after power back on the monitor, the disconnection sound of USB would not interfere the functionality.
 

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
I know but something is not right windows 10 not recognize your usb because the unknow usb device.
I talk about it with windows support but they say it's not their fault it's the vendors..

The problem is the same on my old MB an asus intel i7. Because the problem is on two complete different MB's it isn't in the Universal Serial Bus-controllers software. In my experience with other usb hubs with the same problem (usually with only win7 certification Trying to make it work on Win 10) those hubs worked wel for some time but a few windows updates later they stopped and were useless.

This mean my monitor is in need of a firmware update to solve this yellow exclamation mark. True The gamingosd software still works even with the yellow exclamation mark and usb still works The only concern i have is when windows comes in the future with an update things will stop to work like it always happen.

If i disconnect the usb a to b cable all problems are solved no more yellow exclamation marks.

Only thing i can't use the usb and Gamingosd software anymore.

Kind regard
 

RaidenFox

New member
Joined
Sep 23, 2020
Messages
2
I have the exact same problem. Bought a new MSI MAG272QP today and trying to figure all day why the USB is giving the exact same error as above in the device manager. I tested this on 2 compleetly different machines with the same result as error from the included USB Type B to USB type A cable. As a result i cant use the MSI Gaming OSD 2.0 app because its giving alwas this error: Please make sure of the USB is connecting to use the application. They are 100% connected and testen on differect USB ports, removed USB drivers and try to look for new drivers but it cant find anything. very weird. Would gladly see the solution to this issue
 

Attachments

fauc

Member
SECOND LIEUTENANT
Joined
Nov 21, 2019
Messages
252
1.Please press "Redetect" button on GAMING OSD.
2.Please use another USB Type B to USB type A cable for checking.
 

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
An other usb type b to a cable didn't change things.
could you tell me where to find this redetect button on the Gaming OSD
I can't find it on msi gaming osd 2.0
 

RaidenFox

New member
Joined
Sep 23, 2020
Messages
2
The "Redecect" button (in the Gaming OSD app -> see screenshot) does not do anything, pressed it multiple times but the app just keep saying the same message like in the screenshot. also reinstalled the app a couple of times.
Kinda weird that people have the same issue on different monitors over different machines, is there maybe a USB driver fix for this? It could be once this failt USB connection in the divice managers is fixed that issue will resolve?
 

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
I Only get the Redetect button wenn i take out the usb a/b cable. But than the button does nothing
If i connect the cable again the button disappear. Looks like the button is faulty too and Mathias i was thinking the same, a driver fix or a firmware update.
I would also like to see the monitor named in monitors. It's a specilized gaming monitor not a standaard monitor.
Tho most important device manager says all divices and drivers are 100% ok without yellow exclamation marks.
This will give me a peace of mind.
 

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
After a new update for my amd cpu the problem looks like solved. There is no yellow exclamation mark more. Thx for your time and help
 

mtgr71

New member
PRIVATE E-2
Joined
Mar 14, 2020
Messages
11
Ok I cheered to soon. Problem is still there tho i now have good suspicious the problem is caused by the video card. When i changed the card to an old one. All seems ok.
 
Top