PRO Z690-A DDR4/WIFI Owners Thread

ari.clar157b02e1

New member
Joined
Mar 16, 2022
Messages
3
I'd guess that you aren't realizing that you need two drivers (both end up under Network adapters in Device Manager when complete). One for the wired ethernet (which is sounds like you got), and another for the Wi-Fi (AX211). Download them either from MSI Support or Intel Support. Alternatively if you've got one and connect to internet, Windows Update can typically get the other one.
The network adapters drivers I’ve got are:

Bluetooth Device (Personal Area Network)
Intel(R) Ethernet Controller (3) I225-V
WAN Miniport (IKEv2)
WAN Miniport (IP)
WAN Miniport (IPv6)
WAN Miniport ((L2TP)
WAN Miniport (Network Monitor)
WAN Miniport (PPPOE)
WAN Miniport (PPTP)
WAN Miniport (SSTP)

All are up to date. Is there anything critical I’m missing?
 

doug.hogart153b02d9

Active member
Joined
Nov 9, 2021
Messages
176
All are up to date. Is there anything critical I’m missing?
You are missing Intel(R) Wi-Fi 6E AX211 160MHz, which after installation will appear above all those WAN Miniports.
You need to install that driver in one of the three ways I described, for the device which might be temporarily showing up as a yellow exclamation mark somewhere else in Device Manager.
 

ari.clar157b02e1

New member
Joined
Mar 16, 2022
Messages
3
You are missing Intel(R) Wi-Fi 6E AX211 160MHz, which after installation will appear above all those WAN Miniports.
You need to install that driver in one of the three ways I described, for the device which might be temporarily showing up as a yellow exclamation mark somewhere else in Device Manager.
Cheers thanks, annoying that that driver is missing from the driver disc that came with the mobo and windows updates seem to be wiffing on it too. Will look it up when I’m home later
 
Joined
Jan 23, 2022
Messages
48
Folks,
this damn board doesn't behave. With the original bios, under windows it wouldn't sleep. Bios upgraded to the successive release. Then it slept, but it wouldn't restart (stuck at "restarting"). Pressing the reset button made it turn off the whole computer just for an instant, then turn on again (like it happens sometimes when you change important bios setting.. power cycle). I never observed such a behavior in a reset button.
Upgraded to a beta bios.. now it restarts again, but again it doesn't sleep.

Do I have a failed board?
 
Joined
Dec 16, 2021
Messages
46
Folks,
this damn board doesn't behave. With the original bios, under windows it wouldn't sleep. Bios upgraded to the successive release. Then it slept, but it wouldn't restart (stuck at "restarting"). Pressing the reset button made it turn off the whole computer just for an instant, then turn on again (like it happens sometimes when you change important bios setting.. power cycle). I never observed such a behavior in a reset button.
Upgraded to a beta bios.. now it restarts again, but again it doesn't sleep.

Do I have a failed board?
I changed the settings on the sleep functions in windows - less of a problem now.
 

gerardfraser

Member
SERGEANT
Joined
Feb 26, 2009
Messages
106
After 5 months and no problems still the best settings for me.
Keep single threaded performance for high CPU clocks set.
Heavy workloads set to 75°C to drop CPU clock to default settings on 12900K.You can change the 75°C to higher number to keep full default performance on a Cinebench load.
You still have to test your own personal settings.

My BIOS Settings for 5400Mhz Pc Gaming

Forza Horizon 5 12900K Overclock 5500Mhz 4K HDR PC Gameplay New RTSS Gauges
Forza Horizon 5 12900K Overclock 5500Mhz 4K HDR PC Gameplay New RTSS Gauges - YouTube

Cyberpunk 2077 12900K Overclock 5500Mhz 4K HDR PC Gameplay New RTSS Overlay Gauges
Cyberpunk 2077 12900K Overclock 5500Mhz 4K HDR PC Gameplay New RTSS Overlay Gauges - YouTube

Far Cry 6 12900K OverClock 5500Mhz
Far Cry 6 12900K OverClock 5500Mhz RTSS OSD New Gauges - YouTube

Star Wars Jedi Fallen Order 4K HDR 12900K Overclock 5500Mhz
Star Wars Jedi Fallen Order 4K HDR 12900K Overclock 5500Mhz - YouTube

Call of Duty Black Ops Cold War 4K HDR PC Gameplay 12900K Overclock 5400Mhz
Call of Duty Black Ops Cold War 4K HDR PC Gameplay 12900K Overclock 5400Mhz - YouTube

Marvel's Avengers War For Wakanda 4K HDR PC Gameplay 12900K Overclock 5400Mhz
Marvel's Avengers War For Wakanda 4K HDR PC Gameplay 12900K Overclock 5400Mhz - YouTube

Mirror's Edge Catalyst 4K HDr 12900K Overclock 5400Mhz
Mirror's Edge Catalyst 4K HDr 12900K Overclock 5400Mhz - YouTube

Watch Dogs Legion 4K HDR PC Gameplay Ray Tracing 12900K Overclock 5400Mhz
Watch Dogs Legion 4K HDR PC Gameplay Ray Tracing 12900K Overclock 5400Mhz - YouTube

Crysis Remastered 12900K Overclock 5400Mhz 4K HDR Can it Run Crysis
Crysis Remastered 12900K Overclock 5400Mhz 4K HDR Can it Run Crysis - YouTube

Bright Memory Infinite 12900K Overclock 5400Mhz Ray Tracing 4K HDR
Bright Memory Infinite 12900K Overclock 5400Mhz Ray Tracing 4K HDR - YouTube

Hellblade Senua's Sacrifice 12900K Overclock 5400Mhz HDR PC Gameplay Ray Tracing
Hellblade Senua's Sacrifice 12900K Overclock 5400Mhz HDR PC Gameplay Ray Tracing - YouTube

Call of Duty Modern Warfare 12900K Overclock 5400Mhz
Call of Duty Modern Warfare 12900K Overclock - YouTube

Immortals Fenyx Rising 4K HDR PC Gameplay 12900K Overclock 5400Mhz
Immortals Fenyx Rising 4K HDR PC Gameplay 12900K Overclock 5400Mhz - YouTube

Red Dead Redemption 2 4K HDR PC Gameplay 12900K Overclock 5400Mhz
Red Dead Redemption 2 4K HDR PC Gameplay 12900K Overclock - YouTube

Shadow of the Tomb Raider 12900K 5400Mhz Enermax LIQMAX III 360 ARGB

Shadow of the Tomb Raider 12900K 5500Mhz Air Cooled
 

SmiimS

New member
Joined
Mar 1, 2022
Messages
20
Mine has some. It's stronger with the 'high performance' power profile on Windows or the 'performance' CPU governor on Linux.
Also, it increased when I tried the 'washer mod' to check out if temperatures would decrease somewhat.
 
Joined
Jan 23, 2022
Messages
48
Mine has some. It's stronger with the 'high performance' power profile on Windows or the 'performance' CPU governor on Linux.
Also, it increased when I tried the 'washer mod' to check out if temperatures would decrease somewhat.
That's the first time ever that I hear coil whine from a damn motherboard...! I'm quite disappointed.
 

SmiimS

New member
Joined
Mar 1, 2022
Messages
20
I had an Aorus B560 motherboard for an 11700K earlier on, and it was much worse. It depends partially on luck and partially on the notion that modern CPUs tend to run on a "race-to-halt" basis, i.e. repeatedly switch at a high frequency from a low power state to a high power state, especially if you're not using dynamic frequencies (but still use C-states).

This is not necessarily a motherboard-specific issue. There can be differences from unit to unit, like with GPUs.
 
Joined
Jan 23, 2022
Messages
48
I had an Aorus B560 motherboard for an 11700K earlier on, and it was much worse. It depends partially on luck and partially on the notion that modern CPUs tend to run on a "race-to-halt" basis, i.e. repeatedly switch at a high frequency from a low power state to a high power state, especially if you're not using dynamic frequencies (but still use C-states).

This is not necessarily a motherboard-specific issue. There can be differences from unit to unit, like with GPUs.
Understood, but other motherboards behave with no coil whine with the same CPUs. And, IMHO, differences among specimens of the same model is just bad QC. :(
 

zerijelly

Well-known member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
1,064
Hello, i bought 2 days ago this mobo ( msi pro z690 a ddr4 wifi) and i have a big problem with ethernet connection. There is no ethernet cable detected, like i had no cable connected, and when i go in device manager at adapter options there is nothing. I tried to update bios to latest version ( 7D25v128 ) and didn t work. I tried to update Intel Network drivers but i get an error "
No intel adapters are presented in this computer" . I also tried to download from another pc and set it up by device manager but also didn t work. Please help me, i try for 16H to solve this in so many ways and tried to search on all forums and nothing literally worked. Thank you.
Have you updated BIOS to the latest 7D25v131 to check?
 
Joined
Dec 16, 2021
Messages
46
Have you updated BIOS to the latest 7D25v131 to check?
Trying - access bios and try to use M flash - it does not have me select the source for the new bios file. Select M flash in the bios settings and the PC restarts but then does "nothing" - I gave it about 5 minutes to "do something". Restarted - it exit M flasah, bios screen came up - still old bios setting - hit f10 and restarted PC. Tried th
 

aldavia157c02db

New member
Joined
Mar 26, 2022
Messages
1
I'm running bios 1.10 from 12/13/2021

and my pc often doesn't reboot properly after using it for hours. It hangs.
But if a reboot, and reboot again shortly after, it restarts fine.

weird. anyone else have this issue with this bios?

I really don't feel like upgrading the bios, because the newer bioses disable avx512
I am having the exact same issue using a 12700K processor and 3060TI with 2x8Gb Crucial Ballistix at 3200Mhz..
Everything else is behaving perfectly, but I identified the restart issue the first time I installed an update in Windows 10, after selecting the "Update and restart" option the computer shut down but on restart it posted and the screen froze with the MSI logo loading screen. Had to turn off the computer manually and start it again which provoked that Windows uninstalled the update due to an error on the process.
Same thing happened when I tried to upgrade to Windows 11, wasn't able to do it due to this issue, the system was not able to restart properly so every attempt failed. Finally updated to Windows 11 by manually shutting down the computer and doing a clean start. I was hoping thigs would change in Windows 11 but it has not, same situation.
I have updated to several different BIOS and situation stayed the same, right now I am at BIOS 1.31 BETA and everything is the same as before.
1648269437971.png


I have tried several memory configurations XMS ON/OFF, using only 1 stick, moving the sticks to differente slots and no improvement, it won't restart properly and freeze on MSI logo screen. I did also acquire a new Corsair Vengeance pair from Amazon and situation is the same.

Any ideas on how to solve this restart issue? Curiously many have stated sleep issues and mine has no issue at all there which would be much worst than this, fortunately the restart process is something that I only do while installing updates or new programs which has the workaround of shutting down and booting up from scratch.
Thanks!
 

huy.son8154502d6

New member
Joined
Mar 15, 2022
Messages
2
I am having the exact same issue using a 12700K processor and 3060TI with 2x8Gb Crucial Ballistix at 3200Mhz..
Everything else is behaving perfectly, but I identified the restart issue the first time I installed an update in Windows 10, after selecting the "Update and restart" option the computer shut down but on restart it posted and the screen froze with the MSI logo loading screen. Had to turn off the computer manually and start it again which provoked that Windows uninstalled the update due to an error on the process.
Same thing happened when I tried to upgrade to Windows 11, wasn't able to do it due to this issue, the system was not able to restart properly so every attempt failed. Finally updated to Windows 11 by manually shutting down the computer and doing a clean start. I was hoping thigs would change in Windows 11 but it has not, same situation.
I have updated to several different BIOS and situation stayed the same, right now I am at BIOS 1.31 BETA and everything is the same as before.
View attachment 158212

I have tried several memory configurations XMS ON/OFF, using only 1 stick, moving the sticks to differente slots and no improvement, it won't restart properly and freeze on MSI logo screen. I did also acquire a new Corsair Vengeance pair from Amazon and situation is the same.

Any ideas on how to solve this restart issue? Curiously many have stated sleep issues and mine has no issue at all there which would be much worst than this, fortunately the restart process is something that I only do while installing updates or new programs which has the workaround of shutting down and booting up from scratch.
Thanks!
Try BIOS version .11x and installed new windows 11 (not update), actually BIOS 12x and higher versions have a lot of problems and only windows 11 is fully optimized for intel 12th K series.
 

zerijelly

Well-known member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
1,064
Trying - access bios and try to use M flash - it does not have me select the source for the new bios file. Select M flash in the bios settings and the PC restarts but then does "nothing" - I gave it about 5 minutes to "do something". Restarted - it exit M flasah, bios screen came up - still old bios setting - hit f10 and restarted PC. Tried th
Could you post screenshot of the BIOS version by pressing F12 key in the BIOS and saving the screenshot to USB drive?
Could you post a new ticket regarding all the issue you've been encountered?
 
Top