Pro Z790-A WiFi + DDR5 6400 XMP Stability Issues with Recent A4 Bios


PRO Z790-A WiFi 13900K / GE66-12UGS 12900HK
Apr 10, 2023

I have the Pro Z790-A WiFi paired with a i9 13900K.

I am also having stability issues with DDR5 memory. I have been trying to run DDR5 6400 memory in XMP mode with varying degrees of stability. (2 x 32gb sticks kit).
The memory I have specifically is G.Skill F5-6400J3239G32GX2-TZ5RK ( which is DDR5-6400 CL32-39-39-102 1.40V ). The memory is listed on MSI's compatibility site as compatible, and on G.Skill's site. I'm running it with a Cooler Master MasterAir MA612 Stealth with a decent 6-Pipe heatsink. A nice even thermal paste spread of Thermal Grizzly Kryonaut was put on. On benchmarks maxes out at 85C, games and real use scenario like 75C. I don't run any overclocking on the CPU, just default BIOS settings, aside from XMP mode. I have also tried witching my new PSU for this build out with a known good PSU from my last build with the same results.

Running A3 or earlier BIOS, the system was somewhat stable running in XMP mode with 6400MT stock XMP timings and voltage. I would get occasional hiccups with notoriously glitchy titles like COD. Some random odd behavior but usable stable. However after the A4 BIOS update, it's downright unable. I noticed in the changelog there were memory compatibility changes. I once in a great while get a BSOD in Windows, related to system stability, some more narrow as Clock Watchdog Timeout, but mostly in games get random exit errors. (COD:MWII and Fortnite being biggest offenders). On A4 BIOS the only stable setting is running stock 4800MT settings. I have not tried any other settings besides that and XMP, and if anyone had any pointers who may have this issue, any timings that worked for you would be helpful.

Wondering what others results with DDR5 6400 is in XMP mode. I see others have success running it straight up, others having issues, perhaps due to the processor bin lottery with onboard controller variations. Any specific timing settings, clockrates, BIOS settings to try that are known stable for others with XMP 6400 2x32gb memory would be VERY helpful.

Also, I have run memory86+, memtest86, and Windows Memory diagnostic on it in 4800MT stock settings with zero errors. Running on 6400MT XMP profile, I get random single series errors here and there which lead me to believe the memory is fine, just an issue of timings.

I apologize. I made an incomplete copy from the translator program.
I didn't detect it. I wrote to GSkill. They asked me for the modules. They found the error and sent me a new one. In this case, the Memtest86 results are not conclusive. This needs to be taken care of. Thank you very much.