Psu fan just jerks when connected to mobo

rickymanalo

New member
Joined
Sep 19, 2021
Messages
2
I already tried the paper clip test and the psu worked fine. I bought a a850gf(the only gf I'll get in lyf lol) on an online store. It's brand new and packaging isn't damaged.

After getting it out the box, I immediately mounted it to my pc, but when I turned it on, the psu's fan just jerks and my pc doesn't seem to turn on. Because of my fear of breaking my pc more than it might have been, I turned everything off. I bought the psu because I have a suspicion that my old one broke because of frequent power interruption in my place as my old psu can just power the fans and can't boot the pc anymore. So after the paper clip test, I decided to just connect the 24pin and the cpu, the case fan for testing was still connected. And a stick of ram was also on the mobo, I think I saw a test that needed the ram so I did that. When I turned the psu, the case fan turned on but the psu fan now jerks again. I didn't find any article about this specific scenario so I posted here
 

Alan J T

🙈 🙉 Just 🐝 🤬😈
Joined
Sep 11, 2020
Messages
4,261
Humm Not sure info on tht PSU line is lacking May be passive cooling up to 60% load or something, No fan spin till you have a load on the PSU is my best guess but it do have a 10 year warranty
 

rickymanalo

New member
Joined
Sep 19, 2021
Messages
2
Humm Not sure info on tht PSU line is lacking May be passive cooling up to 60% load or something, No fan spin till you have a load on the PSU is my best guess but it do have a 10 year warranty
So you mean, I need to really use it first to know. Hmm, well, if I don't get any more advice, I'll try that.
 
Top