RAM problem w/ an old computer

Joined
Sep 27, 2021
Messages
5
Hello,
My most recent computer died last friday, and I have a hard time to configure my old computer for my daily work, and i'm far from expert...

I have a very old MotherBoard: MSI B85 G43
with 2x 2GB 1600mHz (DDR3)

And i cant add 2x2GB 1333 mHz (DDR3)...

i can reach the BIOS, but the computer always go in "repair" mode when restarting...Am i trying to do something my MB cant do ? I know it's an old computer but that's my only option at the moment...
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
REPAIR is post boot from windows ?
bootloader is broken or storage

,,.best download identical system + try repair from BOOT USB - auto repair
or manual from this USB + CMD
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
or set boot option -- identical like before
BOOT MODE - UEFI OR legacy or CSM
SATA CONTROLLER MODE - AHCI or IDE

verifiy storages in BIOS -- main tab or system info --exists or not
 
Joined
Sep 27, 2021
Messages
5
Pre Boot.
I's just after the BIOS config screen, I cant' reach Windows.
It needs a restart avec the boot screen, tries to load Windows but fails, instead i have a repair + light blue Windows logo.
I have to remove the 2x2Gb if i want to use my computer and if i do, i can use it (i use it right now) so i guess the bootloader is ok..?

Thanks for the help, I will try that !
 
Last edited:

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
storage or windows corruption
win 10 ? use upgrade "no format" all readable storage data is stored here - c:/windows.old


this is for ISO ,.,.win10 or win7

verify storage in bios "exists or not"
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
for "advanced repair" 3x random shutdown in boot
or F8

more options for repair "if you have POST-BOOT" bios works ,.,.windows not
restore point or try CMD
 
Joined
Sep 27, 2021
Messages
5
windows 10
And i may be not clear the first time,I use the computer right now, it seems broken and goes repair only when i try to run it with all the ram...
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
win 10 is best --upgrade REPAIR "no format data"
easy / fast

// ram debug - memtest from usb
or another RAM set "max 1600mhz or lower"
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
for BOOTABLE USB ,,.from WINDOWS ISO

when not exist storage
BOOT MODE - UEFI OR legacy or CSM
SATA CONTROLLER MODE - AHCI or IDE


windows 10 DEFAULTS is UEFI mode + GPT disk
but old mobo or support is CSM or legacy - MBR partition ,.,.invisible for new windows installation
must create USB and select identical version "old format"
UEFI - GPT
MBR - CSM / LEGACY


what you used before ,.,. otherwise you would have to perform a full disk format - lost DATA
 
Joined
Sep 27, 2021
Messages
5
But i'm confused... I's my hard drive the problem? ! I dont understand because it seems to works like a charm without the 2 new RAM sticks ...?
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,524
But i'm confused... I's my hard drive the problem? ! I dont understand because it seems to works like a charm without the 2 new RAM sticks ...?
// ram debug - memtest from usb
or another RAM set "max 1600mhz or lower"

hard drive
verify storage in BIOS -- main tab or system info --exists or not
 

Richj44

New member
Joined
Sep 6, 2021
Messages
19
But i'm confused... I's my hard drive the problem? ! I dont understand because it seems to works like a charm without the 2 new RAM sticks ...?
If you can boot successfully and use the computer with 2 sticks of RAM, but not with 4 sticks, then I don't think the hard drive / ssd is an issue. RAM incompatibility seems like the problem here since those are not matched sets of RAM. You might try lowering the settings on the 1600Mhz ram to 1333 so they all match there, if your board supports that. Otherwise I think you're going to need to match all 4 sticks (or buy new RAM).
 
Top