Realtek Audio not working after Bios update

arunkumar78

New member
Joined
Nov 20, 2023
Messages
16
I updated my PRO B660M-A DDR4 bios from 7D43v1E to 7D43v1F through MSI control center, after that Realtek Audio is not detecting/showing in Windows 11 and Windows 10 dual boot OS. The Audio is enabled in Bios.

------------------
Module Information
------------------
MS-7D43 1.F0
Intel Chipset Drivers 10.1.19376.8374
Realtek PCIE Network Drivers 11.10.0720.2022
Intel Serial IO Driver 30.100.2237.26
Intel ME Drivers 2319.4.30.0
Intel GNA Scoring Accelerator 3.00.00.1457
LED FW Update(7D43) 01

------------------
System Information
------------------
Product Name: PRO B660M-A DDR4
OS: Microsoft Windows 11 Pro 64-bit Ver.2009 (OS build 22631.2715)
BIOS Version: 1.F0
BIOS Release Date: 11/13/2023
CPU: 13th Gen Intel(R) Core(TM) i5-13400F
Memory: 32 GB @
- 16 GB DDR4-3600, G Skill Intl F4-3600C18-16GVK
- 16 GB DDR4-3600, G Skill Intl F4-3600C18-16GVK
Graphics: NVIDIA GeForce GTX 1650 SUPER
Drive: SSD, XPG GAMMIX S70 BLADE, 476.94 GB
Network: Realtek Gaming 2.5GbE Family Controller #2
Network: TP-Link Wireless PCI Express Adapter #2
Power Plan: GUID: 381b4222-f694-41f0-9685-ff5bb260df2e (Balanced)
 
Solution
If you have the exact same problem,
Reatek audio not working after BIOS update
Please fill in the form and we will get back to you!!!
<< Here is the form >>

Please note we need the serial number on the Motherboard 24Pin connector found here
MB serial.jpg
Can confirm sound is working on 7D43v1G1

PRO B660M-A DDR4:
I had to rollback to 7D43v1C (the latest working version AFAIK) then and only then the upgrade to 7D43v1G1 works ! (I tried H to G1 and it doesn't work)

Note that I have Fast Boot and Secure Boot disabled. Those are the only items changed from the default BIOS configuration.

Thanks !
 
Ok I have sent another form. I hope it works now.

Please help - when I reverted the BIOS the audio works, but i get 100% increase in power usage in idle desktop. On newer versions of BIOS I had 20W now its 40W in idle, nothing else has changed.
 
Last edited:
same for me on MSI Pro B660M-a DDR4 i upgraded my bios to version 7D43v1H from version 7D43v1E-> no sound.
After rerolling to version 7D43v1E my sound is working again ,but it seems like i have the same problem that User "aleksander.kamierczak153602d6" has. Idle power has nearly doubled.

 
Last edited:
Back
Top