Realtek Audio not working after Bios update

arunkumar78

New member
Joined
Nov 20, 2023
Messages
16
I updated my PRO B660M-A DDR4 bios from 7D43v1E to 7D43v1F through MSI control center, after that Realtek Audio is not detecting/showing in Windows 11 and Windows 10 dual boot OS. The Audio is enabled in Bios.

------------------
Module Information
------------------
MS-7D43 1.F0
Intel Chipset Drivers 10.1.19376.8374
Realtek PCIE Network Drivers 11.10.0720.2022
Intel Serial IO Driver 30.100.2237.26
Intel ME Drivers 2319.4.30.0
Intel GNA Scoring Accelerator 3.00.00.1457
LED FW Update(7D43) 01

------------------
System Information
------------------
Product Name: PRO B660M-A DDR4
OS: Microsoft Windows 11 Pro 64-bit Ver.2009 (OS build 22631.2715)
BIOS Version: 1.F0
BIOS Release Date: 11/13/2023
CPU: 13th Gen Intel(R) Core(TM) i5-13400F
Memory: 32 GB @
- 16 GB DDR4-3600, G Skill Intl F4-3600C18-16GVK
- 16 GB DDR4-3600, G Skill Intl F4-3600C18-16GVK
Graphics: NVIDIA GeForce GTX 1650 SUPER
Drive: SSD, XPG GAMMIX S70 BLADE, 476.94 GB
Network: Realtek Gaming 2.5GbE Family Controller #2
Network: TP-Link Wireless PCI Express Adapter #2
Power Plan: GUID: 381b4222-f694-41f0-9685-ff5bb260df2e (Balanced)
 
Solution
If you have the exact same problem,
Reatek audio not working after BIOS update
Please fill in the form and we will get back to you!!!
<< Here is the form >>

Please note we need the serial number on the Motherboard 24Pin connector found here
MB serial.jpg
Hi Guys!

I raised a ticket with the MSI support team, they asked me to clear the CMOS, disable the audio, save bios, and restart. Again enable the audio. That did not work, it was like the Realtek audio controller itself was not there.

I informed MSI that this issue is faced by others too and MSI needs to release a BIOS fix ASAP.

So I just downgraded my BIOS back to 7D43v1E using M-Flash. Now the Realtek audio is recognized in the Device Manager. I updated the Windows 11 audio driver, it is working fine. I can't use my PC without audio.

All of you were very helpful, Thanks 🙏
Thank you - I have been researching and trying most everything else. Just found this forum. But I am not sure how to do this? Can you send me a link or let me know.. can build a computer but can't get windows to work..i am 75 Thanks
 
Thank you - I have been researching and trying most everything else. Just found this forum. But I am not sure how to do this? Can you send me a link or let me know.. can build a computer but can't get windows to work..i am 75 Thanks
How do you do this? Tried to download older Bios but it said not available?
 
That's an AMD-based board. This thread is about problems with the latest BIOS on Intel-based boards.
So i assume you have a totally different problem than those from the thread here.

If it's just that you can't get Windows installed, proceed as mentioned here (including BIOS update). And once you're in Windows, instead of the Intel-specific drivers from that thread, you want to install the AMD chipset drivers from here, and whatever MSI drivers you need from their support page.

Again the BIOS update explained in more detail:
1) Get the latest BIOS. It's the topmost one on the MSI support page for your board.
2) Extract the file and you will get a text file and the BIOS file. Put the BIOS file into the root folder of a USB stick/drive.
3) Enter the BIOS by pressing DEL during boot, go to "M-FLASH" in the BIOS.
4) Once M-Flash (the updater) is loaded, it will show a list of your drives. Select the USB stick and select the previously extracted BIOS file on there.
5) It will ask for confirmation and then update the BIOS. It's fully automatic from there, takes about two minutes.
 
You never described your problem before, i don't think? What is it? Tell you what, create a new thread in the AMD section, list all (!) your hardware, and describe exactly what problems you have. Then we can think of a solution to it. This is the wrong thread for it.
 
Same pb with MSI PRO B760-P DDR4 II with 13600KF
but the 2 available BIOS (12 and 13) are not working for audio (realtek not detected by W11). I need to use NVIDIA controller to get audio through the monitor!
 
That's an AMD-based board. This thread is about problems with the latest BIOS on Intel-based boards.
So i assume you have a totally different problem than those from the thread here.

If it's just that you can't get Windows installed, proceed as mentioned here (including BIOS update). And once you're in Windows, instead of the Intel-specific drivers from that thread, you want to install the AMD chipset drivers from here, and whatever MSI drivers you need from their support page.

Again the BIOS update explained in more detail:
1) Get the latest BIOS. It's the topmost one on the MSI support page for your board.
2) Extract the file and you will get a text file and the BIOS file. Put the BIOS file into the root folder of a USB stick/drive.
3) Enter the BIOS by pressing DEL during boot, go to "M-FLASH" in the BIOS.
4) Once M-Flash (the updater) is loaded, it will show a list of your drives. Select the USB stick and select the previously extracted BIOS file on there.
5) It will ask for confirmation and then update the BIOS. It's fully automatic from there, takes about two minutes.

Thanks
 
I replied to this bios problem on Nov. 20; Info on my system

O/S Windows 10 10.0.19041.3693

MB PRO B660M-A WIFI DDR4 (MS-7D43)
bios 7D43v1E
Intel Chipset Drivers 10.1.19199.8340
Realtek wifi Network Drivers 22.250.10.1
Intel ME Drivers 2334.5.1
Intel GNA Scoring Accelerator 3.00.00.1457
Audio Driver Realtek HD Universal Driver 6.0.9601.1

CPU: 12th Gen Intel(R) Core(TM) i5-12400F
Memory: 32 GB @
- 16 GB DDR4-3600, G Skill Intl F4-3600C18-16GVK
- 16 GB DDR4-3600, G Skill Intl F4-3600C18-16GVK
Graphics: NVIDIA GeForce RTX 4060Ti
Drive: SSD, WDC WDS100T2B0A; 1TB

Power Plan: (Balanced)
 
Last edited:
Still no BIOS update. This is frustrating. My MSI Pro B660M-A is now still on 7D43v1E. Good thing my newly installed 14700K works fine.
 
Same motherboard, same bios update and same problem. I uninstalled the display and sound drivers with DDU and reinstalled them but it didn't work. I installed the old bios (7D43v1E) version and the problem was solved.
However, Realtek Audio Console still did not work at first start-up and gave an error, so I reinstalled the audio drivers again. Now everything is normal again.
 

Attachments

  • Ekran görüntüsü 2023-12-07 011428.png
    Ekran görüntüsü 2023-12-07 011428.png
    671.6 KB · Views: 65
Chat Record
Save Date:2023-12-07 17:42

2023-12-07
17:21 Me My product is:
MSI PRO B660M-A
17:21 Me HD Audio not working after BIOS update 7D43v1F.
I already cleared CMOS, disabled HD Audio, restarted, re-enabled HD Audio, and it's still not working.
I re-flashed 7D43v1E and it works again.
Will not update to latest bios until you fix it.
All B660M-A owners are facing the same issue, check the forums.
17:22 Msi Agent Hi! welcome to MSI chat! we appreciate your business. Please give me some time to read your concern and pull up my resources to help you. Kindly stay on the line. Do not switch tabs as the chat may get disconnected. Thank you!
17:23 Msi Agent Hi Elijah, we're sorry to know about the problem.
17:23 Msi Agent Let me assist you.
17:23 Me Here are the complaints in the official MSI forum. All of us are facing the same problem with B660, B660M, B760 motherboards.
17:23 Msi Agent So on the latest BIOS update from the website. It has an issue when it comes to Audio.
17:24 Me Yes.
17:25 Msi Agent Just to confirm right now your board is running perfectly to version 7D43v1E right?
17:26 Me Audio is perfectly working on 7D43v1E, but Intel APO cannot be enabled on my 14700K
17:27 Me So I need 7D43v1F, but audio is not working. I need both Intel APO feature and Realtek Audio coming from the motherboard. It's been almost 1 month since the BIOS update 7D43v1F was released.
17:27 Msi Agent I see, thank you for information us about that. We will coordinate this with our software engineers to check this 2 BIOS version and to check when they will release new BIOS update.
17:30 Msi Agent Is it alright if we will send you update via email about it?
17:31 Msi Agent I will escalate this with our software engineers to check on this update and ask when the next BIOS version will be release.
 
I finally managed to open a ticket today, waiting for a response.

And short answer:
Thanks for contacting MSI technical support.

Regarding your concern, we are still checking the issue. Please wait for us. Thank you!

Thanks for your cooperation in advance!

Best Regards,

MSI Technical Support Team
 
Last edited:
Downgraded BIOS to previous version, like suggested. That fixed HD audio controller and i can use speakers again. I was really stressed that audio controller in MB got broken or something. Hopefully they release new bios soon with the hotfix.

PRO H610M-E DDR4

Same here, everything worked fine with BIOS 7D48vAC , then I updated to 7D48vAD.

With the 7D48vAD version, no sound, all Realtek devices disappeared from Device Manager, and reinstalling the Realtek HD Universal Driver didn't help either.

After downgrading to 7D48vAC , Realtek devices reappeared in Device Manager and everything worked again.
Same Mb as me. I thought I was going crazy updating uninstalling reinstalling msi realtek audio trying to get realtek to come back to device manager and sound settings after flashing to AD. Like yourself a rollback reverted all back to normal.
 
Same Mb as me. I thought I was going crazy updating uninstalling reinstalling msi realtek audio trying to get realtek to come back to device manager and sound settings after flashing to AD. Like yourself a rollback reverted all back to normal.
you have to reinstall all Realtek drivers and app after downgrade, than all ok.
 
Back
Top