[SOLVED] MEG Z490 Godlike Dynamic Dashboard II not working and Corsair RAM RGB not showing up in Mystic Light after MB LED FW update in Dragon Center

imgr8a159302ea

New member
Joined
Dec 20, 2020
Messages
3
Hey guys,
I also have the same issue, ( no LCD ) I did have one, updated bios 1.20 think it was still there after also I uninstalled Dragon center too. if there is someone that can help I would much appreciate it.
I have Z490 Godlike, the CPU fan is working but not showing rpm on any software or bios Kraken Z73 btw.
 
Last edited:

Furna

The sky above the port was the color of television
Joined
Jul 19, 2020
Messages
381
It seems you have more than one issue; but none of these you have are addressed in this post.
The whole motherboard manual does not include the term "LCD"; do you mean Dynamic Dashboard II ?
 

darkhawk

Well-known member
Global Moderator
Joined
Nov 20, 2012
Messages
14,229
If I'm honest....my dynamic dashboard II has never worked on my Z490 Godlike......and still doesn't. I just gave up on it.
I haven't tried to contact MSI yet. maybe after the new year I will. when the kids are back in school and not using the PC as much.
But it is semi-annoying, since it SHOULD work.
My Z390 Godlike works fantastically.....:/
 

Furna

The sky above the port was the color of television
Joined
Jul 19, 2020
Messages
381
If I'm honest....my dynamic dashboard II has never worked on my Z490 Godlike......and still doesn't. I just gave up on it.
I haven't tried to contact MSI yet. maybe after the new year I will. when the kids are back in school and not using the PC as much.
But it is semi-annoying, since it SHOULD work.
My Z390 Godlike works fantastically.....:/
Check PM ... If I remember correctly it works even without rebooting ;-)
 

darkhawk

Well-known member
Global Moderator
Joined
Nov 20, 2012
Messages
14,229
Check PM ... If I remember correctly it works even without rebooting ;-)
Thanks, but trust me when I say that I've tried that, and every other one (that isn't posted here).
I've worked directly with the engineers on it, and they're as confused about it as I am.
 
Joined
Dec 24, 2020
Messages
1
Hey guys,
I also own this motherboard and have the same issue...
The dynamic dashboard wont work anymore after using the dragon center app...
Could someone Help?
 

kapfhammer8155e02d5

New member
Joined
Dec 29, 2020
Messages
2
Hallo.

habe auch das problem.
Seit dem BIOS-Update funktioniert mein Display nicht mehr.
kann es auch nicht über das Drachenzentrum steuern.
 

kapfhammer8155e02d5

New member
Joined
Dec 29, 2020
Messages
2
Sorry


today have a bios update on my msi
Z490 godlike mainboard carried out.
now my display on the mainboard no longer works.
can't adjust anything on the dragon center either.
Can someone help me please.
 
Last edited:
Joined
Dec 30, 2020
Messages
2
Hi there have the following problem. Yesterday I made a BIOS update version 1.60 on my mainboard. since the update the display on the mainboard no longer works. It is off and I cannot adjust anything in the Dragon Center (ver. 2.0.96.0) in the Dynamic Dashboard. I set up my system again, downloaded and installed all drivers and Dragon Center, I also did a BIOS reset, but none of that helped. I also called Msi Support today but they didn't really have a solution to my problem. I hope one of you can help me because I'm really desperate.
 

Furna

The sky above the port was the color of television
Joined
Jul 19, 2020
Messages
381
@kapfhammer8155e02d5
@blacknightwolf155802e0
The Dynamic Dashboard II firmware is completely independent from BIOS ... it sounds strange you both had this issue at the same time. What BIOS file did you flash' where did you downloaded it?
 
Joined
Dec 30, 2020
Messages
2
I downloaded the bios firmware from the msi side vers. 160
since then the display is off and I have no idea how to reactivate it
 
Last edited:

matt.andrak159d02e4

New member
Joined
Jan 4, 2021
Messages
4
I am experiencing the same issue. After installing the LED FW Update in Dragon Center, the Dynamic Dashboard OLED is now off, and changing the settings in Dragon Center does not seem to turn it back on. I've attempted to clear CMOS, but that has not resolved the issue. Can someone help?

Thanks!
 
Top