[-SOLVED-] MSI GF63 - 8RC: No way to install Windows 10 from USB; keeps asking for Drivers from the USB, DVD or Hard Disk.

108845150b02d4

New member
Joined
Oct 15, 2020
Messages
5
Hi y'all. I'm here seeking for some help. I hope I find it here. So, I'm going to explain my problem in a few steps, in the same order that I did them.
Ok, so. Here's the problem. A few months ago my version of Windows 10 was having a lot of problems. It got so slow that I decided to re-install it. It went good, everything was fine. Then the first problem happened: My Search Bar was gone, I couldn't find anything, so if i wanted to use an app that wasn't in my desktop I had to search it in the whole disk from "This PC". This was a huge problem for me, so I re-installed it again. Everything was fine, everything was good. Now is where I say that I have a partition for ElementaryOS (an OS based in Ubuntu 18), so that was like my main OS because I develop faster in Linux. So I was using it like in an everyday basis, till I wanted to go to Windows to do something. Here was the problem that got me stuck, because Windows got broken and it was trying to fix itself, but it couldn't. I couldn't reinstall it from the Recovery Environment neither. And since I have a MSI GF63 8RC there's a recovery system from MSI, that i couldn't use. So I deleted windows. All good here, but I actually want to go back to be able to play video games because here in Linux it's kinda of hard. Here's the problem, I can't install it back, because every time that i insert my USB with the Windows Installer it says "A media driver your computer needs is missing. This could be a DVD, USB or Hard Disk Driver." So, i tried all this:
1.- After searching in Google what to do, i found that i was supposed to install these drivers "Intel® Rapid Storage Technology (Intel® RST) User Interface and Driver" (I won't put the link here because I don't know if there's a rule about it). I downloaded it and I saved it in a folder in the USB that i used to install Windows 10. When I tried searching for the folder inside the installation I don't know why but its empty.
2.- Then I tried to use something called "MSI Smart Tool". I found this in another video to fix the same problem. The thing is that it is only for windows, so I used a VMBox with Windows 10 and installed from there and mounted the ISO with that in the USB from the Virtual Box. Doesn't work.

There's another thing. I posted something similar to Reddit, and people told me to erase the whole disk, because Windows install better like that. Doesn't work. So please, don't recommend it because I already tried it. So, I came here because I don't know what to do anymore. Up there i said the model of my laptop, so maybe that works for something. If anyone can help me, then thank you so much. See you all later guys, thanks for even read till this long.
 

Crazydonkey

Active member
SECOND LIEUTENANT
Joined
Jun 30, 2020
Messages
629
Is there any hardware missing in BIOS > storage info?
Have you tried to rebuild a Windows 10 2004 image in another USB disk?
Try to follow the steps to reinstall pure OS.
 

next3r

Active member
MAJOR
Joined
Jun 22, 2018
Messages
1,945
windows iso + rufus + f11 "before boot"

..aditional
RST or AHCI --disk configuration
using RAID 2x ssd cross ?? set RST + install RST drivers "load drivers in windows instalation"
17.9.4 -last for you HW

AHCi --single disk config ,,same driver package or windows defaults
for NVME sometimes need special drivers from manufacture "SSD homepage" + ahci and nvme driver or for INtel SSD --RST native

?
ahci or RST --same package ,,f6 driver is OK "no user app" no need
 
Last edited:

108845150b02d4

New member
Joined
Oct 15, 2020
Messages
5
windows iso + rufus + f11 "before boot"

..aditional
RST or AHCI --disk configuration
using RAID 2x ssd cross ?? set RST + install RST drivers "load drivers in windows instalation"
17.9.4 -last for you HW

AHCi --single disk config ,,same driver package or windows defaults
for NVME sometimes need special drivers from manufacture "SSD homepage" + ahci and nvme driver or for INtel SSD --RST native

?
ahci or RST --same package ,,f6 driver is OK "no user app" no need
I tried this. I used RUFUS via VM in a Windows 10 machine, and it didnt work. I installed those drivers too with another USB. Doesnt work.
 

laurence1211

Active member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
422
Last edited:

laurence1211

Active member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
422
I tried it. Doesn’t work. Guess I’ll need to buy an SSD...well.
At this point I'm wondering if you have a hardware issue. Because the other fixes for this are slight changes to what you have done already. Is the bios upto date btw?
 

108845150b02d4

New member
Joined
Oct 15, 2020
Messages
5
Top