Stuttering Recently


Mar 7, 2019
Hey man I have near identical setup to you, did you end up resolving? Also what game are you playing? If via DX12 turn off exploit protection. In bios you need to disable Intel Thermal Monior which was a show stopper for me and a few CPU settings, namely Speed Shift Technology, CStates and EIST..

I also cap frames to my monitors hz (240) then in nvidia set All power and quality to high performance and for VSync change to adaptive. I’d test these independently. That being said I still get the occasional small fps drop and stutter in Fortnite but it’s bareable.

if you’ve found a solution I’d love to hear it. PS my windows is stripped down and optimised, nvidia 3070 on latest drivers but I’ve heard 477.11 runs well
Sorry for the late reply. I've tried everything to no avail. Sometimes it never happens. Sometimes it does. Sometimes it's only certain games. Sometimes switching the game to my SATA SSD fixes the issue. I'm at a loss here man. I've changed every component in my PC except my case and Monitor.

The drops are gone but there's still a stutter/skip that happens out of nowhere. It makes no sense. I never tried turning off the things you mentioned except Speed Shift Technology, and it didn't do anything. I have no idea man. The huge drops stopped but the stutter is still there in some games. I'm thinking this isn't a hardware issue but a software one.

Either way, I'm about to upgrade my mobo to a DDR5 for the RAM and possibly the case. Probably won't be for a while since I spent enough money trying to solve this problem.


New member
Dec 4, 2022
A few things I did when I had this issue was go into bios and turn of fTPM, I think it was called ‘Trusted computing’ or similar in the ‘security’ menu. Once in that submenu set ‘security device = disable’. This is on windows 10 but I’m not sure if you can do this on 11 as it may rely on it.

Next I made sure that Nahimic was completely removed, which is msi’s biggest travesty they’ve done software wise, if you have onboard Realtek audio enabled you probably have it forced on you thanks to windows update, to see if you have look in ‘task manager - services - Nahimic’. I couldn’t tell you how I completely removed it and stopped it reinstalling and then blocked windows update, a day of googling and Reddit posts until it finally stuck.
Lastly I uninstalled the chipset drivers I got from msi’s support page which weirdly were a higher number version than amd’s official website so perhaps they are custom ones and they caused issues.

Nvidia have been really bad with the gpu drivers too recently, from HAGS causing dwm.exe to use 100% gpu, to a couple driver versions where screen switching caused signal loss.
Currently the only stutters I get are from dx12 games (Returnal and Dead Space for example) and the terrible shader compilation/asset streaming stutter that comes with that api.