Time to Upgrade your Software – MSI CENTER (Bug Status)

Joined
Nov 8, 2022
Messages
2
Thank you ! Everything is working now after reflash. In my opinion this LED firmware should be available for download from official MSI website instead we've got pdf...
 

mradyno315e602e5

New member
Joined
Nov 12, 2022
Messages
2
What's the newest firmware for led to x570 tomahawk wifi. Scrrenshot from my msi. And how download and install newest. In my msi if i scan not recognize new adrives. On the site is only pdf and no link to tool led firwamre update
Bez tytułu.jpg
 

Nichrome

Friday? Deploy to prod!
Global Moderator
Joined
Nov 7, 2013
Messages
20,940
What's the newest firmware for led to x570 tomahawk wifi. Scrrenshot from my msi. And how download and install newest. In my msi if i scan not recognize new adrives. On the site is only pdf and no link to tool led firwamre update
View attachment 165614
Do you have any problems with your LEDs? If not then I wouldn't worry about FW.
 

mradyno315e602e5

New member
Joined
Nov 12, 2022
Messages
2
sometimes is feaking but last 5 days is nromal.
D you know about hang windows and freeze? must go reset. This is when i ru nedgde web browser in windows
 

teletubby_po

To infinity and beyond.
FIRST LIEUTENANT
Joined
Apr 6, 2020
Messages
1,927
A major bug has been happening for the last couple of releases. Using color shift in sync mode with the GM41 wireless connected (in wireless mode) causes sound skipping when playing any audio, this mostly happens after waking from sleep. Also, there is a spike in the DPC latency because of this issue. Another way to demonstrate the sound skipping is by turning off then on the wireless mouse while the color shift in sync mode is turned on (after waking from sleep). Its seems to have the color synced with the wireless mouse and the rest of the PC components is causing some kind of delays which results in sound skipping.

This is a major bug that is causing system performance issues. Please resolve it asap

FYI, currently running on the latest MSI Center 1.0.64.0 / Mystic Light 3.0.0.29 / GM41 Wireless FW 0094

Another issue also related to the GM41 wireless is that the applied RGB effect turns off after sometimes randomly and needs to be reapplied through mystic light again
can you please list down your system specification including your audio output device? Posting Guide
how do you observe the DPC latency and pin down GM41 is causing a performance issue?
 

mbushnaq

Member
Joined
Nov 16, 2020
Messages
48
can you please list down your system specification including your audio output device? Posting Guide
how do you observe the DPC latency and pin down GM41 is causing a performance issue?
As requested, below are my system specs:

Main Board: MSI MPG B550 GAMING EDGE WIFI
Bios Version: 7C91v1A
Video Card: PNY GeForce RTX 3080 10GB XLR8 Gaming REVEL EPIC-X
PSU brand and model: Corsair TX850M 80 Plus Gold
12v rail Rating of listed PSU: 70.8A
CPU: AMD Ryzen 7 5800X
Memory: G.Skill 16GB DDR4 TridentZ RGB 4000Mhz (2x8GB)
SSD/ HDD: Crucial P1 1TB NVMe Gen3 | Sabrent Rocket 4.0 2TB NVMe Gen4
CPU COOLER: DeepCool CASTLE 360EX A-RGB
Raid Card: N/A
Sound Card: N/A
Keyboard: MSI VIGOR GK50 ELITE
Mouse: MSI CLUTCH GM41 WIRELESS
Any Additional hardware plugged into your system: None
OC: (Yes / No)
Operating System: Windows 11 Pro 22H2 (Build 22621.819)

Audio from the Nvidia card through HDMI is being used
I used dpclat software to monitor the DPC and noticed only when the color shift effect in sync mode is used, the DPC spikes. I was able to pin it to the GM41 wireless through mouse movement and by turning off and on the wireless mouse which causes and huge sound stutter and a spike on the DPC as well.
The moment I use another RGB effect such as Rainbow and remove device sync, this issue is completely gone.
I would like to also mention that I also have the GM30 wired mouse and that does not have any issue what so ever configuration I try.
 

erikvdneu15f802f4

New member
Joined
Nov 25, 2022
Messages
1
Mystic light is not working even after multiple re- and uninstalls of the latest version.

My event log is full of these
Faulting application name: LEDKeeper2.exe, version: 3.0.0.29, time stamp: 0x63523afb
Faulting module name: KERNELBASE.dll, version: 10.0.22000.1219, time stamp: 0x554c45b0
Exception code: 0xe0434352
Fault offset: 0x00140762
Faulting process id: 0x4928
Faulting application start time: 0x01d900e5098e1afb
Faulting application path: C:\Program Files (x86)\MSI\MSI Center\Mystic Light\LEDKeeper2.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll


And these from .NET RUntime

Application: LEDKeeper2.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.ArgumentOutOfRangeException
at System.String.Remove(Int32, Int32)
at MysticLight_AllDevice.Class_Fun_MB.GetMBInfo()
at MysticLight_AllDevice.Device.AllDevice.Init_AllDevice()
at MSI_LED.MainLoopForSDK..ctor()
at MSI_LED.CGame_SyncHandle..ctor()
at MSI_LED.App.Application_Startup(System.Object, System.Windows.StartupEventArgs)
at System.Windows.Application.OnStartup(System.Windows.StartupEventArgs)
at System.Windows.Application.<.ctor>b__1_0(System.Object)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
at System.Windows.Threading.DispatcherOperation.InvokeImpl()
at System.Windows.Threading.DispatcherOperation.InvokeInSecurityContext(System.Object)
at MS.Internal.CulturePreservingExecutionContext.CallbackWrapper(System.Object)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at MS.Internal.CulturePreservingExecutionContext.Run(MS.Internal.CulturePreservingExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Windows.Threading.DispatcherOperation.Invoke()
at System.Windows.Threading.Dispatcher.ProcessQueue()
at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)
at MS.Win32.UnsafeNativeMethods.DispatchMessage(System.Windows.Interop.MSG ByRef)
at System.Windows.Threading.Dispatcher.PushFrameImpl(System.Windows.Threading.DispatcherFrame)
at System.Windows.Threading.Dispatcher.PushFrame(System.Windows.Threading.DispatcherFrame)
at System.Windows.Application.RunDispatcher(System.Object)
at System.Windows.Application.RunInternal(System.Windows.Window)
at System.Windows.Application.Run(System.Windows.Window)
at System.Windows.Application.Run()
at MSI_LED.App.Main()


This is on WIndows 11
 

servaa0164e02f7

New member
Joined
Dec 2, 2022
Messages
1
Hi, I have X570 Unify and have a problem with fan control as it does not work and all the fans are spinning at a constant RPM. I read from multiple posts that updating the LED firmware will fix this problem. However, similar to #380 above, I tried initiate the LED firmware update via MSI center and shorted JT1 pin but no success. Can someone please send me the firmware for my board 7C35 ? My CPU is running at 80 deg idle with my 360mm AIO..
 

thiagotresc152602da

New member
Joined
Dec 4, 2022
Messages
4
Hi, I'm having an issue with Mystic Light. It doesn't show up at MSI Center and my RGB doesn't light up either, what do I do?
Also I can't download the latest LED FW update because It doesn't appear.
Capturar.PNG
 

plutomate

Well-known member
MAJOR GENERAL
Joined
Jul 30, 2015
Messages
5,758
It looks like you have multiple account on your PC, you need to use the one with administrator privilege or at least try run MSI Center as administrator.
 

thiagotresc152602da

New member
Joined
Dec 4, 2022
Messages
4
Actually all profiles have administrator privileges. I tried to run as administrator and re-installing Mystic Light and nothing changed.
 
Joined
Dec 10, 2022
Messages
1
Hello, i have a problem with my LED firmware for MSI x570 unify. My computer turned off while updating it via MSI center. Now jrainbow1 and 2 doesnt work. I tried to short pins and update ones again but it didnt work. Can you send me file with LED fw for this board?
 
Joined
Dec 18, 2022
Messages
1
1. I've installed MSI Center as an admin, but can't launch it from a different account in Windows 10. It is nowhere to be found. Is it a feature or a bug?
2. In Windows 11 the latest MSI Center lacks the Hardware Monitoring and Support tabs.

How to fix this all?
 

plutomate

Well-known member
MAJOR GENERAL
Joined
Jul 30, 2015
Messages
5,758
1. I've installed MSI Center as an admin, but can't launch it from a different account in Windows 10. It is nowhere to be found. Is it a feature or a bug?
2. In Windows 11 the latest MSI Center lacks the Hardware Monitoring and Support tabs.

How to fix this all?
Most likely you'll have to reinstall again with admin privilege again in user account. MSI Center really doesn't work well in user account, i personally stick to default account and I don't have problem with it.
 

quocanhlae158202e4

New member
Joined
Dec 9, 2021
Messages
11
Got some weird error today. when I login to my admin account, other account not affected just this admin account
Screenshot (50).png

I've tried uninstalling and reinstalling MSI center from Microsoft store along with MSI Center SDK, disable anti virus, and install older version from this forum but nothing seem to work
Edit: Spec: MSI Bravo 15 B5DD (2021)
Window 10 version 22H2
I think this happen after I installed version 1.0.67.0
Here is the log
 

Attachments

Last edited:

emincangule15a802e0

New member
Joined
Dec 25, 2022
Messages
1
Hi.I have a led fw problem with MPG Z690 Carbon Wi-Fi.I tried to update in MSI Center but the update not showing.Also i short JT1 pin.I tried to manuel update and it says connect to device fail.Is there any solution without the service?I dont want to wait ;(
 
Top