Update BIOS for Z68A-GD65 (G3) for GTX 1060

eichzee15da02ed

New member
Joined
Aug 13, 2020
Messages
8
Hi there!

I have a Z68A-GD65 (G3) and want to add a GTX 1060 GPU (Asus 3GB DOC). CPU is an i7-2600K. Might be switching to an i5-3570K if that is of significance.

Current BIOS is 23.6. I have tried to update without success. From this forum i understand that the flashing has to be done in a special way. Can someone please give me some guidance.

Thanks!
 

eichzee15da02ed

New member
Joined
Aug 13, 2020
Messages
8
OK. So I followed the steps. The flash tool worked perfectly and BIOS is now updated.

But I still can't get the 1060 to work. It's like it's not even there. I now the card works because I have tried it in another PC. I have also tried another GPU in the Z68 without issue. PSU is a Fractal Design 650W and it has worked with the same card earlier.

Any further advice?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
Can you double check in BIOS Setup the BIOS version now?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
Okay, then the BIOS indeed is successfully installed.
Have you tried to reseat the card and ensure its filled well in the PCI-E slot?
Have you tried to >>Clear CMOS Guide<< too? with power cord removed?
Have you tried a different PCI-E slot?
Do you have all power cables connected to the card?
 

eichzee15da02ed

New member
Joined
Aug 13, 2020
Messages
8
Yes to all.
I have tried to reseat the card, and I have also tried the other PCI-E slot. I am sure the card is properly fitted.
I cleared CMOS after completing the flash, and was forced into BIOS setup. (I had to try this two times as I probably didn't leave the jumper on for long enough on the first attempt. But this should not be significant?)
Power cable is connected to card.
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
Could be some unknown compatibility issue then with this particular card.
Or maybe your PSU is doing you weird things.
 

eichzee15da02ed

New member
Joined
Aug 13, 2020
Messages
8
Could be... I have used the same PSU / GPU combo in another PC without problems.
I can get a RX 570 (Sapphire Nitro 4 GB) from a friend. Do you know of any compatibility issues with this GPU?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
Sapphire its known to cause compatibility issues, [some models on some boards]
however I don't know for sure if the mentioned model will cause any issues or not.
Simple try it to find-out. Probably should works
 
Last edited:

eichzee15da02ed

New member
Joined
Aug 13, 2020
Messages
8
Btw, do you know if any particular brand or model of GPUs are considered safer / more compatible for use with these older mobos? Or is it more a case of individual incompability, like this card don't work with that mobo?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
Don't have a list, but by memory most of modern cards works or at least to 10 series nvidia and respective cards from amd should works,
when latest bios class and version are installed.
 
You must log in or register to reply.
Top