Wakes on USB even when disabled in BIOS: MSI PRO B660M-A WIFI DDR4 (MS-7D43)

nsvvlmvmwyg153702db

New member
Joined
Sep 15, 2022
Messages
5
When "Settings\Advanced\Wake Up Event Setup\Resume By Onboard Intel LAN" is Enabled, the computer will wake on USB input from keyboard and mouse, even though "Resume By USB Device" is Disabled. Unchecking "Allow this device to wake the computer" under the Power Management tab of the keyboard/mouse in Device Manager also doesn't work. Anyone else have this issue or a solution?

I want "Resume By Onboard Intel LAN" enabled so I can use Wireless Wake on LAN to wake the PC from sleep when connected WiFi, but I don't want USB devices to wake the PC because it's very easy to accidentally move the mouse. Moving things around on the desk or even bumping the table slightly moves the mouse and wakes the PC. Plus, some USB devices can misbehave and I just don't like to have keyboard wakeup anyways.

I'm on the latest BIOS version 7D43v17, Windows 11 PC.
 

teletubby_po

To infinity and beyond.
FIRST LIEUTENANT
Joined
Apr 6, 2020
Messages
1,801
does the issue persist if you change the USB ports?
what are the USB devices (model name, brand, etc) that still wake the system up after resume from USB disabled?
and can you please make sure that the BIOS changes are saved? there will be a pop up message that shows the BIOS change when you're saving BIOS settings
 
Last edited:

nsvvlmvmwyg153702db

New member
Joined
Sep 15, 2022
Messages
5
Hi, thanks for checking in.
Yes I tested every USB port and it wakes on all of them. I tested with a Leopold FC900R keyboard, Das Keyboard 3, and Logitech M720 mouse (via USB dongle), and every device will wake on every port. The only thing that seems to disable it is if I unplug and replugin the device after it goes to sleep, then it will not wake.
I verified the saved settings in the popup message and also checking them again after a reboot to make sure they stuck.
 

teletubby_po

To infinity and beyond.
FIRST LIEUTENANT
Joined
Apr 6, 2020
Messages
1,801
The only thing that seems to disable it is if I unplug and replugin the device after it goes to sleep, then it will not wake.
have you tried S4(hibernate) & S5(power off)? is the system woke up by USB device in S4 and S5 as well? and do you have trouble waking up the system from S4 & S5 with wireless wake on LAN?
 

nsvvlmvmwyg153702db

New member
Joined
Sep 15, 2022
Messages
5
System does not wake on USB when hibernated or shutdown. However Wake on Wireless LAN does work in hibernate but not in shutdown, which was quite surprising to me as I had assumed all components should be powered down in hibernate.

I double checked that hybrid sleep was disabled in Windows, just in case it decided to sleep even when I specified hibernate. And even took a power meter to the PSU to confirm, and power consumption was consistent with a full system shutdown rather than sleep mode.

Only odd thing I noticed was the keyboard (but not the mouse) stopped working after a resume and needed to be unplugged and replugged in to work. I took this as a sign that the BIOS was indeed disabling USB ports during hibernate.
 

nsvvlmvmwyg153702db

New member
Joined
Sep 15, 2022
Messages
5
weird, does it have anything to do with where you plug the keyboard?
Don't think so, but I'll check later. The mouse is plugged into a hub, so it might have something to do with that.

DO you have ERP enabled
When I enabled "ErP Ready" it would disable "Resume By Onboard Intel LAN", so I don't think both are supposed to be enabled at the same time. But if I reboot after enabling "ErP Ready" and disabling "Resume By Onboard Intel LAN", it would let me enable "Resume By Onboard Intel LAN" and still keep "ErP Ready" enabled, but the effect is the same: it still wakes on USB.
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
9,673
YA not sure then as ERP should turn off USB power when computer is power down May be some Windows setting in Device manager

Check all listings for USB keyboard or mouse devices
1663900739183.png


Also check under HID Devices

1663900807045.png
 

nsvvlmvmwyg153702db

New member
Joined
Sep 15, 2022
Messages
5
A bit of speculation here, but I wonder if it has something to do with the Bluetooth module. From the device manager tree, it looks like the AX201 Bluetooth module is connected to the motherboard over a USB interface. So when you enable "Resume By Onboard Intel LAN", it can't just turn on the WiFi module, it has to activate the PCIe interface, which also activates the USB host controller. So to turn off USB wake, you actually need to deactivate the whole PCIe interface, which also shuts off the WiFi module.
 
Top