Weird problem with Msi rx 6600 xt display port

sagodam159d02e3

New member
Joined
Jan 24, 2023
Messages
4
Recently i upgrade my pc buying a gpu ''msi mech x2 8g oc rx 6600xt'' and i face a weird problem.

When i turn on my pc and my screen is turned off from power button the vga led on mobo is on,thats an issue.When the screen is stand by and turn on the pc again the vga led is off.Also i noticed that sometimes (not in gaming) the screen flashes for a fractions of a second but thats it no other problems found so i try these things below.

Use DDU and Revo for deleting old drivers of Nvidia.Also use the same apps for deleting AMD adrenaline and install it again.

Pull out gpu and back again over twice.

Change psu from 520w to 750w

Update mobo bios,graphics card drivers and screen drivers.

Disable upls from registry.

Change with certified dp cable.

Try in all dp ports.

Try the dp from my 2 different older graphics cards (rx 560 oc saphire) and (gtx 1660 oc gigabyte) with no issues.The dp version in all gpus are 1.4 msi included,screen 1.2 but this is not a problem.

Try hdmi cable on msi gpu with no issues.

Contact with AOC for replacing the screen,the new screen arrived but i have the same issue so i kept my first one.The screen is new too.

Plz can u help me on that,may i contact with MSI for rma or is there something else i can do?

There is a short video on YT with my issue but i cant link it if u want.

Sorry for my english.

BIOS GRAPHIC CARD 020.003.000.030

SCREEN:AOC C27G2U/BK 27'' CURVED 165HZ

CPU:AMD RYZEN 5 3600XT

GPU:MSI MECH X2 8G OC RX 6600XT

MOBO:GIGABYTE B450 AORUS PRO

RAM:2 x 8 CORSAIR VENGEANCE 15CL

PSU:750W SEASONIC FOCUS 80+ GOLD

KEYBOARD:AOC AGK700

MOUSE:RAZER VIPER MINI-AOC AGM700
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
11,464
May be best to RMA the GPU may be faulty
Can you test it in a separate system to see if it still does it?
As then you will know it has a problem if it dose it is a different PC
 
Top