Wifi - connected but no internet

rd.alla157a02e6

New member
Joined
Jan 27, 2021
Messages
3
Hi,
Wonder if any of you amazing people can help give some useful ideas if you have encountered this issue.
I own a MPG Z390I GAMING EDGE AC. I have an issue where it connects to the wifi but there is no internet. Due to having used a powerline ethernet plug I have never relied on the wifi since I bought this mobo in December 2019.

1. I have put the case on the desk to avoid interference.
2. I have fully checked the router and tested with other devices for wifi (decent coverage where used)
3. I have uninstalled and installed the drivers for the wifi
4. Tried using a fixed IP address

Any other suggestions on what I can try next please?

Thanks in advance

Rich
 

Sicalo

New member
Joined
Nov 29, 2013
Messages
3
Hello,

If you are able to connect to the Wifi connection, likely its a network issue not a hardware issue. I am assuming it is likely you are on Windows 10. While it seems silly to hear, reconnect your machine to the Wifi connection, then on your computer, right-click the network icon in the task bar and choose "Troubleshoot Problems"

As long as you are connected to the network it will give you either more insight and information of the problem, or at best case it will find the issue and resolve it.

Definitely try that first.
 

rd.alla157a02e6

New member
Joined
Jan 27, 2021
Messages
3
Hello,

If you are able to connect to the Wifi connection, likely its a network issue not a hardware issue. I am assuming it is likely you are on Windows 10. While it seems silly to hear, reconnect your machine to the Wifi connection, then on your computer, right-click the network icon in the task bar and choose "Troubleshoot Problems"

As long as you are connected to the network it will give you either more insight and information of the problem, or at best case it will find the issue and resolve it.

Definitely try that first.
Hi Sicalo,

That is the first thing I did, unfortunately it didn't solve anything, except tell me there was no internet.
 

Sicalo

New member
Joined
Nov 29, 2013
Messages
3
Not to point out the obvious here.
Do you have internet?
You mentioned you have checked with other devices and have Wifi. Were those devices able to connect to the internet via the Wifi connection (turned off Cellular Networks if the device has one to verify Internet is indeed through Wifi connection, not something else)

Can you reconnect the Ethernet Temporarily and verify the machine gets Internet though that?

Also Check your router for 2.4ghz and 5ghz broadcast. Its possible your machine is getting hung up there. (Try using ONLY the 2.4ghz to see if that helps).
 

rd.alla157a02e6

New member
Joined
Jan 27, 2021
Messages
3
Not to point out the obvious here.
Do you have internet?
You mentioned you have checked with other devices and have Wifi. Were those devices able to connect to the internet via the Wifi connection (turned off Cellular Networks if the device has one to verify Internet is indeed through Wifi connection, not something else)

Can you reconnect the Ethernet Temporarily and verify the machine gets Internet though that?

Also Check your router for 2.4ghz and 5ghz broadcast. Its possible your machine is getting hung up there. (Try using ONLY the 2.4ghz to see if that helps).
The answer is yes to everything you mention...my other desk pc connects amazingly to the wifi, I have ruled everything outside of the PC out. It is something to do with the either the software or hardware of the PC. I even set up a wifi extender and connected directly to that, same issue... connects but no internet. The pc is back on the ethernet cable for now and works fine albeit it slow due to using powerline plugs.

I have tried everything I can think of and come up with zero.
 

pashnyo14bd02c4

New member
Joined
Jan 10, 2021
Messages
13
had the same one, just installed official drivers for chipset and wife adapter, restart the windows and issue got out.
 
Top