Win8 Pro and display solution

john4good

New member
SERGEANT
Joined
Dec 21, 2012
Messages
32
Excited to write this post as I wanted to know why Windows 8 will not install on some notebooks. Was very disappointed when the display did not come about. If you have an older system with hybrid card ( or maybe a single one) and still want to use window 8 pro. Try something i tried. Hope you find a work around for your issue.

The reason you dont having a working card is probably because there are no signed drivers from MSI for Win8pro which will not install drivers with WinVista certificate which was acceptable under Win7.

On CX420: I just upgraded to windows 8 pro (from win7), got display issue, the ATi card 5470 1GB ram was not picked up. The Intel built-in one was used. There is a solution.

You might be getting the default intel driver, i suppose after upgrading.

The solution is with 3rd party solution provider. Extremely happy with them about this fix.

1. Uninstall the ATI drivers and Catalyst manager.
2. Download UnifL from Leshcat website
3. On installing this new app, it will ask about installing a DSE - yes to that
4. Use the unifil config tool to add the certificate
5. Install the catalyst driver found as a seperate executable
6. The windows version will show as Test mode, windows 8 pro, xxxx (some number) in the lower right corner of the former desktop view
7. During these steps, let the restart be allowed whenever possible - you should have the drivers working for you now. The device will be shown as a 5000 series - does not matter though - the 1 GB shows up as dedicated VRAM. Its not using intel. :-)

If you have games - please test it. Batman arkham city was zappy than before! There was a glitch though - had to reinstall Window Game live components. Copy xlive files from systemwow64 to system32 - the live component came back into the game.

Alcohol 52% needed reinstallation and works like charm. Till doing testing around the system. To make sure the settings are working around.

Source:
1. For video troubleshooting details: http://www.eightforums.com/graphic-cards/7088-win-8-amd-switchable-graphics-faq.html
2. For Window live gaming components: http://forums.steampowered.com/forums/showthread.php?t=2318449

Do post your efforts after the fix is done, we can compare solutions for common issues.

Do not undo the DSE/certificate settings after running the 3rd party utility. It will revert to a default nasty looking display driver. Just did it and after putting the certificate setting back the display was soooo much better.

MSI should make a standard driver update for Windows 8 pro with signed driver modules rather than the default Win7 drivers which are based on Winvista.
 

john4good

New member
SERGEANT
Joined
Dec 21, 2012
Messages
32
>Do not update intel drivers from windows update<

No clue how to switch between ati and intel video cards. Through Windows update a intel driver was installed. Screen went blank. Restarted the system by pressing the power button. Reinstalled the ati driver by running the custom catalyst tool. Got Ati display back.
========
In my case LA Noire was not working - installed a patch update from rockstar and did not help. Some where within their suggested help links, they advised to install the Windows 8 pro updates.

There were 3 udpates that did not install earlier. It took like half an hr for those updates to show up as a problem of some sort, undo itself and restart over like 3 times. So this time, installed it one by one according to the id numbers - ascending order - all updates got installed - And Vola - LA Noire works.
===========
switchable graphics work by pressing the panel buttons - don't know how it worked, but it works for now. Earlier the backlight dimming, sound and others were working except for the graphics switch. :-)
 

john4good

New member
SERGEANT
Joined
Dec 21, 2012
Messages
32
After the upgrade a lot of time was spent to figure the main issue of non functional tiles. Had Microsoft support rep remote in to work 3 hr into the issue.

From an online forum learned that a folder c:\windows\UAInstallAgent was missing for the tiles to work. After creating the folder few of the installed 3rd party tiles were working and other were not. Microsoft standard tiles were not working at all. The Store would work. So did a Refresh PC option = this gets rid of all the software but leaves your private files. Use the driver installation mentioned in the above first post - it brings the test mode for win8. The rep was saying this has to be disabled for tiles to work - so finally reverted back to the standard Intel video.

After running a few tools for integrity and component testing...blah blah. I had it with the troubleshooting and the MS support rep asked for a fresh install. Was not happy with it at all, asked for the refund. Closed the call.

Out of curiosity had to get it to work:  :idea:
1. Recovered the win7 backup (because I did an upgrade)
2. Installed Win8pro on a new partition (got a dual boot)
3. The install went so fast about half an hour (the upgrade was a sleepy 2 and an half hrs)
4. All tiles are working, found the UAInstallAgent is in place
5. The Intel video driver was detected as default (the highest resolution 1366x768) and updated by the windows update. On accessing the Intel video options - it asked to download .net ver 2 and 3 for the app to work - yes - works fine
6.You don't need to have an online account to have certain tiles to be working (MS support rep wanted to work under an online account to prove that tiles will work there, its not true - mail, calendar, people etc are account centric information- these alone need an online account ). Bing related tiles or Weather, maps, news are not related to your online account, they work fine.
7. Store results were very different when logged under Local Account (signed in with online account) and then switching user to (same) Online Account. When searching for the very same tile under the same categories - the store results were entirely different - newer apps were visible under local account. (talk about Big brother attitude to filter search content!)
8. All Laptop function keys i use normally  - vol related, screen brightness, camera, bluetooth, wireless, numlock are working. Logitech wireless keyboard (with its own shortcut keys) and mouse are working without any extra software installation.
:idea:
9. Now the main part - ATi graphics - this took hours to figure out
a. Found a site (http://www.minecraftforum.net/topic/1086017-ati-radeons-and-windows-8-the-fix/) Kudos to the user Autaall
b. download the Catalyst version 8 (MSI's default version for download or from cd driver is 3)
http://www2.ati.com/DRIVERS/mobile/12-4_mobility_vista_win7_64_dd_ccc.exe
c. Run it - during the setup if it does not list out the display driver - about 90 MB - stop it and run it in 7 compatibility mode with Admin rights
d. Installation will run through
e.  :bonk: the scary part - which is not really scary - the screen might go blank - the hdd light was still blinking - i let it around for few minutes run in the black screen as the setup size was around 200 MB.
f. Windows 8 pro has a shortcut to projector screen  Win+P - there are 4 modes - if you are patient enough and press one by one you will get to the screen that the setting is kept at - the 4 modes are - PC screen only - duplicate - extend - second only - the one that seems to be the right display is "Second screen only" (the 4th one)
g. :bonk: the other scary part II - which is not scary either - you might be stuck with Intel display if you used the right click context menu for switching graphics --- go to device manager - under the display - the ati display will show as disabled - right click and enable it - back to ati
h. To work with the strange display setting - right click on the desktop to open Screen resolution - make sure the setting are brought to your second default display - i can't remember now there were some 4 displays in total (guess it was pulling info from Intel info pool?) - it will show correctly 2 - one should be your screen and the other for hdmi output - my remains at screen number 2
i. Graphics Switch button does not work for now
j. No need for test mode for Win8pro

:welcome: MSI get us an appropriate tool for switching - the product should work for the consumer not vice versa. If there are 100 products to update, there are 100x100 customers to get the product work for. Consumer focus. Thanks. Win8 will work on your laptop given the drivers.
 

john4good

New member
SERGEANT
Joined
Dec 21, 2012
Messages
32
The Camera app from windows gives a very good output for the webcam compared to Win7. Had taken screen shots and really its so much better than the Win7 grainy looks.

There were many Win8pro updates - some are 200 or 400 or so in MB size - its total number of updates itself will make an OS  :hiha:

Anyways, the MS Camera app under Windows Metro will not work anymore. Says "The camera app can't be used with this version of Windows". So tried with other 3rd party metro apps and they just get stuck.

Using the Windows Essential 2012 - Movie Maker - it picks up the webcam without any issues.

Even Video app is affected - will not play default avi files.  :biggthumbsdown:
 

john4good

New member
SERGEANT
Joined
Dec 21, 2012
Messages
32
Another MS support rep called in too. They got my mail about non functional tiles. Had it on selective start up. Had only microsoft services running. This is the new "safe" mode.

Oh boy,  :mad: one mean april prank joke! After restarting we are not getting control of the file explorer or the smart screen interface. As soon as we use the mouse or the shortcut key to make an entry the whole process freezes. The MS rep tried to restart more than 3 times just to make the system response.

Guess what - no safe mode - no f5 or f8 keys to get into troubleshooting screen - MS rep disconnected the remote session, i disconnected the internet. Tried to get any form of access. Still freezes in the file explorer or smart screen. He asked me to remove the laptop battery as it was running. Firmly told him I am not happy with you. I don't to follow any more advice.

On another restart i quickly press ctl+alt+del and accessed the task manager for there. Was able to type in the msconfig command, made it to normal startup and on restart - oh boy got the control back.

Another MS support rep took over, this time uninstalling updates one by one will we come to know which one was responsible to affect the camera app. This did not help either. The network tile i had that monitored bandwidth usage stopped working.

:confused2: Ms support is not taking steps to understand where the issue is. The tile issue is getting spread over every related tiles. Looks like tiles are using a common resource pool. One gets affected, another can show symptions as well. Under the Metro environment - If MS camera app is not working all downloaded 3rd part app are not working too. They were trying to get afte the webcam driver etc. It all worked fine before the Windows updates were done.

Applications in your desktop environment will work great. Got to install my old usb EasyCAP video grabber and works great. Able to use my Sony Cybershot camera as a webcam capture device.

One event was observed, using MS application such as Movie Maker, the laptop's camera will get disconnected. Use a BisonCAM pro camera application and here too behaves in the same manner - both instances it says that another application is taking control.

Where as a application from NCH called Debut video capture does not loose control of the device while capture or standby.

:sleep: need to catch up with some sleep
 

john4good

New member
SERGEANT
Joined
Dec 21, 2012
Messages
32
The ATi display driver found (4th post) was useful to get the ATI card to run. Whereas Intel driver was updated by Windows. No switching other than disabling the card used now and getting switched over automatically to the other.

Due to the earlier issue of MS metro camera and video tiles not functioning properly, I uninstalled the Ati and intel drivers.

Installed the standard Win7 drivers with compatibility and admin rights. Switching was possible after this. Tiles are working without issues.

The catalyst options from version 8 seems better than ver 3 that comes with standard drivers.

:noidea: MSI getting any updates for me??? I worked hard to show the product is functional, but still need updated drivers get Windows8pro work on the laptop flawlessly.
 

giveaway144

New member
PRIVATE E-2
Joined
Dec 7, 2017
Messages
2
Sidenote:
I had a similar problem with a new amd card on my desktop that had win8.1 installed.
AMD have stopped supporting win8 drivers on some of their cards ,just win7 and win10 now.
I had to use win7 drivers and also edit the inf file that came with the drivers to get it working.
 

joelsbarco

New member
PRIVATE E-2
Joined
Feb 22, 2020
Messages
1
The most relevant program for Driver pack solution's for windows 8.1 pro free download 64 bit is Driver Pack Solution. Get a free download for Driver's software in the specialized download selection. plz visit here:- Account recovery form gmail
 

marthaneidig8457

New member
PRIVATE E-2
Joined
Mar 18, 2020
Messages
1
Formatting the disk of your pc from time to time help's you to keep the system in the best shape from inside out. But while formatting your pc, make sure to make a backup every time to secure the data from start lost in the torrent of formatting. Read more:- How to Format a Laptop on Windows.
 

aiomag.xyz

New member
PRIVATE E-2
Joined
Mar 31, 2020
Messages
1
I had the exact same problem, but then I decided to install Windows 10 after 4 years
I have to say my speed is very fast and the whole program loads fast
Think of Windows 8 and 8.1 :)


Also, my laptop MSI GE60 is one of the best
;)
 

rebeccaburrr

New member
PRIVATE E-2
Joined
Apr 21, 2020
Messages
4
Amanda10 date=1585671251 said:
I had the exact same problem, but then I decided to install Windows 10 after 4 years
I have to say my speed is very fast and the whole program loads fast
Think of Windows 8 and 8.1 :)


Also, my laptop MSI GE60 is one of the best
;)
You did a great job,switched to Windows 10 is a good idea.
 
You must log in or register to reply.
Top