X570 wake from sleep on keyboard but not mouse

anthon157402d9

New member
Joined
Jan 12, 2022
Messages
1
Hi I have a MEG x570 unify that has a strange behavior that I was hoping someone can help me with.
I would like to be able to wake from sleep by press a keyboard key, but not from moving or clicking the mouse (as it is easy for someone to bump the mouse and hence wake the PC).
On my previous intel based board it was just a matter of disabling the "allow to wake the computer" option in device manager for the mouse.
On this AMD board though, the usb keyboard and mouse do not wake the computer at all, moving the mouse causes the mouse lights to switch on, but nothing wakes up.
This is with the bios setup for OS controlling the wake events. If I switch to bios then the keyboard and mouse wake up the pc - however I cannot selectively choose only the keyboard, so a bump of the mouse causes the system to wake up which is not ideal for me.
I would really like to be able to set the bios wake events as handled by the OS and then configure the OS, but in this mode only the power button will make the PC.
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
8,436
I have full AMD build with Wireless KB and Mouse and they dont wake PC even though I have them set to
 

hatomun154e02d5

New member
Joined
May 20, 2022
Messages
1
I am also using a MEGx570 and used to be able to resume with the keyboard, but after replacing the video card and clearing the CMOS, I am experiencing the same symptoms.
I tried changing the ACPI setting from [S3 enabled] to [Modern Standby + S0i3], but there was no improvement at all.
I have also tried changing various settings on the Win10 side, but to no avail.
 

eqwebbie_with_PC

Experienced Dummy
Joined
Aug 22, 2020
Messages
858
Hi,
I would try to disable "ErP Ready" under "Power Management Setup".
ErP Ready [Disabled]
Enables or disables the system power consumption according to ErP regulation.
[Enabled] Optimize the system power consumption according to ErP regulation. It will not support S4 & S5 wake up by USB, PCI and PCIe devices.
[Disabled]Disables this function.
If that does not work, I would try disabling "selective USB power saving" in advanced Windows power plan setting.

Good luck!
 
Joined
Oct 7, 2021
Messages
102
Alternatively, wireless mice tend to have a power switch on the underside and you can always turn it off immediately after invoking sleep.

This is what I do on my Windows and Arch rigs but if I'm not quick enough turning the mouse off, they'll wake right up ...
 
Top