X58 Platinum I/O panel eSATA doesn't work

SeanP314

New member
SERGEANT
Joined
Mar 5, 2009
Messages
24
Hey everyone,

I've got an external eSATA drive that I know is good. It works just fine with its USB and Firewire ports, and it even works with the eSATA port on my box that is connected to one of the internal SATA connections. It just doesn't work with the I/O panel eSATA port.

According to liveupdate, I've got the most recent drivers for Vista Business x64.

Anyone got a suggestion for me?

Thanks!
 

HU16E

New member
GENERAL OF THE ARMY
Joined
Jul 9, 2008
Messages
11,111
Check in Bios - Integrated Peripherals - Extra RAID/IDE Controller (Uses the JMB322) - & make sure it is set to 'Enabled'.
 

HU16E

New member
GENERAL OF THE ARMY
Joined
Jul 9, 2008
Messages
11,111
Since the setting is 'Enabled', it's time for you to contact MSI Tech. Support for help.

http://ocss.msi.com.tw

Edit: For clarification, is your E-SATA drive an external HDD or optical device? Let us know what Tech. Support recommends.
 

SeanP314

New member
SERGEANT
Joined
Mar 5, 2009
Messages
24
I think you're on to something with the storage controllers. I downloaded and installed the packages.... twice.... but I only get one jmicron device to show up. I'll send MSI a ticket.

Thanks for all your help guys!
 

NovJoe

New member
GENERAL OF THE ARMY
Joined
Feb 27, 2003
Messages
19,148
You mean you don't see the JMicron RAID drivers?
 

NovJoe

New member
GENERAL OF THE ARMY
Joined
Feb 27, 2003
Messages
19,148
I think you should try installing the JMicron RAID drivers again using Windows installer disc via the F6 option for 3rd party SCSI / RAID controller driver.
 

SeanP314

New member
SERGEANT
Joined
Mar 5, 2009
Messages
24
Alright, got it fixed with MSI tech support. I uninstalled the device and deleted drives, then installed the package that came on the CD. They definitely could include better directions....

Thanks!
 

NovJoe

New member
GENERAL OF THE ARMY
Joined
Feb 27, 2003
Messages
19,148
At least we know that there's another workaround ;).
 
Top