X99A Gaming 7 pcie config with added M.2 adapter

necrogeddon_

New member
PRIVATE E-2
Joined
Nov 6, 2016
Messages
7
Hello. I own the mobo in the title. I have a Samsung NVMe drive in the native slot for my system and recently bought an NVMe pcie adapter so I could connect another drive like this one. CPU is i7 5930K with 40 lanes. My graphics card is in the 1st pcie slot, 2nd pcie slot in empty, 1 device in the pcie x1 slot, 3rd pcie empty and last pcie slot has the adapter I got which is a x4 pcie. In this config my native SSD works 5 times slower than its normal speed, if I remove the nvme pcie adapetr from the last slot to the 3rd, my native ssd is back to full speed but my graphics card is working at x8 and not x16. I have tried many combinations but every time something loses it's full potential. I cant believe that a 40 lane CPU cant handle all this. Any ideas?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
77,141
Loading all related data:


data5.PNG



The SATA5 and SATA6 ports will be unavailable when installing a M.2 SATA
interface module in the M.2 port.

4x PCIe 3.0 x16 slots, support up to 3-way mode
- 1-way mode: x16/ x0/ x0/ x0
- 2-way mode: x16/ x16/ x0/ x0*, 16/ x8/ x0/ x0**
- 3-way mode: x16/ x16/ x0/ x8*, x8/ x8/ x8/ x0**
■ 2x PCIe 2.0 x1 slots
* For the CPU that supports 40 PCIe lanes
** For the CPU that supports 28 PCIe lanes


*********************************


Hello. I own the mobo in the title. I have a Samsung NVMe drive in the native slot for my system and recently bought an NVMe pcie adapter so I could connect another drive like this one. CPU is i7 5930K with 40 lanes. My graphics card is in the 1st pcie slot, 2nd pcie slot in empty, 1 device in the pcie x1 slot, 3rd pcie empty and last pcie slot has the adapter I got which is a x4 pcie. In this config my native SSD works 5 times slower than its normal speed, if I remove the nvme pcie adapetr from the last slot to the 3rd, my native ssd is back to full speed but my graphics card is working at x8 and not x16. I have tried many combinations but every time something loses it's full potential. I cant believe that a 40 lane CPU cant handle all this. Any ideas?
In this config my native SSD works 5 times slower than its normal speed,
In this config:
At what lines the M.2 drive is operating?
and what are the pcie adapter lines?
and which pcie adapter you use?
 

necrogeddon_

New member
PRIVATE E-2
Joined
Nov 6, 2016
Messages
7
Loading all related data:


View attachment 148323


The SATA5 and SATA6 ports will be unavailable when installing a M.2 SATA
interface module in the M.2 port.

4x PCIe 3.0 x16 slots, support up to 3-way mode
- 1-way mode: x16/ x0/ x0/ x0
- 2-way mode: x16/ x16/ x0/ x0*, 16/ x8/ x0/ x0**
- 3-way mode: x16/ x16/ x0/ x8*, x8/ x8/ x8/ x0**
■ 2x PCIe 2.0 x1 slots
* For the CPU that supports 40 PCIe lanes
** For the CPU that supports 28 PCIe lanes


*********************************






In this config:
At what lines the M.2 drive is operating?
and what are the pcie adapter lines?
and which pcie adapter you use?
Thank you very much for the quick reply. the M.2 adapter is this one: IB-PCI214M2-HSL . No sata express is used. The current config is graphics card at PCI_E1, the M.2 adapter at PCI_E5, a wifi/bluetooth card in PCI_E4 and the system's M.2 drive in the board's native M.2 slot. PCI_E2 & PCI_E3 are blocked by the GPU so I don't use them. This way I get full speed from both my NVMe SSds but graphics card runs at x8
 

RemusM

Well-known member
LIEUTENANT COLONEL
Joined
Nov 16, 2006
Messages
2,314
The current config is graphics card at PCI_E1, the M.2 adapter at PCI_E5, a wifi/bluetooth card in PCI_E4 and the system's M.2 drive in the board's native M.2 slot. PCI_E2 & PCI_E3 are blocked by the GPU so I don't use them.
This way I get full speed from both my NVMe SSds but graphics card runs at x8
If you have something in PCI_E5, the first slot (PCI_E1) is downgraded to x8
No matter if you have a CPU with 28 or 40 lanes.
And that's because half of PCI_E1 is shared with the PCI_E5
Please study the diagram and the bandwidth table.

If you want x16 for the 1st slot, don't put anything in PCI_E5
p.s.
If you don't have a "monster" GPU, there is no performances drop between x8 and x16.
 

necrogeddon_

New member
PRIVATE E-2
Joined
Nov 6, 2016
Messages
7
If you have something in PCI_E5, the first slot (PCI_E1) is downgraded to x8
No matter if you have a CPU with 28 or 40 lanes.
And that's because half of PCI_E1 is shared with the PCI_E5
Please study the diagram and the bandwidth table.

If you want x16 for the 1st slot, don't put anything in PCI_E5
p.s.
If you don't have a "monster" GPU, there is no performances drop between x8 and x16.
Tbh I haven't noticed any low performance of my GPU even running at x8. What if I slot my GPU in PCI_E3 so it wont block PCI_E3 & PCI_E4 anymore and I slot my M.2 adapter in PCI_E1, wont that give me full bandwidth in everything?
 

necrogeddon_

New member
PRIVATE E-2
Joined
Nov 6, 2016
Messages
7
Problem solved! M.2 adapter went to PCI_E1, the wifi/bluetooth card to PCI_E2 and the GPU in PCI_E3. All devices (including the native M.2 slot) work full bandwidth now. Thanks for all the help guys
 
Top