Z790 carbon/RTX 4090/i9 13900k black screen after installing NVIDIA drivers

Joined
Nov 18, 2022
Messages
15
Have you tried to use integrated graphics to display and install older NVIDIA driver?
No, I haven't tried it, I was dealing with this issue yesterday, at some point the monitor turned on... I worked for a couple of minutes in windows 11 and passed out, as if the cable was disconnected... I rolled back the BIOS to version 11, it works fine on it...
 

dramio153502d8

New member
Joined
Nov 9, 2022
Messages
8
How can you tell if there is a beta bios available for the Z790 Carbon? In another thread a beta bios was posted but no idea how to determine if a new one exists.
 

plutomate

Well-known member
MAJOR GENERAL
Joined
Jul 30, 2015
Messages
5,771
1669170757765.png

This is how MSI name their BIOS
ex. 1.20 (MP) > 1.25 (beta) > 1.21 (beta), 1.30 (MP) > 1.20 (MP)
 

plutomate

Well-known member
MAJOR GENERAL
Joined
Jul 30, 2015
Messages
5,771
Thank you, they'll be located on the motherboards bios page or somewhere else?
nah, i just grab the information from link above.
but yeah i do know the naming rule because i've been using MSI board for quite a long time :LOL:
 
Joined
Nov 18, 2022
Messages
15
And I'm still trying to overcome this black screen, after update 1.10 to 1.20, the video card falls off, I tried to remove and install nvidia drivers, the result is the same, the video adapter crashes for an error. the screenshots were made via a laptop by connecting via AnyDesk to a remote desktop.
 

Attachments

dramio153502d8

New member
Joined
Nov 9, 2022
Messages
8
Have you tried setting it to 16x PCI-X instead of auto within bios. If you have the cpu with video maybe try disabling the on board video. I have the cpu without video. I still set my pcie to 16x only. I also turned off the MSI boot so it now displays the motherboard info while booting.
 
Joined
Nov 18, 2022
Messages
15
Have you tried setting it to 16x PCI-X instead of auto within bios. If you have the cpu with video maybe try disabling the on board video. I have the cpu without video. I still set my pcie to 16x only. I also turned off the MSI boot so it now displays the motherboard info while booting.
Yes, I changed it, the desktop even booted up once, after a couple of seconds the PC rebooted itself...
 

fatedust

Survey Corps
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
2,358
And I'm still trying to overcome this black screen, after update 1.10 to 1.20, the video card falls off, I tried to remove and install nvidia drivers, the result is the same, the video adapter crashes for an error. the screenshots were made via a laptop by connecting via AnyDesk to a remote desktop.
I will try with BIOS 122 + latest NVIDIA driver + "Prefer maximum performance" selected in NVIDIA Control Panel > Manage 3D settings > Power management mode.
 
Joined
Nov 18, 2022
Messages
15
I will try with BIOS 122 + latest NVIDIA driver + "Prefer maximum performance" selected in NVIDIA Control Panel > Manage 3D settings > Power management mode.
NVIDIA Panel does not work, it loses the card on new bios versions and disables it from devices, error code 43 is visible in the screenshot
 
Joined
Nov 18, 2022
Messages
15
So if you roll back to BIOS let's say 7D89v11 and everything works?
How about trying your card on other system now? Just want to be sure that it's still working.
Yes, if you flash 7D89v11, everything works, in technical support the last beta was sent to it, everything works on it, this card works on other vendors on the z690 chip with 12 series processors, it also works for me, but on the first versions of bios, it may not make sense to change to more new, but even so, I think that it’s not just that updates are made, but they improve the performance of components
 
Joined
Nov 18, 2022
Messages
15
so did you try disable IGPU in BIOS and Hardware accelerated GPU scheduling as a workaround with new BIOS? I mean that fixes the previous problem with MSI card.
Also, have you reached out to ZOTAC support and see if they provide any VBIOS update?
No, I did not do this as in the instructions in this topic, I disabled the integrated video in the bios, also changed the pci-e gen, it did not help. ZOTAC posted VBIOS on its website, installed it... the result on 1.20 of the MSI BIOS was also , black screen ...
 

ra15b602db

New member
Joined
Nov 12, 2022
Messages
5
Doesnt the 4090 have a nvidia firmware update for display port showing black screen on boot ?
are you using HDMI or Display port output from 4090 ?
 
Joined
Nov 18, 2022
Messages
15
Doesnt the 4090 have a nvidia firmware update for display port showing black screen on boot ?
are you using HDMI or Display port output from 4090 ?
Here is the latest vbios installed:

This VBIOS Update file will work on all ZOTAC GAMING GeForce RTX 4090 cards (AMP Extreme AIRO, Trinity OC, Trinity)

Update Description:
- Addresses a UEFI bug (no display on system power on)
- Correction to a Power Setting bug in FireStorm
OS: Windows 11 64-bit, Windows 10 64-bit
 

ra15b602db

New member
Joined
Nov 12, 2022
Messages
5
Not sure if this helps ? NVIDIA GPU UEFI Firmware Update Tool | NVIDIA (custhelp.com)
Nvidia has released a firmware update tool for its new GeForce RTX 4090 and 4080 GPUs to fix a bug that could break display output, causing the GPU to show a blank screen when being used without drivers installed. The issue only affects "certain motherboards," and Nvidia says it "should only be applied if blank screens are occurring on boot." (We installed it on an RTX 4080 Founders Edition in an Asus motherboard that was working normally and didn't notice any adverse effects.)
 
Joined
Nov 18, 2022
Messages
15
Not sure if this helps ? NVIDIA GPU UEFI Firmware Update Tool | NVIDIA (custhelp.com)
Nvidia has released a firmware update tool for its new GeForce RTX 4090 and 4080 GPUs to fix a bug that could break display output, causing the GPU to show a blank screen when being used without drivers installed. The issue only affects "certain motherboards," and Nvidia says it "should only be applied if blank screens are occurring on boot." (We installed it on an RTX 4080 Founders Edition in an Asus motherboard that was working normally and didn't notice any adverse effects.)
Yes, I have now downloaded the utility, flashed the video card with this utility, installed the latest version of the motherboard bios after, a black screen is present, the video card is detected with an error 43 ... the utility did not help ...

p.s. in principle, everything suits me as it works now on 1.2T1, but many people may face such a problem, according to I am trying to find a solution to this problem both for myself and for others :)
 
Top