Motherboards > Older MSI motherboards

BIOS for PM8PM-V / MS-7222 Ver 3.1 + SIL 3114 Issues


I have a two part question:

Part 1 - BIOS Update

I'm running Ubuntu 10.04.2 Server on a headless box.  Although I have a hard drive with Windows XP on that I can boot the box up with (if I really have to), I cannot get Live Update to detect any new BIOS versions for my motherboard.  From having a look around on the internet I am pretty sure I've seen that there is a more up-to-date version of the BIOS than the one I have.

If I am right, could someone direct me to where I can download the latest version of the BIOS for my motherboard?

My motherboard details:

* Model Name: PM8PM-V
* Model Number: MS-7222 Ver 3.1
* Motherboard firmware: V5.2(POST details: PM8PM-V W7222VMS V5.2 032807 09:58:37)

Part 2 - SIL3114 PCI Card woes

The reason I am asking for the latest version of the BIOS for my board is because I have recently installed a SIL3114 PCI SATA Card in order to be able to access more than two SATA Hdds (the PM8PM-V only has two SATA Ports) and I am having problems with it.  I am trying to eliminate the obvious by updating the BIOS on the motherboard.  I have already flashed the BIOS on the SIL3114 to the most recent (and IDE only) BIOS -

My problem is that when I copy files from one hard drive to another – either between two drives connected to the SATA card ports or between one drive connected to a SATA card port and the other drive connected to a motherboard SATA port – the box hangs after an apparently random period of time or number of files copied.  In fact, the problem occurs whether I try and do any significant amount of operations (typically multiple concurrent file transfer operations) involving a SATA Card connected hard drive.

For the avoidance of doubt, if I copy from drive to drive where the two drives are connected to the motherboard SATA ports, there are no problems.  Also, my PC boots happily into Ubuntu and recognizes all of the attached drives.

Larger (>~100MB) individual files seem to cause the problem every time - usually within 5 minutes of starting a file transfer.  Small groups of small files (i.e. a folder with a CD ripped as FLAC files) will copy without issue about 75% of the time.  Large groups of small files generally cause the box to hang within 5-10 minutes.  Multiple file operations on any of the SATA Card connected drives typically guarantee a hang within a few seconds.

Things I've tried:
- Changing SATA cables – I've got a few spares so I've tried various combinations of ports, drives and cables with the same problem happening each time.
- Changing PCI slots – no luck.
- cp-ing files from the command line – no luck.
- rsync-ing files from the command line – no luck.
- I have jumpered all of the drives to SATA 1.5Gbps - no obvious difference.[/li][/list]

The problem is proving difficult to diagnose as there are no error messages and the computer just hangs.

I know Linux and SIL3114 don't always get on but might there be a simpler explanation that I am missing that relates to how the motherboard and SIL3114 card interface with each other?

Any advice on my second question is greatly appreciated!

Ex Forum User 3:
The last BIOS I can find is this one:
But I doubt it will solve anything.

>>Use the MSI HQ Forum USB flasher<<

Are you sure your hang isn't due to a bad harddisk?
Or overheating CPU?


--- Quote from: Bas on 26-April-11, 12:05:06 ---The last BIOS I can find is this one:

--- End quote ---


--- Quote from: Bas on 26-April-11, 12:05:06 ---But I doubt it will solve anything.

--- End quote ---

And, unfortunately, I'm not expecting it will fix anything either.  But I'm eliminating as many possibilities as as I can.

--- Quote from: Bas on 26-April-11, 12:05:06 ---Are you sure your hang isn't due to a bad harddisk?
Or overheating CPU?

--- End quote ---

I'm reasonably confident that it is not a bad hard disk.  All of the hard disks I have have been running in a stable manner at different times off the mainboard SATA connections.  The thing that has changed is the SIL 3114 SATA Card.

The overheating CPU I can't be so sure about.  However, the CPU has run just fine under much more taxing conditions in the past.  I think my problem is likely to be that the SATA Card is useless.

I just can't seem to find any clues to help diagnose the problem...

Ex Forum User 3:
You may want to supply way more specs: >>Posting Guide<<

...and after a long wait.

It's taken a couple of months for work and family responsibilities to settle down enough that I could devote some time to trying to sort out by issues with the SATA Card properly.

I flashed the BIOS firmware and as expected, it didn't solve the problem.  But I have the latest firmware now so thanks!

After playing around with stuff between the madness of making a living and taking care of the family, I tried one of those things that I dismissed up front as being so obvious it couldn't be the solution.

I booted the computer with a live CD and ran e2fsck on all of the drives.

One drive had an error on it and since it has been repaired, everything has functioned as it is supposed without any issues at all.

I won't waste further space posting my specs as they aren't really necessary now.  Thanks for the help that was offered.  I hope my solution to my stupid mistake helps someone else in future!


[0] Message Index

Go to full version