Please login or register.

Login with username, password and session length
Advanced search  

News:

New members, please remember to read the Forum Rules and the Posting Guide before posting for the first time!

Pages: [1]   Go Down

Author Topic: BIOS update - Disable Firewire  (Read 2618 times)

0 Members and 1 Guest are viewing this topic.

fxmick

  • Neo
  • *
  • Offline Offline
  • Posts: 4
BIOS update - Disable Firewire
« on: 10-January-12, 20:06:14 »

Hi,

I recently flahed  my bios :
Mainboard:  MS-1651
PCB Version:  Ver 1.000
BIOS Version: A1651IMS.114
BIOS Date:  20/11/2009
EC-FW Version: 

I still can't disable firewire from the bios, I can't find any hidden features. I need it in order to install PC-BSD (i'm having run_interrupts_driven_hooks issue and it seems that the only way to fix it is to disable firewire port).

Can you help me fix this ?

Thanking you in anticipation,

Regards.
Logged

Stu

  • Hawk
  • *
  • Offline Offline
  • Posts: 19577
  • Birmingham, UK
    • StuOnline.co.uk
Re: BIOS update - Disable Firewire
« Reply #1 on: 11-January-12, 20:50:03 »

Logged
Former moderator and admin, 2004-2012

fxmick

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: BIOS update - Disable Firewire
« Reply #2 on: 12-January-12, 10:15:21 »

Hi,

MY notenook is a GX620-20.

Ty.
Logged

Ex Forum User 3

  • Hawk
  • *
  • Offline Offline
  • Posts: 26817
Re: BIOS update - Disable Firewire
« Reply #3 on: 12-January-12, 10:48:06 »

Disable the firewire driver in BSD, then it's not used anymore.
But I doubt an unused port causes the problems you describe.
Firewire is pretty standard thing, sure it's firewire doing this?
Logged

fxmick

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: BIOS update - Disable Firewire
« Reply #4 on: 12-January-12, 10:59:01 »

Unfortunately, i can't disable it in BSD because this is during a fresh installation of the system.
I've read that several users have solved the issue by disabling firewire in the BIOS and i have not the feature.

I've found a fix : http://lugm.org/2009/09/24/freebsd8-0rc1-run_interrupt_driven_hooks/ but i'm not ready to edit kernel (the goal is to remove firewire support into the iso).
That's why i'm looking for a way to disable it IN the bios.

Thanks
Logged

Ex Forum User 3

  • Hawk
  • *
  • Offline Offline
  • Posts: 26817
Re: BIOS update - Disable Firewire
« Reply #5 on: 12-January-12, 13:24:52 »

That's from 2009....I doubt it's still in their kernels.
Are you sure it's firewire?
I would think it's maybe your harddisk controller set in AHCI mode and not IDE mode, such is more likely then a firewire port.
Logged

fxmick

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: BIOS update - Disable Firewire
« Reply #6 on: 12-January-12, 13:53:43 »

I'v tried with AHCI mode disabled and it's the same.
Logged

Ex Forum User 3

  • Hawk
  • *
  • Offline Offline
  • Posts: 26817
Re: BIOS update - Disable Firewire
« Reply #7 on: 13-January-12, 00:36:10 »

Try a Linux system instead, could be a BSD issue alone.
Logged
Pages: [1]   Go Up