Please login or register.

Login with username, password and session length
Advanced search  

News:

The Forum FAQ contains answers to many frequently asked questions, please browse or search there before posting.

Pages: [1]   Go Down

Author Topic: MSI GE60 OND disk drive eject button not working  (Read 1893 times)

0 Members and 1 Guest are viewing this topic.

shananigans89

  • Neo
  • *
  • Offline Offline
  • Posts: 2
MSI GE60 OND disk drive eject button not working
« on: 19-July-12, 00:14:27 »

i have a new MSI GE60 OND version and the disk eject button up above the keyboard (part of the 6 quick buttons) is not ejecting my disk. i have uninstalled and re-installed the S-bar application with the most recent version of the program and still no luck.

i have rebooted and tried pushing the button before the OS loads and that does not work either.

i know there is a button actually on the drive that works to open it as well...i would just like the computer to work the way it is supposed to with the button above the keyboard.

thanks for any help
Logged

Philennium

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: MSI GE60 OND disk drive eject button not working
« Reply #1 on: 20-July-12, 04:44:08 »

I just tested the eject button on my GE60 OND, and it did open the disc tray, both with and without a disc in it.

Was yours a custom build of the laptop by any chance? Was the OS re-installed on it or something that might have lost the driver? Could that button somehow have been set to one of the "user defined" keys somehow and is overriding the eject function?

-Phil
Logged

Ruudt

  • Administrator
  • *****
  • Offline Offline
  • Posts: 114
Re: MSI GE60 OND disk drive eject button not working
« Reply #2 on: 20-July-12, 22:04:02 »

The eject button on top needs software to work (i.e. S-bar), when running windows.

You can also test the eject function without a button using Windows explorer. Right click on the DVD drive and select Eject.
This also should eject the tray.

If it does open there might be a problem with the eject button on top (try also the other button on top) or the software (i.e. S-Bar).
Maybe S-bar is conflicting with some other program.

If it doesn't open it might be a mechanical problem of the optical drive.
You can try to use a small pin (maybe a straightened paperclip) to unlock the tray (better turn off the notebook for safety) through the small emergency unlock hole in the bezel of the drive. If you can see any obstruction try to resolve it or send it in for repair. Sometimes the tray's slider is bend too much so it won't open anymore but that doesn't happen all by itself usually. And sometimes the drive is just dead. If you think you cannot solve it by yourself it might be wiser to send it in for repair.


Logged

mikerovak

  • Neo
  • *
  • Offline Offline
  • Posts: 5
Re: MSI GE60 OND disk drive eject button not working
« Reply #3 on: 14-August-13, 04:15:15 »

I had the same problem with my GT783R until I realized what the problem was in my case. At one point I swapped out the optical drive for an additional disk drive with a spare optical drive bay caddy. My laptop is the center of my "media lab" and I have a 12-port USB hub plugged into it and lots of part time peripherals that get swapped in and out as the need arises.

I moved a lot of stuff onto a network available storage, consolidated my disk drives, and then swapped the original optical drive back in. I also have a Virtual Clone Drive installed. After all the swapping, the clone drive is F: and the optical drive is G:.

Turns out, after messing with it a bit, that the S-Bar Eject Switch at the top of the laptop is coded to operate against the FIRST "optical" drive it sees. It worked the eject on the Virtual Clone Drive.

After using Disk Management app to swap the drive letters, making my optical drive F:, all is now restored to the expected and preferred behavior.

Hope your situation is as simple to figure out.

cheers
Logged
Pages: [1]   Go Up