Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Advanced search    

News:

Pages: [1]   Go Down

Author Topic: Need help. MSI GL62 6QF (new laptop) screen flickering.  (Read 3269 times)

0 Members and 1 Guest are viewing this topic.

nerijus.kelpsas1Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1

Good day,

Recently I've bought a new MSI laptop (GL62 6QF), installed all new drivers (using Windows 10 Pro) and decided to test out some games.
I've launched Assassin's Creed 3 on medium settings (fairly easy for 960M) and fps were fine, but the whole screen was twitching, moving and flickering. 
I can't tell if its drivers (BIOS) problem or hardware. Need help. Anyone else had this problem? :nooo:
Logged

sportkung

  • CAPTAIN
  • ****
  • Offline Offline
  • Posts: 749
Re: Need help. MSI GL62 6QF (new laptop) screen flickering.
« Reply #1 on: 26-December-16, 20:42:44 »

You could use [DDU] to remove the Nvidia driver and reinstall 359.00 from following MSI website.
http://www.msi.com/Laptop/support/GL62-6QF.html
 

Besides, maybe you could export the whole system information by latest Help Desk and post that info in here. Let forum guys to help you to check the system configuration and software environment
Logged

4lberto

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 1317
  • I'm Captain-Alberto
Re: Need help. MSI GL62 6QF (new laptop) screen flickering.
« Reply #2 on: 27-December-16, 08:40:10 »

was it only Asssasin's creed ? 


Source : http://www.tomshardware.com/forum/383488-33-graphics-problem-assassins-creed

dheeraj9933:
"when u put the settings on high 
http://www.youtube.com/watch?v=pVAJjWeobs4
does it look like this?
bcoz if it does, then there is no problem with your graphics card.
it is perfectly fine, and no need to worry.
if the game aint good enough to look at, then THAT is just a problem u have with developers!!
and assassins creed is not gpu intensive either! and it is not exactly known for its graphics"

Source : https://forums.geforce.com/default/topic/524275/assassin-39-s-creed-iii-flickering/?offset=2


dkflint723
I noticed that if you enable "Force alternate frame rendering 2" the flickering goes away. So for now, I guess I'll be leaving it on that setting. At least till there is a better SLI profile pushed.



Me: update all your driver AFTER all windows update . verify from MSI support driver page. i did keep the MSI driver in that past for older game . now that i'm playing new game , i use GEforce experience to update them .
Logged
MSI GS70 Stealth i7 4720HQ 12 G /750 GB/ 128 GB SSD

GTX860M GDDR5  2GB

:lookandok:

Make me best solution ! 

Hooah !
Pages: [1]   Go Up