Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: trouble installing StarTech usb 3 on z97 gaming 5  (Read 338 times)

0 Members and 1 Guest are viewing this topic.

scramblurTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
trouble installing StarTech usb 3 on z97 gaming 5
« on: 12-February-18, 20:56:49 »

Hi Folks,

Need to add more USB ports to my PC.  I have a MSI Z97 Gaming 5 and want to add a StarTech PEXUSB3S44V.  

I have updated all my drivers and the motherboard bios.  When I insert the card, I get a PCI-to-PCI driver error.  Further, I no longer get a bios post screen, it passes right by it and never gives me the chance to enter the bios.  

I have tried other PCI slots.  Given how the bios posts differently if this card is inserted or not, I believe I'm dealing with a motherboard issue and not an OS driver issue.

Any ideas?
Logged

darkhawk

  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 11191
« Reply #1 on: 12-February-18, 23:06:43 »

See : >>Posting Guide<<
Give as much info as possible.
Logged
MSI GS73VR 6RF
I7 6700HQ
16 GB DDR4
GTX1060 6GB

MSI X370 SLI Plus
Ryzen 5 1500X
16 GB DDR4
R9 290X
GTX1050Ti

scramblurTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
« Reply #2 on: 13-February-18, 16:42:37 »

Given I feel this is a hardware issue, are there any specific bios settings I should adjust?  Any known compatibility issues?  Anyone else using this card and motherboard combo with any luck?
Logged

darkhawk

  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 11191
« Reply #3 on: 13-February-18, 17:57:41 »

Given I feel this is a hardware issue, are there any specific bios settings I should adjust?  Any known compatibility issues?  Anyone else using this card and motherboard combo with any luck?

Given that I don't have much, if any, real information, I cannot speculate on anything you suggest.
See : >>Posting Guide<<
Logged
MSI GS73VR 6RF
I7 6700HQ
16 GB DDR4
GTX1060 6GB

MSI X370 SLI Plus
Ryzen 5 1500X
16 GB DDR4
R9 290X
GTX1050Ti

scramblurTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
« Reply #4 on: 13-February-18, 19:43:36 »

Since I'm asking to focus on the hardware, my question is specific to a particular motherboard and usb card working together (original post).

You want to help, which is why you keep asking me to be more specific. Maybe you can demonstrate by being specific on what you need to know, and we can make this thread useful to others.

I know others have had issues getting this card to work, with other motherboards.  I've come here to address this motherboard (if that is the issue).  Let's be productive... what info can I offer to help you help me?
Logged

darkhawk

  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 11191
« Reply #5 on: 13-February-18, 20:45:30 »

Since I'm asking to focus on the hardware, my question is specific to a particular motherboard and usb card working together (original post).

You want to help, which is why you keep asking me to be more specific. Maybe you can demonstrate by being specific on what you need to know, and we can make this thread useful to others.

I know others have had issues getting this card to work, with other motherboards.  I've come here to address this motherboard (if that is the issue).  Let's be productive... what info can I offer to help you help me?

Click the link. >>Posting Guide<<
Everything is there. 
I don't know why listing what hardware you have is such a problem. 

I'm all for being productive, but I'm not the one here that's hindering that goal at this time....
Logged
MSI GS73VR 6RF
I7 6700HQ
16 GB DDR4
GTX1060 6GB

MSI X370 SLI Plus
Ryzen 5 1500X
16 GB DDR4
R9 290X
GTX1050Ti

linds1234

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1
« Reply #6 on: 03-May-18, 14:03:04 »

Hi All,

I thought I'd post in this topic as I have exactly the same hardware as OP. Might help out others with this combo.

The PCIE ports were initially set to 8x/4x/4x, thinking that would be enough as far as compatibility goes. But on this setting alone the PC wouldn't event POST.

I set the "PEG2" slot (the bottom of the 3), to "Gen2". It then booted fine. I just went with the native Windows 10 drivers for the card as I've heard they are newer than the Startech card. All is working well.

Cheers,
Lindsay
Logged

Nichrome

  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 15075
« Reply #7 on: 03-May-18, 17:21:46 »

Thanks for input :)
Logged
I only take responsibility for what I say, not for what you understand.  Any posts are my own views!
Pages: [1]   Go Up