Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD  (Read 4538 times)

0 Members and 1 Guest are viewing this topic.
This topic contains a post which is marked as Best Answer. Press here if you would like to see it.

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18

2990WX
X399 Creation
Bios: 7B92V11
G.Skill 64 GB DDR4-3200

enable win 10 support, run raidxpert 2, can only find nvme ssd attached to pcie using[font=DINCondMediumRegular, Arial, Helvetica, "Microsoft JhengHei", sans-serif] [/font][/color][font=DINCondMediumRegular, Arial, Helvetica, "Microsoft JhengHei", sans-serif]M.2 XPANDER-AERO, however even no m.2, raidxpert 2 cannot detect any drive through sata, click rescan can only find m.2 sdd, if i turn off win 10 support to get legacy mode, raidxpert 2 won't even show up.[/font][/color]

[font=DINCondMediumRegular, Arial, Helvetica, "Microsoft JhengHei", sans-serif]i know MSI trying to get nvme raid through the update, however there are still a lot of old school guy like myself want to use hdd raid.[/font][/color]
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #1 on: 30-August-18, 13:55:06 »

calvin.82110, please tell us more.  Are you talking about the RAIDXpert2 (RX2) in the UEFI or W10?  What version of  W10 are you running?  Please post a screenshot of RX2.  Did you Enable SATA RAID?  Something really strange is going on with your post, I cannot see most of it.  Please open it, Preview and correct it.  Perhaps you used some controls and did not close one.    Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #2 on: 31-August-18, 02:25:32 »

Yes, it is the raidxpert 2 in the uefi (bios) i want to setup a hardward raid, not windows raid
I am using 1803 build but dont think it is related
Logged

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #3 on: 31-August-18, 02:27:02 »

P.s. of course i have enabled raid on sata, will attach screenshoot
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #4 on: 31-August-18, 10:07:15 »

calvin.82110, first, please go to your first post and correct the errors so it can be read.  Please install RX2 in Windows.  You can DL it from the AMD Driver Download website.   Post a screenshot from it not the one in UEFI.  Make sure you are running the latest chip set drivers DLed from the same site.  Also DL your RAID drivers here.  What RAID drivers are you running now?  Where is your W10 installed?  Is it a fresh install, not cloned?  You are running 64 bit W10, right?  Please post your system specifications: SATA drives, NVMe drives and where installed (Board or Aero), power supply, etc.  Is CSM Enabled or Disabled?
Here are my RAIDs:
http://" />
Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #5 on: 31-August-18, 10:34:57 »

For some reason if i login using google login, the forum doesn't allow me to modified my previous post after logout (as it doesn't know it is mine).

My windows is fresh installed on the m.2 ssd

I have tried to install RX2 in windows (both attempted from amd site and msi site), the msi site one only say driver installed but no software is provided, if you install the amd driver afterward it will result in a crash.

install AMD site RX2 after fresh windows will not result in crash, but when i run RX2 it will open browser and ask me to login, default admin/admin doesn't work because the submit button is greyed out.

SATA drives (SATA 1 /2 port, 4TB Western Digital Gold)

NVME drive (Samsung 950 pro on aero)

Power supply EVGA 1600W P2

CSM: there is no option for CSM in X399 creation (unless i cannot find it), enable win 10 support will auto turn off CSM, disable it will give legacy + UEFI or UEFI only options, both will not show RAIDxpert 2 in bios.
Logged

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #6 on: 31-August-18, 10:37:29 »

p.s. yes win 10 64-bit
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #7 on: 31-August-18, 11:02:18 »

Thanks, calvin.82110.  I have only been here shortly and already discovered that MSI web sites are really weird.  I actually saw your first post corrected, but when I logged on to reply it was gone. 
I should have posted my system:
ASRock Fatal1ty X399 Pro Gaming, Threadripper 1950X, 2xSamsung SSD 960 EVO RAID0, 4xSSD
960 EVO on ASRock Ultra Quad, 1TB & 500 GB WD Black, G.SKILL [Flare X (for AMD)] F4-
3200C14Q-32GFX, Windows 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler,
Radeon RX580, BIOS 3.30, AGESA ThreadRipperPI-SP3r2-1.1.0.1.
I am here to learn about your board because I plan on a build with it and to help if I can.  Please get your AMD files from AMD not MSI unless they direct otherwise.  Vendor DLs are almost always down level.  I suspect you do not have the RAID drivers in W10.  Please install them and try RX2 again.  If you get another error message, please post a screenshot.  Is W10 installed on the Aero or on the board?  Please post a screenshot of your Disk Management screen in W10 showing all your drives.  You did not say what RAID drivers you are running - please do.  You should be running 9.2.0.70 unless MSI says otherwise.  I am curious what AGESA you are running - latest CPU-Z will tell you; please post.  Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #8 on: 31-August-18, 11:30:41 »

Frankly i do not think it is windows related, UEFI (bios) should able to set up hardware raid and it is "pre-windows", I can setup software raid without RAIDxpert 2 because windows also offer "striped volume"

thanks for your time, i think i will take this to the MSI support however the board is so new they don't even let me select the board
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #9 on: 31-August-18, 13:09:24 »

Thanks, calvin.82110.  Of course, do as you wish, but if you were to answer my questions, I may be able to help you - have helped many with RAID and other problems.  RX2 running in W10 does not create SW RAIDs.  The RAID10 you see on my screenshot was created in RX2 in W10.  It is much easier to use than the UEFI.  I only use the UEFI RX2 when creating my boot RAID.  I have never used the SW RAIDs offered in Windows.
You are welcome.  I am glad to help when I can and sorry I could not help you.  Enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #10 on: 31-August-18, 13:32:38 »

There is no error, as i said i installed XR2 directly from amd site: https://support.amd.com/en-us/kb-articles/Pages/NVMe-RAID-Support-for-the-AMD-Ryzen-Threadripper-platform.aspx

however i am unable to login even i input the default user and password admin/admin.

the RAID driver is surely installed because before there is no error in the device manager (before the RAID driver were shown as question mark)

the nvme ssd is in aero
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #11 on: 31-August-18, 14:27:11 »

calvin.82110, if you would like to continue, please answer my questions.  Do you have a RAID created?  How many NVMe drives do you have on the Aero and on the MB?  How many HDDs and SSDs plugged into the SATA?  Please post a screenshot of the Storage Controllers area of your Device Manager.  It should look like this:
Thanks and enjoy, John
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #12 on: 01-September-18, 00:57:39 »



as you can see, even the windows RX2 can only show SSD, which I have 2 4TB in the disk manager
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #13 on: 01-September-18, 10:19:11 »

Great, calvin.82110, thanks much!  Now I think we can try some things.  I will think for a while, but  here is what I am thinking now.  Please answer my questions and tell me what you think.  A one SSD RAID is probably just an little slower than the raw drive, so I propose deleting the Legacy RAID and installing W10 on the 950 SSD.  I reviewed the W10 WHQL setting in your UEFI and I want you to install in pure UEFI only mode.  First in the UEFI do a Load UEFI Defaults then Save and Exit.  Go back into UEFI and set SATA Mode to RAID but leave NVMe RAID Mode disabled.  Set the Win10 modes as required to be pure UEFI mode.  Now boot to the Boot Menu and select the USB (assume) with W10 files in UEFI mode.  Make sure your 950 is GPT Style.  Do a Load Driver in Windows Setup and be sure to install version 9.2.0.70 DLed from the AMD driver website.  After W10 is installed, please install RX2, and post a screenshot as before.
Now some questions:
Is the one 950 SSD all you have on the Aero?  I looked for a document for the Aero and could not find one.  I assume you have one - please tell me where to DL it.  I tried to Edit by previous Reply last night and could find no way to do it.  I am fairly sure a user cannot Delete a post and perhaps not even Edit it.  I am assuming you want to make a RAID with the 2 4TB HDDs - correct?  Please give me the details - type of RAID and what about the other two HDDs?  You should know that when you set SATA Mode to RAID, all SATA drives will need to be RAIDs to be usable.  I do not know how you got your SSD into Legacy mode but I recommend if you just want the non-RAIDed devices to be normal HDDs, then create a Volume RAID on each one - first Delete them then RAID (Volume) them.  When dealing with non boot RAIDs it is easiest to use RX2 in W10.  You should be able to see all your drives and create what kind of RAID you want.  Then you go to Disk Management, partition and format them.
Please ask any questions before you start and let me know what you think.
Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #14 on: 02-September-18, 09:59:09 »

1. there is no ssd raid, just single ssd on aero, it is marked as raid array for no reason, if i delete it result unable to boot in windows
2. if you turn on W10 WHQL (which i did), it will default to install windows in pure UEFI only, you cannot install windows as legacy.
3. you cannot choose NVMe Raid, there is only one setting where you can choose RAID of ACHI, which is the SATA
4. if the windows is installed in UEFI mode on ssd, it must be GPT
5. SSD is the only ssd on the Aero and the only ssd in the PC, there is no document for Aero because it comes with the motherboard and the motherboard Manuel is the only doc for me
6. yes i want to set up raid 0 for my 2 4TB
7. i tried to deleted the "raid" it setup for my single ssd, i can do that but then the windows won't boot afterward even i setup a array with the single ssd again.

i think from all the information i can only try to install ssd in ACHI mode with UEFI windows, then change it to Raid, yet i have low confident this will work
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #15 on: 02-September-18, 10:43:08 »

calvin.82110, RAID is an AMD function not a MB function and MSI has made it much more complicated that it needs to be and been fancy with the Super RAID, what ever that is.  It is poorly implemented and I have worked extensively with AMD to understand it.  AMD support and I came to understand it and it is not what I see in the MSI documentation.  I have read the MSI manual on RAID and Aero and do not get a good feeling.  In other machines I have worked on, SATA and NVMe RAID functions are separate.  You can run one or the other or both.  I will need to do some research to see how to create a SATA only RAID environment.  It seems to me you have run into a gigantic bug.  I installed the latest UEFI for my ASRock X399 board and have many problems, so it is common.  I want you to do a fresh W10 insall, so not being able to boot the current system is not a problem.  If you do not want to do this, please let me know and I will surrender.  Will let you hear what I learn.  Enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #16 on: 02-September-18, 16:08:34 »

OK, calvin.82110, I think I have figured it out.  Please watch this video.  MSI RAID is really the same as my ASRock MB.  The screens are essentially the same with minor differences.  Open your UEFI, go into RX2 (in UEFI) and delete the one M.2 SSD RAID you have.  Use the procedure in the video to create your your two drive SATA RAID.  It looks like you click Create and RX2 asked what type of drives.  You have the same three choices as I have (SATA, SSD and Both).  Please select SATA.  Now RX2 should show SATA drives only.  Select your wanted two drives and proceed as in the video.  You will need to install RAID drivers to see your RAID.  Install W10 on your SDD.  Please ask questions but remember I cannot see in your UEFI, only the video.  MSI should have placed a link in your manual to this video.  F12 can be used to take a screenshot in your UEFI see manual.  Enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #17 on: 03-September-18, 06:28:39 »

I have tried everything and watched that video since day one.

if i remove the array and create again, only m.2 ssd can be scanned, select SATA (actually it shows HDD) will not give you any device.

Yes NVMe and SATA Raid controller should be seperated, but there is no such options on this board, this is the first and last time i will get a msi board on high end machine, i had no choice because Asus is not ready for 2990WX.
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #18 on: 03-September-18, 09:44:58 »

calvin.82110, I think it is time for you to open an MSI technical support request and give them a hard time.  How did you find the video?  I found it through Google and not any MSI document.  These problems always seem to start with poor documentation.    This may just be a startup problem and right now I think MSI is the only game in town especially with the 16 phase CPU VRM.  I have an open e-mail request and plan on calling today when I get a minute.  I will let you hear if I learn anything.  I will resolve this for my own sanity in MB selection.  Sorry I could not help but PLEASE let me hear what you learn!  Thanks and enjoy, John
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #19 on: 03-September-18, 15:15:44 »

just google msi x399 raid is the first thing that pop up, ez.

don't think i can send ticket because as i said, the motherboard is so new they don't even let you select it.

my previous experience with msi is their bios have problem on x99 that cause m.2 nvme unable to upgrade to win 10 1703 onward, it took msi a year to fix that by releasing a new bios, so i won't put much hope on them
Logged

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #20 on: 05-September-18, 06:55:18 »

jhchris2 get intouch with msi beta bios and pm me the link, however it still doesnt work (as expected)
Logged

Svet

  • T9246ED
  • Administrator
  • *****
  • Offline Offline
  • Posts: 73188

you can try this beta bios .123:
https://drive.google.com/file/d/1AU9Jg9dqYF3BccLjfmArLJGGyqUVyE-v/view
you can try it anyway.

Follow this SOP to how to create SATA raid on X399:
1.       Go to BIOS, enable RAID mode and UEFI
2.       RaidXpert2 Setup
test hardware example: 1 NVME M.2 SSD as OS drive, 2 SATA SSD RAID and 2 SATA HDD RAID as data drive.
a.       Make sure user delete all the array on the existing storage device from BIOS\Settings\Advanced\RAIDXpert2 Configuration Utility\Array Management\Delete Array
b.      Create RAID volume for NVME M.2



c.       Create RAID 0 for 2 SSD


d.      Create RAID 0 for 2 HDD
3.       Install OS (win10 Pro x64 1803)
4.       Load Driver
a.       Load AMD 9.2.0.70\Packages\Drivers\SBDrv\RAID_NVME\RAID_bottom\WT64A once


b.      Load AMD 9.2.0.70\Packages\Drivers\SBDrv\RAID_NVME\RAID_driver\WT64A once


c.       After that, all RAID volume should appear in the list


5.       Continue and finish the installation, the motherboard would pick up all the RAID array in the device manager
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #22 on: 06-September-18, 09:57:32 »

Svet, I do not have an MSI MB yet but I am curious why the rccfg driver files are not loaded in your SOP?  I always load them on my X399 board with 1950X.  Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #23 on: 07-September-18, 02:07:50 »

you can try this beta bios .123:
https://drive.google.com/file/d/1AU9Jg9dqYF3BccLjfmArLJGGyqUVyE-v/view
you can try it anyway.

Follow this SOP to how to create SATA raid on X399:
1.       Go to BIOS, enable RAID mode and UEFI
2.       RaidXpert2 Setup
test hardware example: 1 NVME M.2 SSD as OS drive, 2 SATA SSD RAID and 2 SATA HDD RAID as data drive.
a.       Make sure user delete all the array on the existing storage device from BIOS\Settings\Advanced\RAIDXpert2 Configuration Utility\Array Management\Delete Array
b.      Create RAID volume for NVME M.2
c.       Create RAID 0 for 2 SSD
d.      Create RAID 0 for 2 HDD
3.       Install OS (win10 Pro x64 1803)
4.       Load Driver
a.       Load AMD 9.2.0.70\Packages\Drivers\SBDrv\RAID_NVME\RAID_bottom\WT64A once
b.      Load AMD 9.2.0.70\Packages\Drivers\SBDrv\RAID_NVME\RAID_driver\WT64A once
c.       After that, all RAID volume should appear in the list
5.       Continue and finish the installation, the motherboard would pick up all the RAID array in the device manager

Thanks, tried last night but still unable to see any sata drive, as you can see attachment, it is set on RAID and you can see all the drives on the first page, however raidxpert 2 still can only scan nvme ssd as physical drive. your test is base on 2990WX?
Logged

plutomate

  • MAJOR GENERAL
  • ***
  • Offline Offline
  • Posts: 3052
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #24 on: 07-September-18, 10:16:10 »

did you "delete" all the array? can you check there's nothing in BIOS\Settings\Advanced\RAIDXpert2 Configuration Utility\Array Management\Delete Array?
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #25 on: 07-September-18, 10:48:17 »

calvin.82110, please tell us something.  Are you saying you were unsuccessful?  What steps did you take?  We can see your two 4TB WD drives.  Did you try to Enable them?  BTW, it looks like you can use F12 to get a screenshot in UEFI.  Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #26 on: 07-September-18, 12:12:14 »

plutomate: yes, deleted "all" array when there is only one, a single ssd on aero, also it is such a pain in the ass each time you remove the array, you need to reinstall the windows once

jhchrist2: are you following all this time? unsuccessful to scan any sata drive as physical drives, so you cannot create any array with HDD/SSD plug into sata, in raidxpert 2 all sata drives are non-exist, cannot be found no matter what you do, of course i can use them as normal drives (the picture show they are connected to the sata ports and the bios can see it, but RX2 can't), however they cannot be raid
Logged

plutomate

  • MAJOR GENERAL
  • ***
  • Offline Offline
  • Posts: 3052
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #27 on: 07-September-18, 12:30:59 »

this might sound extremely stupid and unrealistic, but do you happen to have another CPU such as 2950X or 1950X to try?
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #28 on: 07-September-18, 13:52:59 »

yes, calvin.82110 I am following.  As I said as you started trying the Beta UEFIs, I will resolve this for myself.  I may well be right here in a month or two.  Enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #29 on: 08-September-18, 12:44:17 »

this might sound extremely stupid and unrealistic, but do you happen to have another CPU such as 2950X or 1950X to try?
i wish i have :(
Logged

Svet

  • T9246ED
  • Administrator
  • *****
  • Offline Offline
  • Posts: 73188
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #30 on: 09-September-18, 22:02:51 »

Thanks, tried last night but still unable to see any sata drive, as you can see attachment, it is set on RAID and you can see all the drives on the first page, however raidxpert 2 still can only scan nvme ssd as physical drive. your test is base on 2990WX?

2990X, see attached
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #31 on: 10-September-18, 13:50:30 »

HUH?????????
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #32 on: 12-September-18, 08:48:28 »

hmmm, is 2990x the engineering sample for 2990wx, i gave up because i don't see why it doesn't work on my board, the only difference is the cpu however i don't have other cpu to test
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #33 on: 12-September-18, 12:40:05 »

calvin.82110, I do not think it is time to give up, yet.  I suggest you call the support number and see if you can talk to Svet.  Please look in your Device Manafger and see if you have a Config device like this:
If so, please tell us the driver being used.  Also, please post a screenshot from your UEFI like Svet's (Create page).  Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

oliverrye

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #34 on: 18-October-18, 01:08:46 »

Made an account here because I have encountered the exact same issue described here. I have an AMD 2950X on the MSI X399 Creation Motherboard. 

I intend on installing Windows 10 on an NVMe SSD, and creating a RAID array of HDDs. I also have two other NVMe drives installed as well, but they are separate and not for the raid or OS. 

When I attempt to create the RAID array in RaidXpert2 Utility (before the OS install), it only sees the NVMe drives, not the HDDs. I feel like I've tried everything.
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #35 on: 18-October-18, 06:04:16 »

oliverrye, RAID in AMD Ryzen is a real pain.  MSI has made it worse by making all drives (SATA and NVMe) RAID when SATA Mode is Set to RAID Mode.  When set, all SATA and all NVMe will run in RAID.  I suggest you try this:  Set SATA Mode to RAID,  W10 to WHQL, reboot and use RAIDXpert2 (RX2) to create your RAID to install W10 on.  Install W10.  Be sure to use the latest RAID drivers (9.2.0.70) during install.   Install RX2 in W10.  Open RX2 in Windows. you should see your RAID and all you other drives.  Create VOLUME RAIDS for each of the individual drives to wish to remain single and any other RAID you want.  Enjoy, John.

My Specifications:
MSI X399 Creation , Threadripper 2 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on ASRock Ultra Quad, 1TB & 500 GB WD Black, G.SKILL [Flare X (for AMD)] F4-3200C14Q-32GFX, Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler, Radeon RX580,UEFI 7B92v11, AGESA ThreadRipperPI-SP3r2-1.1.0.1
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

oliverrye

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #36 on: 18-October-18, 18:12:33 »

Thanks for the reply, jhchris2. I've come to the same conclusion. I've tried that same process at least twice now and still no luck. 

Pretty disappointed in the raid "feature" on this "high end" motherboard. I gave up and bought a LSI hardware raid controller. Maybe one day they'll have this all ironed out.
Logged
Marked as best answer by calvin.82110 on 26-October-18, 06:39:07

richard.y

  • CAPTAIN
  • ****
  • Offline Offline
  • Posts: 595

hi
I have the same issue but if you dont enabled AHCI/RAID in EZ mode. Go to settings\advanced\integrated peripherals and set sata mode to raid mode. This issue will be solved. ;-))
Logged

calvin.82110Topic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 18
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #38 on: 26-October-18, 05:42:48 »

richard.y you are the man! the savior of the diy world,  the official have no idea what they are doing, if i knew a month earlier, the following wouldn't happen at all

1. i wouldn't order a raid card from newegg in 2018!
2. i wouldn't order a second raid card from newegg because the first one is not working!
3. i wouldn't order wd 1tb ssd from newegg along with the second raid card because paying the shipping for a cheap card isn't worth it
4. both my business credit card and personal credit card wouldn't get hacked because newegg had security problem back then
5. found out my order of the wd 1tb sdd cannot be used on my x99 board because it is sata not nvme and x99 doesnt support sata, what a waste
6. second raid card still not working on x399

sad!
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #39 on: 26-October-18, 09:49:03 »

Wow, thanks. richard.y!  Have you told MSI support this?  If not, please do.  I could not find the RAID Mode setting in Settings, only in EZ mode.  Does it matter if WHQL is set or not?  Thanks much and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

Svet

  • T9246ED
  • Administrator
  • *****
  • Offline Offline
  • Posts: 73188
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #40 on: 29-October-18, 13:55:29 »

Update:

Here is a new bios that should solve this issue, have a try it:
https://drive.google.com/file/d/1jFUKFLT-kyCnWczcTU1YiFg4BwG_rnXN/view?usp=sharing
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #41 on: 29-October-18, 14:36:51 »

Thanks, Svet.  I was going to suggest to eliminate EZ Mode completely as I suspect this is a rather common error.  For the others it is version 129 and contains AGESA!V9.SummitPI-SP3r2-1.1.0.2.  I used Advanced Mode to set SATA Mode to RAID Mode and discovered that my SATA HDD was visible in RAIDXpert2 (RX2) as legacy and W10, usable in SATA mode in W10 and all my data is fine!   Surprised me and provides a great method to transport data from another system even when using RAID Mode.  Enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

thegreatskywalker

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 5
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #42 on: 11-November-18, 05:31:48 »

Update:

Here is a new bios that should solve this issue, have a try it:
https://drive.google.com/file/d/1jFUKFLT-kyCnWczcTU1YiFg4BwG_rnXN/view?usp=sharing

Thank you for uploading the new BIOS. I believe it's for Meg Creation. Is there a similar BIOS that solves this issue on other x399 boards like SLI plus or Carbon AC?
Logged

Svet

  • T9246ED
  • Administrator
  • *****
  • Offline Offline
  • Posts: 73188
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #44 on: 12-November-18, 10:07:03 »

Svet, can you please tell us when there will be a UEFI compatible with the latest AMD RAID drivers - 9.2.0.00087?  I'm looking for the X399 MEG Creation board.  Thanks and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2

Svet

  • T9246ED
  • Administrator
  • *****
  • Offline Offline
  • Posts: 73188
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #45 on: 13-November-18, 07:55:18 »

Svet, can you please tell us when there will be a UEFI compatible with the latest AMD RAID drivers - 9.2.0.00087?  I'm looking for the X399 MEG Creation board.  Thanks and enjoy, John.

probably yes, why not?
Logged

jhchris2

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 405
Re: X399 Creation raidxpert 2 cannot find SATA raid HDD/ SSD
« Reply #46 on: 13-November-18, 08:39:39 »

Thanks, Svet.  Right now I am unable to install W10 1803 using 9.2.0.00087.  With 9.2.0.00070, Shutdown, Restart, Sleep, and Restart to UEFI all hang and require manual Reset.  I installed W10 on an HDD and am running with no RAID - what a dog!  Thanks much and enjoy, John.
Logged
MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-1.1.0.2
Pages: [1]   Go Up