Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: GT83VR Black Screen  (Read 985 times)

0 Members and 1 Guest are viewing this topic.

elzosalloumTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
GT83VR Black Screen
« on: 04-October-18, 11:51:52 »

Hello Guys, Last night I turned off my laptop normally after having a few hours of playing, This morning I turned it on and I noticed there is no MSI & Windows logo shown but I know the system is running normal and I confirm that when I connect HDMI cable to another screen. I write to MSI support but never had answer yet.

I reboot my laptop several times with no hope, I tried the EC reset bottom from back side also nothing.

The screen got light and I can control the brightness high & low but all in black no any other sign, Keyboards - fans - etc.. all working fine.

I searched a little bit on Internet there is one guy said you need to disable both cards from device manager and enable them again it will work, so i did that now I can't even use the HDMI cable to other screen cause the cards in disabled mode and am totally blind now :(

Note: Laptop still brand new with no body or screen scratches and no hard working I can't believe it can be spoiled quickly like that.

Any help about this issue! Please advice.

Logged

sydneyblue203

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 445
Re: GT83VR Black Screen
« Reply #1 on: 04-October-18, 16:12:29 »

That sucks man. Is the laptop even turning on ? If it still new you can refund/replacement. Are you sure the bios logo isnt appearing ?
Logged
MSI GT73EVR 7RE TITAN  3.9 7820hk 1070 GTX Samsung 250GB NVME M.2 GSKILL RIPJAWS 2400Mhz 2x8GB

elzosalloumTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
Re: GT83VR Black Screen
« Reply #2 on: 04-October-18, 17:28:03 »

It's really sucks :( that's what happened, The bios logo is not showing at all!!
Logged

falkentyne

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 413
Re: GT83VR Black Screen
« Reply #3 on: 05-October-18, 14:30:36 »

It's really sucks :( that's what happened, The bios logo is not showing at all!!

Did you at any point ever, switch to the Intel iGPU?

Please answer this.

To fix your laptop, press and hold the power button down for 60 seconds.  Then release it and wait 3 minutes.
Logged

elzosalloumTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
Re: GT83VR Black Screen
« Reply #4 on: 05-October-18, 14:53:01 »

Hello falkentyne, This model don't have any bottom to switch between SLI cards and Intel card and I think it don't have an Intel card. I'll try your solution as you advice and will write reply here soon. But please advice should I press the power key while the charger plugged or how?
Logged

falkentyne

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 413
Re: GT83VR Black Screen
« Reply #5 on: 05-October-18, 15:08:31 »

Hello falkentyne, This model don't have any bottom to switch between SLI cards and Intel card and I think it don't have an Intel card. I'll try your solution as you advice and will write reply here soon. But please advice should I press the power key while the charger plugged or how?

Yes the adapter must be plugged in.

On the GT73VR And GT75VR, holding down the power button for 60 seconds causes a 60 second black screen, then a "Power LED cycle" then another 30-45 seconds of black screens, then the MSI boot logo looping about 6 times.
Then the BIOS is reset to original base user defaults.

I do not know if this also works on the GT83VR.  Since you have a black screen already, there is no harm in trying.
Logged

elzosalloumTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
Re: GT83VR Black Screen
« Reply #6 on: 05-October-18, 16:39:54 »

Hi falkentyne, I tried everything you said and the screen flash almost 6 times exactly as you said but without MSI logo but no luck still same issue, Check the attached photo to see.

Nite: There is a small bottom from back side got battery logo on it I don't know if this will bring any ideas.
Logged

sydneyblue203

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 445
Re: GT83VR Black Screen
« Reply #7 on: 05-October-18, 19:58:13 »

Have you considered a refund/replacement from the place you got it ?
Logged
MSI GT73EVR 7RE TITAN  3.9 7820hk 1070 GTX Samsung 250GB NVME M.2 GSKILL RIPJAWS 2400Mhz 2x8GB

falkentyne

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 413
Re: GT83VR Black Screen
« Reply #8 on: 05-October-18, 23:02:07 »

Hi falkentyne, I tried everything you said and the screen flash almost 6 times exactly as you said but without MSI logo but no luck still same issue, Check the attached photo to see.

Nite: There is a small bottom from back side got battery logo on it I don't know if this will bring any ideas.

HI,
That's a defective or dead video card or a problem with the LCD panel for sure.  But if HDMI is working fine, then it's the LCD panel.

You have a backlight activation, but no logo which means something is internally wrong which you probably can't fix.

I would do a RMA.
Logged

art1ntrex

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1
Re: GT83VR Black Screen
« Reply #9 on: 23-November-18, 04:27:14 »

I think I have the exact same issue :( happened after pressing the button, next to the power button which shutdowns the screen.
Logged

freeyh

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 476
Re: GT83VR Black Screen
« Reply #10 on: 28-November-18, 05:40:33 »

I think I have the exact same issue :( happened after pressing the button, next to the power button which shutdowns the screen.
You should create a new post and describe your laptop information such as marketing name, OS version, VGA driver version...etc instead of hijack in other user's post. 

Describe the problem more specific. Have you adjusted the behavior of the button next to the power button?
According to the user manual, the button is called "Display OFF" which is used to switch OFF the display of the notebook. Also, check the SCM version is latest on the MSI website which is related to that button.
Logged

alexsupermagik

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1
Re: GT83VR Black Screen
« Reply #11 on: 28-December-18, 14:33:51 »

Hey,have you solved this problem cuz i have same
Logged

pennknig

  • CAPTAIN
  • ****
  • Online Online
  • Posts: 699
Re: GT83VR Black Screen
« Reply #12 on: 28-December-18, 14:56:16 »

 I think it don't have an Intel card. 
What do you think the notebook is using in Safe Mode to power/display the screen?
Logged

falkentyne

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 413
Re: GT83VR Black Screen
« Reply #13 on: 29-December-18, 18:00:32 »

What do you think the notebook is using in Safe Mode to power/display the screen?

The Nvidia adapter in VGA mode.
The exact same thing the bios uses and "real mode" command prompt (freedos, MEMtest86, Linux, etc) uses.
Logged

pennknig

  • CAPTAIN
  • ****
  • Online Online
  • Posts: 699
Re: GT83VR Black Screen
« Reply #14 on: 12-January-19, 18:10:25 »

The Nvidia adapter in VGA mode.
The exact same thing the bios uses and "real mode" command prompt (freedos, MEMtest86, Linux, etc) uses.
Seriously?!
When in SAFE MODE, having deleted all NVIDIA with DDU in preparation for a clean install ..... What is the PC using to drive the graphics then?!
Intel HD iGPU ..... Nvidia doesn't even load in Safe Mode.
And you can run your desktop without your video card installed. Play some not so demanding games.
All because of the INTEL HD iGPU

AMD Ryzen is going to go full boar with NO video cards in their builds, its all going to be iGPU, at a fraction of the cost for Intel/Nvidia setup.
Logged

falkentyne

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 413
Re: GT83VR Black Screen
« Reply #15 on: 15-January-19, 22:44:17 »

Seriously?!
When in SAFE MODE, having deleted all NVIDIA with DDU in preparation for a clean install ..... What is the PC using to drive the graphics then?!
Intel HD iGPU ..... Nvidia doesn't even load in Safe Mode.
And you can run your desktop without your video card installed. Play some not so demanding games.
All because of the INTEL HD iGPU

AMD Ryzen is going to go full boar with NO video cards in their builds, its all going to be iGPU, at a fraction of the cost for Intel/Nvidia setup.

Please refrain from replying if you don't know what you're talking about.  You've made a complete fool of yourself both here and NBR, trying to pretend you are an expert.
The iGPU does NOT LOAD if it's disabled.
The GT73VR and GT73VR have hardware MUX switches that disable the iGPU completely meaning it is not even used, when the Nvidia GPU is active.
Do you even know what the GPU switch button does in the GT73VR and GT75VR?  No you do not.  I do.  Because *I* hacked these laptops and I was the first one to do so.

The GPU button (which requires SCM installed) sends a "01" code to embedded controller register F1, which tells the EC to "switch the current active GPU.".
Even without SCM installed, you can still switch GPU's by programming this register with RW Everything.

When you then reboot, the EC will *CUT electrical power* to the PEG port completely, which then enables the iGPU, because the IGPU with the "Auto" setting will enable itself if the PEG port is disconnected.

In safe mode, you are using the Nvidia GPU with BASIC VGA microsoft drivers.  Desktops have done this for YEARS, including desktops that have NO IGPU even present on the chip itself.

So please do your research next time and do not yell at me again. i *WILL* block you.
Logged
Pages: [1]   Go Up