Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: PCIe Speed on Z97 Gaming 5  (Read 135 times)

0 Members and 1 Guest are viewing this topic.

Joshie65Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 5
PCIe Speed on Z97 Gaming 5
« on: 11-February-19, 07:28:14 »

Hello,

I am running an MSI GTX 1070 graphics card and two identical Samsung 970 EVO 500 GB SSD's along with an Core i7 4790K in my Z97 Gaming 5 board:

PCI_E2 (mechanical x16, electrical max. 3.0 x16): GTX 1070
PCI_E5 (mechanical x16, electrical max. 3.0 x8): 970 EVO with PCIe 3.0 x4 adapter
PCI_E7 (mechanical x16, electrical max. 3.0 x4): 970 EVO with PCIe 3.0 x4 adapter

I configured the PCIe lanes to x8 / x4 / x4 mode in the UEFI BIOS, so both SSD's should get 4 3.0 lanes directly from the CPU. Basically both SSD's are running fine, and Crystal Diskinfo shows that both SSD's are connected with PCIe 3.0 x4. But while the first SSD in slot PCI_E5 achives its full speed of more than 3200 MB/s read, the second SSD in slot PCI_E7 achieves only about 2500 MB/s. I switched both SSD's from slot E5 to E7, but the SSD in slot E7 is always slower. Is this a normal behavior, may be due to the cascaded lane switching (first switch E2 x16 -> E2 x8 / E5 x8 + second switch E5 x8 -> E5 x4 / E7 x4) ? Has anyone similar effects?
Logged

rbleroy91

  • LIEUTENANT GENERAL
  • ****
  • Offline Offline
  • Posts: 4068
  • RBL_FR
Re: PCIe Speed on Z97 Gaming 5
« Reply #1 on: 11-February-19, 09:07:42 »

Hello,
What is the speed for this in PCI_E7 when you unplug the adapter in PCI_E5?
Are the 2 adapters the same model? Have you also tried to exchange them?
Have a good day,
:hat tip:
Logged
MSI X99A XPower Gaming Titanium (Bios 1.61)  –  Windows 7-10 Pro x64 (1809)  –  i7-6850K + BeQuiet! Dark Rock Pro 3 + Corsair Vengeance LPX Series DDR4 3466MHz 4x16Go + MSI GeForce GTX 1070 Gaming X 8G + SSD Samsung, 1x 850 PRO 512GB (SATA) [Boot+OS drive] & 1x 970 PRO 1TB (NVMe) + HD SATAIII Seagate Barracuda, 7x 1TB & 1x 3TB + LG BR R/W + BeQuiet! Dark Power Pro 11 1000W 80PLUS Platinum +  BeQuiet! Dark Base Pro 900 + HyperX Alloy Elite keyboard + HyperX Pulsefire FPS mouse

Joshie65Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 5
Re: PCIe Speed on Z97 Gaming 5
« Reply #2 on: 11-February-19, 09:23:42 »

The two adapters are the same model, and I did exchange them from one slot to the other. I have to try one SSD in slot 7 with slot 5 not populated. That will not help me with my current config, but may clarify the problem a bit. I will report tomorrow.
Logged

rbleroy91

  • LIEUTENANT GENERAL
  • ****
  • Offline Offline
  • Posts: 4068
  • RBL_FR
Re: PCIe Speed on Z97 Gaming 5
« Reply #3 on: 11-February-19, 11:14:20 »

I have to try one SSD in slot 7 with slot 5 not populated. That will not help me with my current config, but may clarify the problem a bit. I will report tomorrow.
Yes, the goal is only to understand what happen.
Have a good day,
:hat tip:
PS: what is the adapter model?
Logged
MSI X99A XPower Gaming Titanium (Bios 1.61)  –  Windows 7-10 Pro x64 (1809)  –  i7-6850K + BeQuiet! Dark Rock Pro 3 + Corsair Vengeance LPX Series DDR4 3466MHz 4x16Go + MSI GeForce GTX 1070 Gaming X 8G + SSD Samsung, 1x 850 PRO 512GB (SATA) [Boot+OS drive] & 1x 970 PRO 1TB (NVMe) + HD SATAIII Seagate Barracuda, 7x 1TB & 1x 3TB + LG BR R/W + BeQuiet! Dark Power Pro 11 1000W 80PLUS Platinum +  BeQuiet! Dark Base Pro 900 + HyperX Alloy Elite keyboard + HyperX Pulsefire FPS mouse

Joshie65Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 5
Re: PCIe Speed on Z97 Gaming 5
« Reply #4 on: 11-February-19, 12:16:43 »

Okay, I tested the following:

- two identical SSD's Samsung 970 EVO 500 GB in two identical PCIe 3.0 x4 adapters
- SSD in slot 5, slot 7 not populated: 3200 MB/s
- slot 5 not populated, SSD in slot 7: 2500 MB/s
- SSD in slot 5, SSD in slot 7: slot 5 3200 MB/s, slot 7 2500 MB/s
- exchanging the SSD's in slot 5 and 7 does not change the results

So the problem seems to be really caused by the board, not by the SSD's or adapters. My guess is that the cascaded lane switches on the board increase the administrative PCIe overhead for slot 7 so much that the maximum achievable bandwidth is decreased to 2500 MB/s. Or is it just bad board wiring? In any case, I just wonder if I am the only one with such a problem?

Thanks for your help and have a nice evening.

P.S. adapter model is the following (recommendable, high quality with good cooling):

https://shop.aquacomputer.de/product_info.php?language=en&products_id=3400
Logged

rbleroy91

  • LIEUTENANT GENERAL
  • ****
  • Offline Offline
  • Posts: 4068
  • RBL_FR
Re: PCIe Speed on Z97 Gaming 5
« Reply #5 on: 12-February-19, 02:14:10 »

Hello,
Quote
P.S. adapter model is the following (recommendable, high quality with good cooling):
https://shop.aquacomputer.de/product_info.php?language=en&products_id=3400
A very goodly designed adapter! :biggthumbsup: I did not know it...
Quote
So the problem seems to be really caused by the board, not by the SSD's or adapters. My guess is that the cascaded lane switches on the board increase the administrative PCIe overhead for slot 7 so much that the maximum achievable bandwidth is decreased to 2500 MB/s. Or is it just bad board wiring? In any case, I just wonder if I am the only one with such a problem?
I think it the best is to ask directly to MSI Support to have a definitive answer: >>How to contact MSI<<. Let me known about their explanation.
Have you already the last bios >>Last Bios Version<<? If not, I would give a chance to updating it. BUT, if you do, reset bios values before to run M-Flash and set back x8/x4/x4 after to have booted once.
Friendly yours,
:hat tip:
Logged
MSI X99A XPower Gaming Titanium (Bios 1.61)  –  Windows 7-10 Pro x64 (1809)  –  i7-6850K + BeQuiet! Dark Rock Pro 3 + Corsair Vengeance LPX Series DDR4 3466MHz 4x16Go + MSI GeForce GTX 1070 Gaming X 8G + SSD Samsung, 1x 850 PRO 512GB (SATA) [Boot+OS drive] & 1x 970 PRO 1TB (NVMe) + HD SATAIII Seagate Barracuda, 7x 1TB & 1x 3TB + LG BR R/W + BeQuiet! Dark Power Pro 11 1000W 80PLUS Platinum +  BeQuiet! Dark Base Pro 900 + HyperX Alloy Elite keyboard + HyperX Pulsefire FPS mouse

Joshie65Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 5
Re: PCIe Speed on Z97 Gaming 5
« Reply #6 on: 12-February-19, 02:35:51 »

Thank you rbleroy91, I already have the latest BIOS version 1.D for my board installed (I even managed to mod it with the latest Intel microcode updates :) ). MSI support is already contacted, I will let you know their reply.
Logged

darkhawk

  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 11592
Re: PCIe Speed on Z97 Gaming 5
« Reply #7 on: 12-February-19, 08:36:10 »

See page 3-9 within the manual online ( https://www.msi.com/Motherboard/support/Z97-GAMING-5#down-manual ) and you should be able to setup some of the PCI-E lane configuration.
Logged
Name            Motherboard                                CPU                                              RAM                             GPU                                            
System 1MSI GS73VR-6RFIntel i7 6700HQ16GB DDR4MSI GTX1060 6GB
ServerMSI X370 SLI PlusAMD Ryzen 5 1500X16GB DDR4NVidia Quadro 4000
System 3MSI Z390 GodlikeIntel i9 9900K16GB DDR4 @ 3600 MHz MSI GTX 1070Ti Armor OC
System 4MZI Z390 Gaming Pro Carbon ACIntel i5 860016GB DDR4 @ 3600 MHzMSI 7700 Aero

Joshie65Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 5
Re: PCIe Speed on Z97 Gaming 5
« Reply #8 on: 12-February-19, 09:36:36 »

Well, I set the PCIe lane configuration to x8 / x4 / x4.
Logged
Pages: [1]   Go Up