Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: MSI P67A-GD53 Issue  (Read 108 times)

0 Members and 1 Guest are viewing this topic.

hasanukTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
MSI P67A-GD53 Issue
« on: 11-February-19, 17:57:37 »

Hi I was wondering if someone could help as I am at my wits end trying to get this to work
I purchased a RX580 and no matter what I do I cannot get it to display an image via HDMI - The card is working as the white led is on but no image appears
I know some people have mentioned the motherboard has to be UEFI for it to work but I'm pretty sure this board is ( bios is colourful and is browsable using a mouse)
I have no drivers pre-installed for a graphics card but I'm sure this isn't normally an issue as the image is normally displayed and later the drivers can be downloaded. ( I have no drivers for my current 7950 I am upgrading from)
I also cannot see any options in the bios regarding legacy or uefi but I am sure it supports both.
Does anyone know what could possibly be wrong or is it that this motherboard is simply too old? I also flashed the bios to version 4.3 but still no image is displayed. I would be grateful if anyone could help me. Thanks in advance
I am running it on windows 10 64 bit with an i5 2500k and the power supply is more then capable ( seasonic) and below is the drivers I downloaded and flashed from an usb stick
Version
4.3
Release Date
2013-01-09
Logged

hasanukTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
Re: MSI P67A-GD53 Issue
« Reply #1 on: 11-February-19, 18:03:40 »

also if I could add would it be worth trying the card in another pci express slot or are they all the same?thanks
Logged

flobelix

  • MSIHQ Red Rockets Team Member
  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 30937
  • 微星科技
    • Afterburner New Features Introduction | MSI
Re: MSI P67A-GD53 Issue
« Reply #2 on: 12-February-19, 11:29:44 »

Just hdmi does not work or there is no image from the card even with displayport or dvi?
Logged
MSI X299 Gaming M7 ACK (MS-7A90) Bios 1.9
Core i7 7820X @ 4203.84 MHz (42 * 100.09 MHz, fixed all cores), 1.086v - delidded and using der8auer Skylake-X Direct Die Frame
Cooler Master MasterLiquid 240 Liquid CPU Cooler
32GB (4 x 8GB) Corsair CMK32GX4M4C3000C15R @ 1500 MHz (DDR4-3000), 15-17-17-35-2t 1.35v
MSI GeForce RTX 2080 GAMING X TRIO
256GB Samsung 830 SSD + 2TB Crucial MX500 SSD
Thermaltake Toughpower Grand RGB 1200W Platinum • +12V: 100A • +3.3V: 25A • +5V: 25A
Windows 10 Pro
MSI MAG BUNKER

hasanukTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
Re: MSI P67A-GD53 Issue
« Reply #3 on: 12-February-19, 13:01:45 »

Just hdmi does not work or there is no image from the card even with displayport or dvi?

Hi I do not have a dvi cable will that make a difference  It's just normally I use an hdmi straight to my TV

Logged

flobelix

  • MSIHQ Red Rockets Team Member
  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 30937
  • 微星科技
    • Afterburner New Features Introduction | MSI
Re: MSI P67A-GD53 Issue
« Reply #4 on: 13-February-19, 12:35:54 »

TVs are mostly causing issues. Can you try with a monitor?
Logged
MSI X299 Gaming M7 ACK (MS-7A90) Bios 1.9
Core i7 7820X @ 4203.84 MHz (42 * 100.09 MHz, fixed all cores), 1.086v - delidded and using der8auer Skylake-X Direct Die Frame
Cooler Master MasterLiquid 240 Liquid CPU Cooler
32GB (4 x 8GB) Corsair CMK32GX4M4C3000C15R @ 1500 MHz (DDR4-3000), 15-17-17-35-2t 1.35v
MSI GeForce RTX 2080 GAMING X TRIO
256GB Samsung 830 SSD + 2TB Crucial MX500 SSD
Thermaltake Toughpower Grand RGB 1200W Platinum • +12V: 100A • +3.3V: 25A • +5V: 25A
Windows 10 Pro
MSI MAG BUNKER
Pages: [1]   Go Up