Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Mouse and Keyboard Don't Work in Recovery Mode  (Read 206 times)

0 Members and 1 Guest are viewing this topic.

kent.attridgeTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2

I have an MSI Z97S SLI Krait Edition motherboard running Windows 7 Pro. Mouse and Keyboard work fine when in Windows 7 and in bios mode but stop working when I go into Recovery mode. [font=verdana, geneva, lucida, "lucida grande", helvetica, sans-serif]M[/font][/color][font=verdana, geneva, lucida, "lucida grande", helvetica, sans-serif]y mouse and keyboard aren't recognized, and I can't move forward with the onscreen dialogue, leaving me stuck at the language selection window. Mouse and keyboard are plugged into the two USB 2 ports and Legacy support is enabled in the bios setup. Any suggestions? I do not have another keyboard or mouse to check for compatibility issues, but I'd be surprised since both stop working. Could it be an old bios problem? I have not updated the bios since I built this desktop many years ago.[/font][/color]
Logged

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 73186
Re: Mouse and Keyboard Don't Work in Recovery Mode
« Reply #1 on: 21-May-19, 09:17:52 »

Are you using a wireless kbd & mouse?
Logged

kent.attridgeTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Re: Mouse and Keyboard Don't Work in Recovery Mode
« Reply #2 on: 21-May-19, 16:25:54 »

No. Both mouse and KB are wired to the two UBS 2 ports. I actually was able to solve my problem, which has been bugging and scaring me for years, since it was preventing me from accessing any backup image or recovery disk. Every solution proposed on the internet at large would not work. I did discover that it is a very common problem with MSI motherboards. My solution sounds strange, and it may only work for me or this kind of motherboard. On boot up, hit DEL to enter the settings menu and, under the USB configuration menu, set xHCI mode to "Enabled" and EHCI Handoff to "Disabled". Save and exit to reboot. On reboot, go immediately back into the USB Configuration settings and changed the xHCI mode back to "Disabled". Save and exit and reboot again this time into the boot device selection menu (F11). I selected my DVD as the boot drive where I had my system recovery disk. My mouse remained activated to finally get by the language selection page. It's not a permanent fix. I did have to redo this boot routine again, since my mouse stopped working again after a few reboots. So, it's a temporary fix, but it's the only one that works for me.
Logged
Pages: [1]   Go Up