Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: MSI GS70 6QE Stealh Pro - headphone jack not working, two sound devices  (Read 121 times)

0 Members and 1 Guest are viewing this topic.

rainer.j.schmidtTopic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 11

Hello,

I have a really weird issue with my MS GS70 2QE Steatlh Pro.

The notebook has three soundjacks.




Headphones (left) - LineIn (center) - MicIn (right)

The notebook has two top speakers under the lid and a speaker on the bottom left.




I have Windows 10 1903, latest bios, EC firmware and Sound drivers form the MSI support page.
https://de.msi.com/Laptop/support/GS70-6QE-Stealth-Pro#down-driver&Win10%2064

With no external device connected I have one Realtek sound device in the Windows device manager.
Windows recognizes this as quadraphonic speakers (4.0). Sound is only been played for the front left and front right speaker utilizing the two top speakers under the lid.
If I plug my headphones into the headphone jack, nothing happens. Sound is still only been played from the two top speakers.
Nahimic does nothing. The sound effects are not being used, no matter if I enable or disable them.

Realtek GUI only shows the LineIn and MicIn connector, but does not recognize the headphone jack.

When I plug a Mic into the LineIn or the MicIn, something really weird occurs.
Not I have two Realtek audio devices in Windows sound dialogue. Now both are only recognized as stereo devices
One is showing a speaker symbol and still playing sound from only the top speakers under the lid.
One is showing a headphone symbol in Windows sound dialogue, but playing sound from the bottom speaker!

It should probably work like this:
With no headphones connected, combine the top and bottom speaker to a (pseudo) quadraphonic device. Add some effects with Nahimic.
Recognize the headphones when they are plugged in, disabling internal speakers and switching to a stereo device.

How do I fix this? your help is appreciated.   
Logged

rainer.j.schmidtTopic starter

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 11

I found a solution using a modded driver available here: http://forum.notebookreview.com/threads/nahimic-3-on-unsupported-systems.822763/page-60#post-10948424

- Internal speakers are working in quadraphinonic mode and thus sound much better then before!
- Headphones are working when I select SPDIF out.
- Nahimic is working for both internal speakers and headphones.
- Old Realtek GUI (RAVCpl64.exe) is working.
- Realtek Audio Console (UWP app) is also working.
Logged
Pages: [1]   Go Up