Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Front panel is off... Many issues  (Read 350 times)

0 Members and 1 Guest are viewing this topic.

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Front panel is off... Many issues
« on: 20-September-19, 10:00:12 »

Hey people.... I just assembled my new pc(not my first one)... With:

1. Msi rx470
2. Ryzen 7 3700X
3. 2x16 corsair Vengeance lpx
3. Corsair hydro
4. Amd rx 580 nitro +

Power on....
Fans r working
Hydro working...
Ram(red lights above them... On motherboard)
No front panel(reset, hdd light)
No picture on my monitor(hdmi.. Maybe try with stg else first.. I mean cable)...

It s not my first pc that I m building
Can't see my bios

Thanks in advance and sorry for my English
Logged

montyac

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 833
Re: Front panel is off... Many issues
« Reply #1 on: 20-September-19, 10:03:34 »

Try clearing CMOS. Reseat the ram stick, using only one in slot 2 per manual. See if you can get into BIOS or if there are red debug lights on.
Logged

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Re: Front panel is off... Many issues
« Reply #2 on: 20-September-19, 10:33:24 »

I try to do what you said but... Nope..... Same thing
Logged

montyac

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 833
Re: Front panel is off... Many issues
« Reply #3 on: 20-September-19, 10:37:32 »

Which debug lights stay red at start up?
Logged

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Re: Front panel is off... Many issues
« Reply #4 on: 20-September-19, 10:53:17 »

The top one...
Logged

montyac

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 833
Re: Front panel is off... Many issues
« Reply #5 on: 20-September-19, 10:57:38 »

The top one...

The CPU debug light? The lights are labeled.
Logged

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Re: Front panel is off... Many issues
« Reply #6 on: 20-September-19, 11:03:45 »

I think it sais CPU yeap....
Logged

montyac

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 833
Re: Front panel is off... Many issues
« Reply #7 on: 20-September-19, 11:11:55 »

I think it sais CPU yeap....

Has your X470 board been updated to work with the 3000 series Ryzen? If not, you will need a first or second generation Ryzen CPU to update to a gen 3000 BIOS. What is the name of your board? Check the MSI support page for the BIOS.
Logged

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Re: Front panel is off... Many issues
« Reply #8 on: 20-September-19, 11:24:59 »

All I have is an Fx8350.. Nothing else
Logged

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Re: Front panel is off... Many issues
« Reply #9 on: 20-September-19, 11:26:09 »

And I can't say if it's updated... I can't open the machine
Logged

montyac

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 833
Re: Front panel is off... Many issues
« Reply #10 on: 20-September-19, 11:36:55 »

Do you have a local shop that you can have them check what version BIOS you have? Also if needed can they update the BIOS to work with your CPU?
Logged

thiakos.spirosTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
Re: Front panel is off... Many issues
« Reply #11 on: 20-September-19, 11:38:43 »

I think I can find stg.... But in case I don't what can I do?
Logged

montyac

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 833
Re: Front panel is off... Many issues
« Reply #12 on: 20-September-19, 11:54:26 »

If you know someone that has a first or second gen Ryzen, see if they will update the BIOS for you. You can also contact AMD for a BIOS update kit for your board..
Logged

jawn

  • CORPORAL
  • ****
  • Offline Offline
  • Posts: 14
Re: Front panel is off... Many issues
« Reply #13 on: 28-September-19, 23:18:27 »

What Motherboard do you have?

And an FX8350 CPU?
Logged
MSI Big Bang Trinergy
Intel 870 @ 2.93Mhz
4X2 Gs Crucial BT 1600 @ 8888 24/1.65v
Twin Sapphire 5870 VCs
Apevia Warlock 1100w PSU
Seagate SATA 1T HD

Chike

  • LIEUTENANT GENERAL
  • ****
  • Online Online
  • Posts: 4299
Re: Front panel is off... Many issues
« Reply #14 on: 28-September-19, 23:23:25 »

Dude, make everyone life easier trying to help you and put your specs in your signature.
Full motherboard model
>>Posting Guide<<
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  Samsung 840 EVO 120GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

Pages: [1]   Go Up