Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Immerse GH70 Bass not working  (Read 872 times)

0 Members and 1 Guest are viewing this topic.

jnlt2Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1
Immerse GH70 Bass not working
« on: 03-November-19, 20:59:21 »

So I recently bought the MSI Immerse GH70 Gaming Headset (Has a USB type A connector). It seems to have very poor audio quality. I have what I believe to be the proper drivers and applications for it, but there is next to no bass for it being a 50mm driver. My old headset is a Razer Kraken with an analog 3.5mm connector and has a much more adequate sounding bass while having smaller drivers in the headset. I can't seem to figure out what is wrong with them. Are they just broken?
P.S. I have an MSI X470 Gaming Pro Carbon motherboard. No additional sound cards.
I apologize if I have said anything incorrect, I am not very familiar with sound terms and technology. And if this kind of post isn't allowed then please let me know and I will take it down.
Logged

thomas_carstensen

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
Re: Immerse GH70 Bass not working
« Reply #1 on: 10-February-20, 10:07:06 »

I had the same problem. MSI offers an old tool ( gaming center) on its support page. This tool does a firmware downgrade to version 101. Download the Dragon Center from the GH50 support site and do a firmware update back to version 103 again.
Logged

mirec1208

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
Re: Immerse GH70 Bass not working
« Reply #2 on: 22-March-20, 06:39:32 »

I had the same problem. MSI offers an old tool ( gaming center) on its support page. This tool does a firmware downgrade to version 101. Download the Dragon Center from the GH50 support site and do a firmware update back to version 103 again.

How do you update firmware to version 103? I have dragon center installed however I can't find a way to update firmware on my headset. I have big problems with microphone it is working totally bad.
Logged

thomas_carstensen

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
Re: Immerse GH70 Bass not working
« Reply #3 on: 24-March-20, 09:47:13 »

Hello, it worked that way for me:
Logged
Pages: [1]   Go Up