Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Radeon rx570 8gb armor doesn't work in new motherboard  (Read 119 times)

0 Members and 1 Guest are viewing this topic.

cliff.hTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2

The graphics card works fine in my gigabyte board with an i3 6100 but when I put it in my new Asrock H310CM-HDV/M.2 with an i3 9100f (UEFI boot win 10 pro 64bit) I get no output and can't even access the bios. I know the 9100f has no onboard graphics. If I plug a Nvidia Geforce GT 710 in the pc boots fine.
I have the latest BIOS update and all drivers are updated.

Does anyone know how I can get the better board to work please?
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: Radeon rx570 8gb armor doesn't work in new motherboard
« Reply #1 on: 04-December-19, 05:53:14 »

Is csm mode enabled?
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

cliff.hTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Re: Radeon rx570 8gb armor doesn't work in new motherboard
« Reply #2 on: 04-December-19, 06:13:44 »

Is csm mode enabled?
No
On enabling it the options are
Launch pxeoprom (set to legacy) option are do not launch, uefi only or legacy only.
Launch Storage OpROM policy set to UEFI only other options as above
Other PCI Device ROM priority, set to UEFI only, same options as above.
Thanks for the quick reply
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: Radeon rx570 8gb armor doesn't work in new motherboard
« Reply #3 on: 04-December-19, 06:22:44 »

Whatever is the default I guess.
Those options are a bit weird, if there is no uefi and legacy what's the point of csm?
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

Pages: [1]   Go Up