Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: B450M Gaming Plus - front and back audio jacks not working  (Read 325 times)

0 Members and 1 Guest are viewing this topic.

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8

Hello,

I have a B450M Gaming Plus with AMD Ryzen 5 processor. For some reason, my front and back audio jacks both dont work.


Whats happening:
- Front headphone and microphone jack are not recognized at all. Plugging in doesnt give any sort of notification, windows doesnt add a new option of a device in sound settings
- Back audio jacks give me a prompt asking "What did you plug in?" when I plug in anything, but choosing "Headphones" after plugging into the right jack doesn't give me any sound. The device gets recognized, but plays no sound.

What I have done:
- Install latest drivers for Audio from MSI Website
- Install audio drivers from AMD website
- Triple checked that the wires are connected properly to the motherboard.


What to do?
Logged

newlin9

  • SECOND LIEUTENANT
  • **
  • Offline Offline
  • Posts: 141
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #1 on: 05-December-19, 16:58:13 »

What I have done:
- Install latest drivers for Audio from MSI Website
- Install audio drivers from AMD website
- Triple checked that the wires are connected properly to the motherboard.

Does your sound device appear (show up as a listed, active device) in DEVICE MANAGER?

Did you ENABLE SOUND in your BIOS?
Logged

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #2 on: 06-December-19, 10:06:45 »

Does your sound device appear (show up as a listed, active device) in DEVICE MANAGER?

Did you ENABLE SOUND in your BIOS?

Audio Inputs and Outputs just shows my monitors (which have inbuilt speakers) connected via Displayport to my GPU.
Sound controllers shows AMD High Definition Audio and Realtek(R) Audio. The AMD HD Audio is probably the GPU, and the Realtek one is the jacks which are not working.


I couldn't find an option to enable sound in bios. where is that?
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #3 on: 06-December-19, 10:18:10 »

Does monitor support audio over displayport?
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #4 on: 06-December-19, 10:32:42 »

Does monitor support audio over displayport?
Yes and that works fine. Both monitors are able to play sound through DP/HDMI. It's the audio jacks which don't work.
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #5 on: 06-December-19, 10:39:02 »

What do you connect to the ports?
What is printed on the front panel audio connector, hd audio.azalia or ac'97?
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #6 on: 06-December-19, 10:41:01 »

What do you connect to the ports? What is printed on the front panel audio connector, hd audio.azalia or ac'97?

I'm connecting a pair of Sennheiser Momentum Headsets. There's nothing on the front panel audio connectors, the ports only have the small mic and headphone icons next to them.

Also, I found the Sound option in the BIOS. It was already enabled. I just disabled and re-enabled it and restarted my PC.
The back audio jack for Speakers works fine now as I can plug in my headphones and it plays sound. The front jacks are still dead and unrecognized.
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #7 on: 06-December-19, 10:45:55 »

The front panel connector that connects to the board.also make sure it is connected properly
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #8 on: 06-December-19, 10:58:47 »

The front panel connector that connects to the board.also make sure it is connected properly
Ok I just opened my case to check it out. The connector says HD Audio, I've attached pictures. It is connected properly to the JAUD_1 port on the motherboard.
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #9 on: 06-December-19, 11:07:30 »

Ok this should work.
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #10 on: 06-December-19, 11:19:42 »

Ok this should work.
It fixed itself :/ maybe the connector was a little bit loose or something, but I did take it out and replug it like 3 times before and it never worked then lol. 

Oh well. The audio quality through the headphones is kinda :censored:  though, even compared to the monitor speakers. idk if its my headphones cable (since I got a replacement from AliExpress) or the default audio card is just not good
Logged

newlin9

  • SECOND LIEUTENANT
  • **
  • Offline Offline
  • Posts: 141

Does your sound device appear (show up as a listed, active device) in DEVICE MANAGER?

Did you ENABLE SOUND in your BIOS?
In cases where the realtek sound device's drivers have been installed correctly, and no sound is being produced, it is usually due to the audio device NOT BEING ENABLED in the BIOS.

You can also run 'DXDIAG' in the popup menu and it will diagnose your sound hardware and determine if there is either a hardware or software existing problem/issue.

rbelroy91 answered this very well in this forum link:  https://forum-en.msi.com/index.php?topic=295525.0
Until your sound problem remains:
- Verify in the Bios that "Advanced Mode \ SETTINGS \ Integrated Peripherals \ HD Audio Controller" is "Enabled" (default value).
- Try with Windows 10 basic tools: "Control Panel \ Updates and Security \ Troubleshooting Tools \ Sound".

If your sound problem is not corrected after all of that,
- Do a copy of device manager showing hidden devices and expanding the two parts about Sound.
- Run "C:\Program Files\Realtek\Audio\HDA\RtkNGUI64.exe" and upload its main windows. Then, click on each of the 3 icons shown below and upload the window copies.

Good luck,
:-)
RBL
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #12 on: 06-December-19, 11:22:39 »

Can you connect the headsets to the monitor?
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #13 on: 06-December-19, 11:24:10 »

In cases where the realtek sound device's drivers have been installed correctly, and no sound is being produced, it is usually due to the audio device NOT BEING ENABLED in the BIOS.

You can also run 'DXDIAG' in the popup menu and it will diagnose your sound hardware and determine if there is either a hardware or software existing problem/issue.

rbelroy91 answered this very well in this forum link:  https://forum-en.msi.com/index.php?topic=295525.0
Until your sound problem remains:
- Verify in the Bios that "Advanced Mode \ SETTINGS \ Integrated Peripherals \ HD Audio Controller" is "Enabled" (default value).
- Try with Windows 10 basic tools: "Control Panel \ Updates and Security \ Troubleshooting Tools \ Sound".

If your sound problem is not corrected after all of that,
- Do a copy of device manager showing hidden devices and expanding the two parts about Sound.
- Run "C:\Program Files\Realtek\Audio\HDA\RtkNGUI64.exe" and upload its main windows. Then, click on each of the 3 icons shown below and upload the window copies.

Good luck,
:-)
RBL


Thanks a lot, it's working now though :)

Can you connect the headsets to the monitor?

God damn I didn't even know my monitors could do that. I plugged them in, and the sound quality is way better through the monitors. So I guess it is the audio card then?
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #14 on: 06-December-19, 11:27:06 »

God damn I didn't even know my monitors could do that. I plugged them in, and the sound quality is way better through the monitors. So I guess it is the audio card then?
I don't know I'm fine with my sound (same alc877 chip)
Same quality from front and back ports?
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

hardik.kumar1999Topic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #15 on: 06-December-19, 11:28:02 »

I don't know I'm fine with my sound (same alc877 chip)
Same quality from front and back ports?
Nope the back is way better than the front.
Logged

Chike

  • GENERAL
  • *****
  • Offline Offline
  • Posts: 6423
Re: B450M Gaming Plus - front and back audio jacks not working
« Reply #16 on: 06-December-19, 11:31:53 »

Nope the back is way better than the front.
That is where I connect my headset
Logged
Motherboard: ASUS Z97-K R2.0 BIOS ver. 0903 2/26/2016
CPU: i5-4670k
Cooler: CNPS10x Performa
Memory: F3-2400C11D-16GXM
GPU: EVGA GeForce GTX 950 FTW ACX 2.0
SSD: 1. Samsung PM981 512GB, 2.  SanDisk SSD PLUS 240GB
HDD: WDC WD3200AAKS-00L9A0
PSU: Antec 500W VP500PC
OS: Windows 10 Home 1903 64-bit / Windows 7 Home Premium 64-bit
Case: Compucase 6C60

Pages: [1]   Go Up