Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Can't boot to Linux unless SATA device is disconnected  (Read 94 times)

0 Members and 1 Guest are viewing this topic.

jfoyeTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1

I have a new MSI x570 Gaming Pro Carbon Wifi with latest BIOS.

I spent two days trying to boot to any distro of Linux without success. Finally I found a post elsewhere in this forum that said to disconnect SATA devices (!). I have a DVD player in this machine, and I disconnected it, and sure enough, could boot to and install Linux.

This seems like a serious flaw. Is MSI aware of this? Will there be a BIOS update that will fix it?

I don't know if this is the best place for me to post this, but I apparently cannot post a tech support request until I register the product, and it was impossible for me to register this motherboard, because a) I cannot find the serial number on it, at least not without taking the machine apart, and b) the vendor I got it from did not give me an invoice in the format expected by MSI - a very strange requirement, that one is.

Any help much appreciated.
Logged

istosadmin

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Re: Can't boot to Linux unless SATA device is disconnected
« Reply #1 on: 17-January-20, 11:42:52 »

Have similar problem on same motherboard. I tried to install just linux on my new rig on an m.2 nvme drive and installation was good but when I tried to boot into it, it would show me that grub was not installed or something like that. But GRUB did work on a SATA SSD. In the end I installed windows 10 on the nvme drive and linux on the SATA SSD now when I boot I have to use the SATA SSD and that will show grub asking me what I want to boot into. Linux or Windows 10. Spent 3 days on this and still not actually fixed..just gave up!
Logged
Pages: [1]   Go Up