Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Immerse GH70 firmware not updating  (Read 389 times)

0 Members and 1 Guest are viewing this topic.

abailen2008Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Immerse GH70 firmware not updating
« on: 22-June-20, 22:11:43 »

I recently purchased the Immerse GH70 and had issues where the audio quality was terrible and there was no bass whatsoever.  I tried updating to firmware version 103 but it would say installation failed and proceed to restart my computer.  Is there any way to manually download the firmware update?  Or is there a solution to fix the update installation?
Logged

fatedust

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 372
Re: Immerse GH70 firmware not updating
« Reply #1 on: 23-June-20, 22:44:11 »

How did you update firmware? In Dragon Center or Gaming Center?
After updating firmware and pc restarted, did you unplug and replug the headset?
Logged

abailen2008Topic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
Re: Immerse GH70 firmware not updating
« Reply #2 on: 24-June-20, 13:03:22 »

Dragon Center and Yes I did all that and nothing worked.  Getting a refund and a different pair of headphones
Logged

fatedust

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 372
Re: Immerse GH70 firmware not updating
« Reply #3 on: 28-June-20, 21:35:11 »

Maybe the old one is faulty, the new one should be fine.
Logged

jimmylim85

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1
Re: Immerse GH70 firmware not updating
« Reply #4 on: 10-July-20, 22:47:07 »

Is there any update on whether anyone successfully solve this problem? Tried updating firmware to 103 yet it failed.
Logged

fatedust

  • FIRST LIEUTENANT
  • ***
  • Offline Offline
  • Posts: 372
Re: Immerse GH70 firmware not updating
« Reply #5 on: 13-July-20, 01:44:36 »

Same question: 
How did you update firmware? In Dragon Center? What version you are using?
After updating firmware and pc restarted, did you unplug and replug the headset?
Logged
Pages: [1]   Go Up