Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: K8N NEO2 - summary time - what's the current consensus?  (Read 1432 times)

0 Members and 1 Guest are viewing this topic.

zforgetaboutit

  • Guest

(Hello everybody, nice to post here for the first time.)

At stock speeds, can it yet be said it's no more defective than other leading boards?

Has it been confirmed yet that everything will work as advertised, if you

  • properly install all drivers in the correct sequence
  • have a suitable P/S
  • stick to a narrow choice of RAM mfgr/model
  • etc.
or does it require screwing around, and some things still don't work properly?

Does it live up to its overclocking hype?

I find it hard, because of all the posts, to get a clear idea. I expected this number of pioneering posts, since the NEO2 is relatively new.

I'm unable to get an idea of how many NEO2 mobo's have been purchased, and how many are happily in service.
Logged

jam

  • Guest
(No subject)
« Reply #1 on: 08-September-04, 23:53:28 »

well, I had to rma my first board;DOA!!! hopefully #2 will work
Logged

texan

  • Guest
(No subject)
« Reply #2 on: 09-September-04, 00:59:02 »

All I can say is that this is the first computer I ever attempted to build from scratch, and other than a corrrupt RAID driver floppy disk everything has worked perfectly.  I followed every instruction in the manual and had no problems setting anything up, and my system benchmarks exactly where it should.  Seems like a great product to me, the only thing I can gripe about is concerning board layout:  wedging both the ATX power connector, floppy and both IDE channel connectors into such a small space onboard makes cable management a real pain in the butt.  Wouldv'e been great if they'd at least moved one IDE channel to a lower spot on the board and spaced the other three connectors out some.
Logged

fatty

  • Guest
(No subject)
« Reply #3 on: 09-September-04, 02:24:39 »

Yeah if you are running stock speeds the mobo is ok the first few times you start the mobo it will hang but that seems to go after a while???
Logged

SAB

  • AM2 Pioneer
  • GENERAL
  • *****
  • Offline Offline
  • Posts: 5530
  • The streets are fields, that never die.
(No subject)
« Reply #4 on: 09-September-04, 03:56:29 »
  • Best Answer

  • Love my first Neo2, and can't wait to build another Neo2!!!!!
    Logged
    ASUS Crosshair V Formula Z
    AMD FX-8350
    G.Skill DDR3 ~ 16GB
    Western Digital 2 ~ 150GB Raptors
    ASUS 52X CD/RW
    ASUS CD/DVD/RW
    ASUS 2 ~ GTX770
    Logitech Z-560 4.1 Spkr. Sys.
    Logitech MX Pro Laser Mouse
    Windows7 Ultimate X64 Edition
    Linksys WMP55AG 811A/G Wireless Adapter
    Thermaltake 1050W PSU

    camelot

    • Guest
    (No subject)
    « Reply #5 on: 09-September-04, 06:33:52 »

    No problems here, running a nice 2.55Ghz OC while folding@home.
    Logged

    jamathe

    • Guest
    (No subject)
    « Reply #6 on: 09-September-04, 12:19:27 »

    I'm not an over-clocker, but the only problem I've had since last Saturday when I put it all together is the RAID won't work.  But seeing the post reply ahead of mine, maybe my RAID drivers on the floppy disk they provide is corrupted.
    Logged
    Pages: [1]   Go Up