Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: MSI GE70 Not Displaying OpenGL in Window  (Read 3081 times)

0 Members and 1 Guest are viewing this topic.

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
MSI GE70 Not Displaying OpenGL in Window
« on: 03-July-13, 15:18:30 »

So I just got this laptop, but it when running any game using OpenGL in a window, it is just white. I have the latest drivers. What can I do?
Logged

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 72610
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #1 on: 04-July-13, 05:08:49 »

exact NB model?
exact VGA drivers used?
exact games that you tried?
Logged

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #2 on: 08-July-13, 10:47:17 »

GE70 2OE-017US

9.18.13.1148 (uninstalled and reinstalled latest from the MSI website)

FTL (Faster than Light) is a game on Steam which does it, but I have several other programs running OpenGL that do it as well, and have not found an OpenGL program which does not. It definitely appears to be a universal OpenGL issue.

Edit: I also disabled the dedicated card and tried the integrated Intel HD4000. That did not work correctly either, but in a differnet way. It works fine fullscreened, but when windowed only shows one frame, and will update that one frame if you move/resize the window. No idea if its related or not.

I also called MSI tech support and they did not have an information on this happening and have not contacted me back yet.
Logged

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 72610
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #3 on: 08-July-13, 13:26:22 »

dont disable anything, this will cause a mess

restore OS to factory default and recheck
Logged

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #4 on: 08-July-13, 15:43:48 »

I don't think that should cause a mess. The laptop has 2 video cards. You can select either of them for any program, or force one on all programs. I just forced it to select the Intel HD 4000. I am a computer graphics programmer. This is a high end laptop. The settings are there to be used and a fairly straight forward.

I did restore the factory OS settings while completely reinstalling the driver and got the same result.
Logged

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 72610
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #5 on: 08-July-13, 15:47:25 »

sure you can switch between them, but not to disable it
if you disable onboard one, nothing will works.


can you tell [and give a link] to some of those OpenGL applications to try?
Logged

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #6 on: 08-July-13, 16:31:06 »

Here is a great one, the original angry birds demo is available at the bottom of the screen here:

http://download.angrybirds.com/

The original does not show anything at all, as I suspect it runs in a 'fake' full-screen mode by making a border-less window the size of the display. I also tried the newest game 'bad piggies' and interestingly that works even when windowed. They both have the same requirements, but they must be rendering differently.

SFML is the environment I use for programming, and its example programs are included in the free distribution (/examples/opengl/opengl.exe is one):

http://www.sfml-dev.org/download/sfml/2.0/

I have verified that the same program runs fine on other SFML users Windows 8 machines, so it is something specific to my model of or particular laptop.

Faster Than Light is another released title that shows the same issue:

http://store.steampowered.com/app/212680/
Logged

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 72610
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #7 on: 08-July-13, 16:50:21 »

i've tried 1st 2 and they runs fine.

noted they are using intel card, so its not related to the nvidia card.


can you check and install latest intel hd drivers from:
http://www.intel.com/p/en_US/support/detect
Logged

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #8 on: 08-July-13, 17:25:35 »

Updated the HD4600 driver from 9.18.10.3111 (version on MSI website) to 9.18.10.3165. No change when telling programs to use only HD4600, only 765M, or to choose for themselves.

You got the first 2 running on a GE70 2OE-017US?
Logged

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #9 on: 08-July-13, 17:32:56 »

UUUHHHHHGGGG!!!!!

I figured it out, well not the solution yet. THIS IS SO STUPID!

It is the high contrast theme in Windows 8!!!! WHAT THE HELL! The amount of time it wasted because for some reason it turns windowed OpenGL white is crazy.

MICROSOFT WHAT THE HELL

So now I have no way to customize the appearance without breaking OpenGL?!
Logged

darkhawk

  • Global Moderator
  • *****
  • Offline Offline
  • Posts: 11791
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #10 on: 08-July-13, 20:27:12 »

UUUHHHHHGGGG!!!!!

I figured it out, well not the solution yet. THIS IS SO STUPID!

It is the high contrast theme in Windows 8!!!! WHAT THE HELL! The amount of time it wasted because for some reason it turns windowed OpenGL white is crazy.

MICROSOFT WHAT THE HELL

So now I have no way to customize the appearance without breaking OpenGL?!

Wow....really? That's terrible. I had no idea. I was trying this out on my GT70 and yeah, it all worked just fine in Windows 8, but I'm still using the default theme (as bad as it is). Well, that explains alot.
Logged
Name            Motherboard                                CPU                                              RAM                             GPU                                            
System 1MSI GS73VR-6RFIntel i7 6700HQ16GB DDR4MSI GTX1060 6GB
ServerMSI X370 SLI PlusAMD Ryzen 5 1500X16GB DDR4MSI GTX 1070Ti Armor OC
System 3MSI Z390 GodlikeIntel i9 9900K32GB DDR4 @ 3600 MHz MSI RTX 2070 Gaming Z 8GB

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 72610
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #11 on: 09-July-13, 04:56:16 »

UUUHHHHHGGGG!!!!!

I figured it out, well not the solution yet. THIS IS SO STUPID!

It is the high contrast theme in Windows 8!!!! WHAT THE HELL! The amount of time it wasted because for some reason it turns windowed OpenGL white is crazy.

MICROSOFT WHAT THE HELL

So now I have no way to customize the appearance without breaking OpenGL?!

bla, what do you mean?
if you apply some specified theme, this removes your GPU OpenGL ability :confused2: :bonk:
 :shocked:
Logged

AcumenTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 9
Re: MSI GE70 Not Displaying OpenGL in Window
« Reply #12 on: 09-July-13, 09:10:44 »

What seems to be happening, is that when you use one of the high contrast themes, it shuts off the DWM (desktop window manager) that the regular themes use. When DWM is off, windows running OpenGL are not be rendered to the desktop.

The reason I use the high contrast theme, is because it lets you customize your windows colors and I have some very specific settings I like to use. I have not been able to find any workaround, but I am not the only person who uses these themes and it seems that it really needs to be fixed on Microsoft's end.

It should be easy to confirm this just by switching to a high contrast theme.
Logged
Pages: [1]   Go Up